/e/OS Installation: Signature verification failed (error: 21)


I‘m relativly new to the topic of custom ROMs.
I recently bought a second-hand Galaxy S10 with the stock ROM.
I tried to flash /e/OS to it but ran in to the following issue:

I followed the installaiton instructions, on an openSUSE computer, given here:
At the penultimate step “Install/e/OS” the installation process was cancelled and on my computer “Total xfer: 1.00x” was displayed, but the S10 showed:

„E: failed to verify whole-file signature
Update package verification took 78.4 s (result 1)
E: Signature verification failed
E: error: 21

Install from ADB completed with status 2.
Installation aborted.“

and the installation wasn‘t succesful.

I tried using different USB-Cables and -Ports, also restarting my computer and the local ADB-Server.
I also read an articel about this Problem in the Forum:

But this Articel ended with the solution „I edited the times 8 days back“ :confused:
Not really helpful, it didn‘t worked.

I hope someone can help me, cause unfortunately I‘m no expert.
So please submit some solutions or correct me if I‘m wrong on something or if you need further Information on my device.


Name: Samsung Galaxy S10
Model: SM-G973F/DS
Recovery Sotware: /e/OS recovery tool
ROM: stock Samsung Android

So flashing is done.

[HOWTO] an Unified Install Guide Project for /e/ - #4 by piero

This topic was automatically closed after 90 days. New replies are no longer allowed.