Easy Installer failed - Fairphone 3 blocked on fastboot mode

Hello there!

My FP3+ phone is stuck on fastboot mode after installing /e/ with the Easy Installer on Windows 10.

Background: Everything went well during the installation with Easy Installer. During the last step Easy Installer informed me that /e/ was successfully installed on my phone, and that I had to restart it by pressing the Volume Down key to lock the bootloader. So I did it.

But when my phone restarted, it displayed an error message “Your device is corrupt. It can’t be trusted and will not boot.”

  • I can’t start the phone.
  • I can’t launch the recovery mode.
  • The phone isn’t recognized anymore by ADB on the computer.

I only manage to unlock something using the command “fastboot flashing unlock” while reading other threads with similar issues.

  • I tried to press the power button for 30 seconds, but it still reboots on fastboot mode after 5 seconds.
  • I tried to press POWER + Volume Down keys, but it still reboots on fastboot mode
  • I tried to press POWER + Volume Up key, but it still reboots on fastboot mode
  • I tried to use the “fastboot reboot bootloader” command, but it still reboot on fastboot mode and nothing changes.
  • I tried to boot an image using the “fastboot boot twrp.img” command but it failed and notifies “FAILED (remote: ‘unknown reason’)”
  • I tried to flash it using the “fastboot flash twrp.img” command but it failed and notifies "unknown partition ‘twrp.img’ " "cannot determine image filename for ‘twrp.img’
  • I tried to find it on the computer to erase all the datas and copy the backup, but there’s nothing.

I don’t understand why it ended up like this! And I don’t know how to fix this neither.
I’ve read on other threads that it means my phone is “bricked”.
So if someone is kind enough to help me… I thank you.

Can you provide the log file of the installer? See Howto troubleshoot issues with the easy-installer for some hints how to do that. Maybe it contains some information on what went wrong.

In order to rescue your phone I’d try to install the stock ROM again, see

I tried to generate a link but apparently the “document exceeds maximum length”.

Do you already have an /e/ account? In that case you could create a ZIP file containing the log, upload it to your /e/ account and share the link here.

I uploaded the log file here : https://filebin.net/bd99z34lm9p6royv
Sorry to be so unaware about how to use the /e/ account, I couldn’t find where to upload it.

Does it suit you or should I search for uploading on my /e/ account?

That filebin works, so no need to upload to your /e/ account.

I’ll have a look if it contains something useful.

Edit: there is nothing suspicious in the log…

What you can try before reverting to the stock ROM:

Execute
fastboot getvar current-slot
That should result in either “a” or “b”.

If it was a:
fastboot --set-active=b

if it was b:
fastboot --set-active=a

Then try to boot again. The installer flashes both slots, so maybe if one doesn’t work the other will.

1 Like

Doesn’t work. I cheked if typed it wrong, but doesn’t seem so.
“current-slot: INVALID
Finished. Total time: 0.016s”

I tried it again a the Total time indicates 0.000s this time.

Edit:
So I tried to select slot A, then slot B, but it doesn’t. However, since I selected the slots, the command “fastboot getvar current-slot” works now. So now it says “current -slot: a”
Probably it was not on any slot before?

Maybe it’s best to try and get stock ROM running again. That would hopefully result in a working system again, even if it is not /e/ yet.

How do I get stock ROM running again?
I agree on the fact that at least it will work again even if it isn’t /e/…!

I tried “fastboot boot twrp.img” to put my backup but doesn’t work.
And when I tried “fastboot flash recovery twrp.img” it says “partition table doesn’t exist”

That’s why you usually just fastboot boot TWRP.


1 Like

Head’s up: adb and fastboot can be downloaded as a part of https://developer.android.com/studio/releases/platform-tools

To setup TWRP you need to do the following:

# Download TWRP image from
https://twrp.me/fairphone/fairphone3.html

# Push TWRP image to the device;
adb push twrp.img /sdcard/TWRP

# Boot into TWRP
fastboot boot twrp-3.5.0_9-0-FP3.img

# Install TWRP in recovery by
Once booted, navigate to the Advanced > Install Recovery Ramdisk option. This will ask you to select the image you want to install TWRP from. Select the TWRP image you just downloaded and copied into device storage. Proceed to install this image.

This should help wrap-up the recovery process

So far, so https://twrp.me/fairphone/fairphone3.html … but what about “You also need to use the ‘Fix Recovery Bootloop’ option present in the same Advanced Tab. Use that option after you have installed the recovery ramdisk successfully to avoid boot loops happening from installing TWRP Permanently.”?

And then you have installed TWRP into the boot image.
And then /e/ gets an OTA update.
And then TWRP is gone, because /e/ restores its own boot image with every OTA update.

Or not?

Thanks for pointing that, @AnotherElk. Didn’t have to do it on my end when setting up the /e/ test build here.

Correct. /e/ gets an OTA update and TWRP is gone is what I understand as well.

1 Like

Here are some updates :

1.)We had no other solution than erasing the phone and reinstall manually Fairphone Android as recommended here.

Unfortunately, the IMEI codes disappeared from the info about the phone.
The OEM unlocking was bugging: when I tried to toggle it I was redirected to the previous menu or completely ejected from the settings menu (the menu shut down, showing a black screen with a little white window notifying that the settings will “stop systematically”. I could click on “info” or “shut down” but “info” didn’t work)

2.) We manually install /e/ successfully on the phone. At the end I had the error message about the corrupted device but then it reboot on /e/ for the very first time.

Unfortunately the IMEI are still missing. Even when I dial the *#06#. About this, I should have more info on Monday.

Otherwise, everything seems to work for now. But I will test it this week-end and give a feedback later.

Thank you all for your help!

Hello !
Thank you for your post that gives me hope !
I just wonder what you mean by “erasing the phone” ? I will try to proceed as you did, fingers crossed.