Easy Installer failed with Pixel 5

I have no idea where to ask for help, sorry if this is in the wrong place. It is NOT easy to figure out for me.
I bought a Pixel 5 to try the easy installer. It stops at the Bootloader screen. It does reboot the phone into Fastboot mode. It says LOCKED in green on the screen. If course I selected all the buttons it ask to inside of the settings including OEM Unlock. I tried to do the command line fastboot flashing unlock from the adb folder but that just says waiting for a device. What next ? I am disabled so maybe I am just not smart enough to degoogle.

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

hi,
could you try another cable

@piero Yes, the cable is working as it talks to the phone just fine. It sees it and reboots it into the fastboot bootloader mode. Thank you for trying to help.

At this point you have abandoned Easy Installer?

Are you using Windows?

If yes to both this may be a drivers issue – try opening a Device manager window. Does the phone turn into a “:warning: Problem device” when booted into fastboot mode.

If yes Windows update at this point should find the required “combination” driver.

Yes, using Windows 10. It sees the phone fine. I can bring it up in Windows Explorer and it shows as a hard drive. No problem. I will check the device manager to see if it shows the yellow triangle.
I want to use the easy installer as I am not very good with this phone stuff.

No yellow triangle. Windows shows the device as a Pixel 5. I can click on it and access the hard drive. No errors at all. Also, I just tried to install with my Ubuntu machine and it stops at the very same point. So is it the phone ?

If Easy Installer starts but leaves the phone locked, this can be hard to debug. However you could try to show us the log.

Please can you confirm that you did this Windows test when the phone is booted into fastboot mode.

@aibd YES, you are correct. it DOES show the yellow triangle once it reboots into Fastboot Mode. How can I fix that ???

The Easy Installer log, this one run on Linux, does not detect the phone. No reason is given. Incidentally the command used to detect the phone is
adb devices -l

The log tells us you are in USA; could your phone possibly be locked by your carrier? Please could try to give us the full details of the phone and model so that we can try to rule that out.

Were you sure to add no Google account to the phone? Has the phone any data on it? Did you Factory reset before starting Easy Installer?


Note that you do this with the phone in fastboot mode. If you are unfamiliar with this, here it is described for a different device https://doc.e.foundation/pages/install_easy_installer/win_fp4.html.


The manual install instructions https://doc.e.foundation/devices/redfin/install. If you had to follow this path would you prefer to use Windows or Ubuntu?

Before trying to unlock the phone I suggest that you try to demonstrate some control of the phone with the commands

adb devices
adb devices -l

and with the phone in Fastboot mode

fastboot devices

Is the phone fully updated? What version of Android is it running?

You found the problem. The Pixel 5 would be found by Windows as long as it was NOT in fastboot. Then it gave the error. I had to install a new USB driver that actually didnt say it was for the Pixel, it was like a generic driver. Then it saw the Pixel 5 in fastboot. After that, everything went smooth. Sorry for crossing the Linux and Windows. I have been working on this for 12 hours and I was trying everything. THANK YOU very very very much for helping me. Yes, I am in the US state of Missouri. I am guessing there are not alot of US users for this OS. I just cant stand Google anymore and had to do something. I have probably tried 3 or 4 times before to load a different OS on Samsungs and Motorola but could never get it to work. The Pixel 5 is up and running and loaded my Proton apps fine. It sees my US Mobile service which runs on Verizon towers. No problem at all. Speeds download at 150mb. I am beyond thrilled to be off Google.

3 Likes

Android 12 on the Pixel 5.