Easy Installer + Gigaset GS290 not working correctly - wifi / wlan not working

I wanted to install /e/ OS with the Easy Installer on a Gigaset GS290. Everything works fine at first, but after the installation, wifi no longer works on the device. So it is no longer of any use to anyone. Is there a solution for this?

Ich wollte /e/ OS mit dem Easy Installer auf ein Gigaset GS290 bringen. Das funktioniert erst mal alles gut, nur es geht nach der Installation kein WIFI / WLAN mehr auf dem Gerät. Das Gerät nutzt also keinem Menschen mehr etwas. Gibt es dafür eine Lösung?

This is a known issue. Let me just first point you to Gigaset - GS290 - gs290 - Documentation Suggestions.

I will not add distracting information as I do not have the device. The following post from the above thread probably summarises the issue.

Unfortunately, this does not help me with the current state of affairs in July 2022. Is there a detailed guide somewhere? I don’t think the Easy Installer has been further developed or adapted for a long time, what a pity …

Maybe resetting the device or reinstalling it from the command line will help.

I also think that the Easy Installer should support the Gigasett GS290 better, however, as far as I know, it is still in beta.

The development of Easy Installer doesn’t seem to have stopped though, as new devices were added just the other day and a version for macOS was released.

Hi Sudeki,

I have still the same phone and after installing with the e-installer i got the same problem i thought.
When you go to the settings on your phone and then mobile networks…you can deselect the option calling at 4G. But i do not know if this is the best choice. For me it worked, and when i put this option on, i lost my Wifi. The GS290 is not so reaally expensive, but i have some issues with an echo when i am calling and a black screen. also the camera is worthless for me. You can make pictures, but its not so good en when you go filming you will see what i mean. Its a good phone for testing if eOS is something for you, but its not a great phone. For the rest i am really happy with eOS.

You feel understandably, that because I specifically linked a post dated January 2021 there must have been a workaround. If so it is not widely published. Many users did follow the guidance linked from that thread.

I would suggest that the problem lies deeper than Easy Installer, probably.

I wonder if you found a solution?

I realise that it is a lot of reading and research, perhaps you could pick on one of the [solved] threads concerning #gs290 Wifi not working and ask there?

Notice how the problem seems to present differently in the stable and dev builds (explained Different Build Types); Having used Easy Installer your build is likely stable. This can be confirmed from

Settings > About phone > Android version > /e/ version. If you should want to share your build, long press on /e/ version to copy to clipboard.

Good luck

Now I have found a solution: I did the system update to e-os 1.2 via mobile data, after that wifi worked, but bluetooth didn’t … :frowning:
This was solved by resetting the phone to the factory settings. It’s a bit awkward, but it works! My request to the developers: please update the Easy Installer to a version that works properly.