eCloud possible issues with syncing content - please test

Hi guys, we have pushed an /e/OS update a few days ago (dev only, not stable yet).
Some of use are having issues with eDrive, despite the tests shew no issues.

We would be grateful if you could test this and report any issue you encounter.

How to test?

  • make sure you are using a “dev” /e/OS ROM (e.g. NOT on a preinstalled /e/-smartphone like the /e/-FP3 or the /e/-Galaxy…)
  • ensure that you have an /e/ account configured in Settings->User and accounts (otherwise, check this)
  • check that Pictures & Video sync is enabled in Settings->User and accounts->>account sync
  • upgrade to the latest available /e/OS version 0.11-20200829xxxx using OTA update (Nougat: Settings-> About phone->System updates / Oreo: Settings->System->About->System Updates / Pie: Settings->System->Update manager)
  • take a couple pictures, record a short video, delete an older picture
  • switch your screen off
  • one hour later connect to
  • in the “Activity tab” check which content has been sychronized during the past hour
  • check in your pictures that you can retrieve the picture and video you have taken earlier
  • report us here if it worked/if it didn’t work


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Still does not work - as of today.

I encountered some issues already with the last /e/-p-0.09 dev version from July.
I opened an issue in the issue tracker earlier this week (

Since then: I completely reinstalled my phone with a fresh /e/-p-0.10.
First, syncing seemed to work. New pics where uploaded.
But later when I deleted some older images on the phone, the they pics remained in the /e/cloud. This was three days ago. As of today, they are still not deleted in the cloud.

Yesterday, I updated to /e/-p-0.11.
I did a new test with pics taken today with my phone.
After 1h they were not uploaded to the cloud - and the pics that I deleted from my phone three days ago are still present in the cloud.
The test of today I conducted with the standard camera app as well as with GCam.

According to my device, today there was no syncing activity conducted at all.

I am experiencing this issue since upgrading the herolte device to 0.11-2020082970471 (Android version 7.1.2).

The last successful photo sync was the last photo taken before the upgrade on 2020-08-31, and those taken since have not sync’d.

Attempting a manual “Sync now” in the “Settings -> Accounts -> /e/ -> (specific account)” menu shows that “Pictures and videos” attempts to sync (along with the Address boooks, Calendar, Mail, etc), but the photos do not show up in the edrive, and there is no indication of the attempt to sync on

@ralxx the device you are using is the Poco F1 right?
Just wanted to check if it is device specific as @keverets is reporting an issue on the herolte

Little update from my side.

  • Pics that I had taken yesterday, were finally uploaded in the cloud. It just took around 5 hrs. Pictures that I have taken today are not uploaded yet. I am wondering if it could br possible that the pic/video and mail sync is only executed every 12 hours (at 7 and 19h)?
  • The pictures that I deleted some days ago on my device are still present in the cloud.
  • I tried manually to sync pics, but pics are not synced with cloud neither.


  • Yes, my device is Poco F1/Beryllium
  • Device specific? Likely as there are only few others who reported.

I have the same issue. I’ve a OnePlus 3 but it has the UNOFFICIAL rom. It takes many hours before uploading photo or video. Though calendar and email are working as expected and both sync fast.

Would you please report the state of this?

settings --> apps --> eDrive --> permissions -->  storage

Is it enabled or disabled?
If disabled, please:

  • enable it
  • test again and report if it fixes the synchronization issue

settings --> apps --> there is no eDrive app on my phone.

Update @ tcecyk: Thanks for the explanation. On my OnePlus 3 eDrive storage is enabled. Which makes sense as it uploads photo and video it only takes several hours. Version beta-1-build-o-20-06-05T2120

in the upper right when all (user) apps are listed, there’s the option to show all system apps/services. There you can find “/e/ Drive” - it should be translated to your locale

There are two “/e/ Drive” listed (one in the main profile and the other in the Shelter/work profile), and both have Storage permissions enabled.

Version beta-1-build-n-20-08-13T1523 (for both)

S7, android 8.1, /e/ O.11 and storage permission for edrive is active…

But doesn’t work for me.

Is this issue recent …starting in the past week ?

I am using a slight earlier version

Pictures and Videos are syncing for me.
There is a problem with the Contacts sync recently, which only started 2 days ago.


Response{protocol=http/1.1, code=500, message=Internal Server Error, url=}

500 Internal Server Error

500 Internal Server Error


I have no evidence, but the “camera” folder is empty…and my old pictures are still in the “opencamera” folder. So i think the problem exist since the update to oreo

I tested today and it works!
Thanks /e/team

1 Like

Hi @Manoj

Just for your information and to answer your question, I have the same issue : syncing photos stopped working.
Last photos synced in my OpenCamera folder on is dated 10th September 2020.

I haven’t participated in the test as posted by Gael in this discussion.
My version is still 20200810 67149 stable-star2lte

Also, I checked the storage permission on the eDrive app, all good.

I hope this helps.
I will look out for the forum to see if anything has been identified.

All the best


Still not working after update to 0.12-2020100176273 on herolte.

/e/ Drive is still at version beta-1-build-n-20-08-13T1523

Are you still having this issue with the sync. If yes pl can you raise an issue on Gitlab if not already done.

@keverts - there were no commits to the app since august, the version string is thus up to date

As there already exists a gitlab issue backlog#1772 I think it is helpful if affected persons continue to post their logs. To filter to relevant log components and Errors use

adb logcat chatty ActivityManager ScannerJob ObserverService OperationManagerService DbHelper *:E

(or *:S to silent everything else)

I’m on a 0.12-pie dev and only see successful syncs after a reboot, as @rhunault noted.

Flipping the sync button on/off for “Pictures and videos” and activating “Sync now” in the Account settings doesn’t seem to overwrite the half-hour file sync interval and has no consequence (either in logcat or the accesslogs of a remote instance. You’d see PUT requests by the eDrive user-agent then). This would offer another user workaround to reboots.

I’m a new /e/ user, with e-0.13-o-2020120889191-dev-starlte installed on a Galaxy S9. I noticed that out of 7 photos, only 2 are showing on the cloud ( I tried the test above from @GaelDuval but nothing changed.

Is this still an issue?