Email app - what happened to flagging spam?

I can no longer see an option to flag / refile emails as spam in the app, since updating to 1.91.1 T.

What happened to this feature and will it return?


I am checking on a OnePlus 7T.
When you open a mail >> three dot menu right >> refile >> spam

Does not exist on my phone. I can only:

Sort by…
Select all
Mark all as read

Or - if selecting a message:

Add star
Select all

Motorola One 5G Ace on 1.91.1 T

I checked K-9 and it has the spam options visible.

You can move them manually in spam folder: the IMAP server will catch that and call the exact same program as flagging email as spam.

1 Like

There is no ‘Move’ option in the stock email app either. See above…the only other function available is swiping right on an individual email to delete it.

Curious as to why this problem exists in the first place. Is it my device? It’s not the first time a stock app has had bugs/problems, but the email app is the main cornerstone for my purposes. I’m getting a bit frustrated with having to use workarounds every time these things break.

Kinda strange … Could you please send us a screenshot of the 3-dot menu at upper right, with both messages list and any message displayed?

You have to go into the Settings of the Mail app, General Settings, then Display (“Affichage” in french, don’t know about the english version), then Visible actions in emails (“Actions visibles dans les courriels” in french). Then you can select the actions you want to have in the three dots menu, and enable spam flagging.

@MaMaTT88 Sorry, that does nothing for me.

Do you manage to reach this screen and have the spam option enabled?

Yes, and it didn’t change anything.

For me it changes the three dot choices when I open an email (your second screenshot). Weird that for you nothing happens. Are you also in version 6.711 of the Mail app?

Same version 6.711, yes.

Could you produce the same screenshot than me, just to be sure we are on the same page?

I meant a screnshot similar to mine, with the visible actions on emails in the Display setting.

Going to Settings / Account / Folders, do you have the correct folders set up?

Also, from Folders management screen in hamburger menu, is your Spam folder “1st Class”?

I don’t even see those options.

Weirder and weirder!
When you go to on a PC, what do you see in the email section? Do you have Spam folder there?
(Assuming we’re talking about your murena emails)