Error building unofficial Pie ROM for Moto G7 Plus (lake)

FYI, LOS 16.0 isn’t officially supported for this device (but sources are on their github).

So it might be normal if everything isn’t ready to be built. Though I don’t know why it doesn’t work exactly.

In file it has
PRODUCT_NAME := lineage_lake

Ok, than check if this is available

In LOS16 sources it’s missing

If it’s not in the Lineage sources, how will Docker know where to pull it from? Do I need to find a repo that does have it, and write some magic in a roomservice.xml file? Or…?

You will have to use a roomservice.xml and put it in a “local_manifests” directory which has to be next to “src”, “logs”, “zips”.

Then in docker you will have to add the line

(I think)

The roomservice will need at least : vendor source, device source and kernel source.

Thanks @harvey186 @Anonyme. I was only building this in response to this thread, not for my own use, and because I have some unused credit with OVH. According to it is supported by Lineage so I thought it would be straight forward (the ROM for G7 river built with no problems).
I don’t think I want to spend the time tracking down the necessary files and creating the manifests so I will stop trying :slight_smile:
Thanks again for your help .

In in your kernel sources is a defconfig. Rename it it ‘lineageos_lake_defconfig’ and try once more.

Yes but only on Android 10, see here.

@Anonyme all los16 sources are available in LOS git. So no need for roomservice.

OK, one file is missing in kernel sources, but after renaming as I have written it should work

I’ll give that a try sometime over the weekend

And you mentioned it in your list of lineage supported devices but I didn’t spot it there either :slight_smile:

device and kernel seems available in lineage repo for 16.0 branch and it’s downloaded without issues according to your logs
I cant find vendor on the other hand, need to extract it from the latest lineage 16.0 that could be found for that device i guess

Vendor blobs are available on github

Lake Pie manifest is already in @harvey186’s repo. I’ve build it, shared with user but did not hear anything back, so don’t know if it works. But build went well.

1 Like

@andrelam Is that a recent build, and is it publicly available? If so, there’s no point me building another.

No, I deleted it, needed space. @petefoth

I tried a couple of times[1] but got kernel build errors each time. I am giving up on this build and filing it under ‘Unofficial builds that didn’t work for me’. Thanks again for your help. And I’m still open to suggestions for devices[2] that could do with a new unofficial build.

  1. First time I renamed file /kernel/motorola/msm8998/arch/arm64/configs/defconfig. Second time renamed file `sdm660_defconfig
  2. Preferably ones supported by LOS :slight_smile:

This file is indeed missing from LOS repositories for lake.

Have you tried with the manifest andrelam mentioned above ?
This file is there :

Thank you. If the weather turns bad enough for me to spend time on ROM building, I may gve this a try :slight_smile:

No issues to build it for me with this in the file .repo/local_manifests/roomservice_lake_PIE.xml :

<?xml version="1.0" encoding="UTF-8"?>
    <project name="Jleeblanch/android_device_motorola_lake" path="device/motorola/lake" remote="github" revision="lineage-16.0" />
    <project name="LineageOS/android_device_motorola_sdm660-common" path="device/motorola/sdm660-common" remote="github" revision="lineage-16.0" />
    <project name="Jleeblanch/android_vendor_motorola" path="vendor/motorola" remote="github" revision="lineage-16.0" />
    <project name="Jleeblanch/kernel_motorola_sdm660" path="kernel/motorola/msm8998" remote="github" revision="lineage-16.0" />
    <project name="LineageOS/android_packages_resources_devicesettings" path="packages/resources/devicesettings" remote="github" revision="lineage-16.0" />
    <project name="LineageOS/android_external_bson" path="external/bson" remote="github" revision="lineage-16.0" />
    <project name="LineageOS/android_system_qcom" path="system/qcom" remote="github" revision="lineage-16.0" />