Error during adb sideload on FP2 - Zip signature verification


I am trying to install /e/ on my FP2. I’ve followed the instructions but I get an error on the last step “Sideload the /e/ .zip package”.

The command adb sideload initiates and the transfer starts but it systematically fails around 50%.

The output of the terminal is Total xfer: 1.00x.
The output on the device is Zip signature verification failed.

I have check the settings of the TWP and the zip signature verification option is unchecked.

I’ve used to following TWP image: twrp-3.2.3-0-FP2.img

Any idea what could be the problem?


Figured it out. I used a different version of TWP: twrp-3.2.2-0-FP2.img

The Zip signature verification did not happen and I was able to boot /e/.

1 Like

Usualy happens with an outdated version of TWR recovery.

Try reflashing twrp-3.2.3-0-FP2.img

1 Like

Hello, same issue for me.

I try to install these versions :

I tried to use the v3.3.0 of TWRP, but it doesn’t work neither.
Any advise ?

Did you even have problems installing TWRP itself out only the /e/ os?
Did you try with twrp-3.2.3 too?
If you have an SD card you can also save /e/ zip to the SD card and install it directly via TWRP “install” function without adb sideload. Did you try this?

The problem occurs during the signature verification.
I’ll try to copy it in my SD card instead of use adb sideload, and let you know. Thx.

You may try to untick zip signature verification option in TWRP installation.
And you also might try to make sure that downloaded files are not corrupt.

Ok, the transfer via sideload fail at ~45%. I didn’t notice that.

I tried to upload the zip on my SD Card and use the TWRP “install”, but I get the “Zip signature verification failed” message (even unticking zip verification option).
I downloaded several times the zip. I’ll try to check the signature via pgp.

Sorry, for repeating the question, but there was yet no answer about if you have tried after flashing twrp-3.2.3 first?

I tried tonight with many versions of twrp (3.3.1, 3.3.0, 3.2.3 and 3.2.2) and still have the same issue.
The signature of /le/ image downloaded on my computer (latest is valid when I compare the MD5, but twrp say it is not.

The only thing I don’t do between each try is to format data, cause if I do I lose the image on my SD card.
I just Wipe Cache and Dalvik / ART Cache.

Also, when I start to wipe, I got this message in the console Unable to find partition for path '/system', just before the cache clean.

Might it be that above the message you mention (signature error) there is another message saying something like that it’s not installing e-06-n… because it’s expecting FP2 device but found . device? I had this when trying to install this zip on a completely factory reset device. I had to install FPOS first and then I could install…

Ok thank you very much for your support.
Do you have some link about FPOS ?

Here the log file of my last try, but I didn’t find any usefull information in it.

You may have a look here:

In the log I also didn’t find a lot of useful information.
I’m just surprised to see that it’s “unable to mount /external_sd”. You said you have an sdcard, haven’t you?

I installed the Fairphone OS before restart the /e/ install but no success.
Same message as before.

About the SD Card, it seems that I don’t have any, it’s just internal storage.
(I was pretty sure I had a SD card but I just opened my celllphone and the answer is no x )

I stop try by now, since it’s quite annoying to have a phone without any applications, contacts, email, …
Thank you for your time btw !

1 Like

at first I had the same error message ‘zip signature verification’ failed with the latest version of /e/OS ( )
My TWRP version was the one pre-installed on the FP2 : version 3.1.1-0.
Following what I read here I flashed the lastest TWRP version for the FP2 : version 3.3.1-1.
Then I could install /e/OS without errors.

However, for the record I had a lot of trouble having adb recognize my device.
Should this happen to you, what follows may help :

At first in the Fairphone Open OS (that was installed), I activated the USB debug mode.
This was not enough, I had to reboot into the OS to authorize my computer.
After my first unsuccessful attempt with sideloading, when trying to flash TWRP my device was again not recognized.
From trial and error I eventually found this solution :
I had to type on my computer :
adb kill-server
adb devices (will start the adb daemon again)
adb devices
This was not enough I had also to force reboot of the phone pressing the power button for 15 seconds.
Even after the successful installation of TWRP my device was again not recognized. I has to do the sequence again.
In the end after successful sideloading of /e/OS, when I rebooted from TWRP it said “are you sure ? No OS installed !” I did it nonetheless and /e/OS launched after some stressful dozens of seconds !
I am happy I was able to start /e/OS but was a stressful experience ! :scream:

Zip signature is based on certificates, not checksums.
As non-vendor builds are often not properly signed, you can ignore it.
But you should always check zip file against md5/sha1 checksums !

Btw, signatures check should be mandatory when installing an application package (.apk) …

I guess zip certificates are checked using root certificates stored in phone or TWRP, and therefore they are static.
So developers would have to buy a certificate from one of the root or intermediate authorities to get a properly signed zip …

I have the same problem here what I have done so far:

  • flashed the latest twrp (how do I verify the version of trwp after boot)
  • rebooted into recovery mode
  • sideloaded tha ltest zip-file.

Then it fails with verification error after having transferred about 40%. The instruction page mentioned to wipe out system but I can’t find such an option (only mount system partition but that seems to do nothing).

Any hint would be appreciated.

Just to make sure … You recently posted that you bought a phone and wanted to make use of the current earphone promotion … this would mean you bought a Fairphone 3.

This topic here is about the Fairphone 2. If you are sure you are doing this to a Fairphone 2 :wink:

Please follow steps 1. to 4. of this guide to install TWRP and wipe the phone, just don’t reboot at the end like the guide suggests, but from TWRP’s main menu do Advanced - ADB Sideload and try to sideload the /e/ install file again.

1 Like

Thanks I’ll try that, sorry for confusion, yes I bought a ne FP3 with /e/ preinstallerd and now I want to install /e/ on my old FP2 also :slight_smile:

I was now able to install, it seems the problem was that I was not able to boot the new bootloader successfully, but with the mentioned guid it works like a charm!

1 Like