Error while installing /e/ on sony Xperia XA2


I just bought an Xperia XA2 phone so that I could install /e/ on it.

I followed all the instructions here up untill step 8. of “Installing /e/ from custom recovery”

The problem is that during the step where I send the zip file to the phone everything stopped and the terminal told me it was terminated without error.

Now my phone can’t turn on, and when I do:
fastboot boot twrp-3.3.1-1-pioneer.img
it tells me: FAILED (remote: ‘Failed to load/authenticate boot image: Load Error’)

I just bought this phone, I really hope I can fix this, anybody knows what ? should do?

Did you unlock the bootloader?

yes I had. Now nothing works, I can’t even turn on the phone.

Power the phone off and connect an USB cable to the phone, but not yet in the PC. press and hold vol up, and connect the USB cable to the PC still holding vol up, blue led should be on now and you are in fastboot mode. Are you sure you did the bootloader unlocking right? Do it again and post screenshot here pls.

So the sony companion system tells me I can’t recover with there software because the the bootloader is unlocked.

I was able to launch twrp to make a backup and launch installation of /e/ once. then it stoppoed working.

I did the steps you told, blue led is on, and here is what I get:

Ok, what happens when you try the unlock stuff again?

When the unlocking is done right and it still does not work, go here . I flashed my sony XA2 with it, but i forgot how it exactly works… What was original OS, Oreo or Pie?

The thing is that I can’t do anything anymore with my phone. the only signals I get is blue light for bootloader and green light for flashing, but otherwise it won’t turn on…

So I don’t understand how I can try tu unlock with the phone that can’t turn on.

I will read you link, thanks

Oreo I think, I guess I didn’t check which OS I had…

So now I checked ‘adb devices’ commend, and it doesn’t find my phone.

I think it might be because with twrp I formatted the system, and then when I tried to install the new one it didn’t work so my phone has nothing to boot to.

I mean this:
fastboot oem unlock 0x[insert your unlock code]
You can still access fast boot mode, (blue led)

fastboot oem unlock 0x[insert your unlock code]

Oh to that I get:

FAILED (remote: ‘Device already unlocked’)

Ok, try to restore your phone with Emma tool from Sony: here

I’ve been through the same thing before. Since I could still start TWRP Recovery and had the e-zip stored on the SD card, my inattentive actions were not a disaster.

You may be able to use Sony’s PC Companion software. Xperia™ Companion is available for Windows and Mac operating systems.

With the Sony software “PC Companion” you can perform a software repair or completely reinstall Xperia smartphones with a StockROM.

Ok, try to restore your phone with Emma tool from Sony: here

Okay I launched:

You may be able to use Sony’s PC Companion software. Xperia™ Companion is available for Windows and Mac operating systems.

Companion doesn’t work on unlocked phones…

Ok, you were on Pie. /e/ is based on Oreo. Please wait with flashing e again. I will test the instructions first.



Did you try to install the ROM from 26/09/2019 (
In my case it failed to update (OTA; I wrote it in Installation of ROM from 26/09/19 failed on XA2), therefore I am just wondering if there is something wrong with it

Yes it is indeed this one I tried to install.

Thank you, I am waiting.

Meanwhile there is some news, I have the visual aids on telling me that my phone turns on in a setting up mode, but it doesn’t seem to recognise my double taps and the phone doesn’t seem to answer the tactile screen. The screen itself just turns off and back on like this:

The on/off and volume buttons answer.

I’m going to check instructions tonight, so the emma recovery did not work fully?