Failed attempt at updating Android versions

Spent 5 hours and have a stock phone to show for it presently…
wow that was easy to revert to stock. Then the easy installer failed and bricked phone. Possibly because of a mismatch with versions?
Below is the saga-
after talking to @marcdw , learned there is an updated version of android but I wasn’t getting the notifications, see convo here:
read into how to update,
have to go back to stock, update, then redo eos, now w easy installer!
read into how to go back, found instructions here:

so simple, seriously 1 click “flash all” and it did it… took a couple tries and I was worried at it taking a long time at the oneplus “spinning balls of death” screen
from there, updated to android 11 OTA
again, took a while at the planetary death balls…
system update again to 12 (named 11xx apparently due to OnePlus’ old naming conventions
how many times to do this? One would think it would go straight to the latest version…
OnePlus offers manual updates here JIC:
Latest version is 11 though so did more OTA updates
next updated to android 12

Everything was good until here

tried to go back to eos now that Android was updated
easy installer failed
can boot to recovery but gets into loop
now tried manual install found here:
doesnt work, “the current image (boot/recovery) has been destroyed” error
phone unresponsive until I found a tip here:
started trying to use MSM tool, ran into some issues.
tip here got msm to start:
phone now boots into fastboot
attempted “flash all” from previous instructions, but bootloader now locked
reboot, wiped/erased w/ the onboard option
spinning planetary death balls…
Stock OS running!

Now will try to figure out how to install /e/ OS without a 5-hour brick…

interestingly, while on oxygen, phone indicates 5G is working, whereas on eos it does not.
Previously had read thats because the phone uses the european 5g frequency and not north america…

bricked again trying to “flash all” to downgrade.
used msm method from before to downgrade
worked; was able to use this to downgrade from 12 to 11

easy installer again
on android 11
already not working- dev mode enabled but not detected
instructions were circular after OEM unlock
easy installer wiped device and restarted it
rebooting in bootloader…
fail, restarted os
rebooting in bootloader
manually restarted in recovery
installation proceeds
“installation over”
do not see e logo, just recovery
try again
dead android cartoon
factory reset
e logo!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Wow, what an adventure! Hoping to avoid this when time comes to update my 7T to S or T. Praying for an OTA or official e/os procedure that is relatively easy.

I think its official… Just didnt work, ha!

Apologies for the stream of consciousness.
Eventually got it working.
I think issue resulted from having a higher version of Oxygen OS than /e/ OS
trying to install /e/ over the latest Oxygen didnt work but going down one step in Oxygen seemed to work

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.