Failure to text photos

This is on a Galaxy S9 running e-0.13-o-2020120889191-dev-starlte

When trying to attach a photo to a text with the stock text app, it fails immediately and I get the error ‘Failed to send. Tap to try again.’ The same error happens when taking a photo from within the text app. I tried a 2nd app (SMS Messenger) and it did not show any error, but my text messages w/ photos were not received on the other end.

Also, I checked with my carrier (T-Mobile USA), and they apparently have limits on file size/dimensions, but when I tried sending small files well under the limit I still had the same problems notied above.

Is this a known /e/ bug or a carrier issue? The APN settings check out for my carrier (I can send regular texts, make calls fine), but I haven’t verified my SMSC setting, because I can’t find it.

Some more info after talking with my carrier’s support (Ting). They basically have their scripted response when it comes to the APN settings below - nothing about the other APN settings.

My question - there are other settings in the APN that are not set to anything - should they be? Such as: proxy, port, username/password, server, MMSC, MMS proxy/port, authentication type, bearer, MVNO type, etc. ?

Name Ting Data
APN type* default,admin,fota,mms,supl,hipri,internet,dun
MCC 310
MNC 240
APN protocol IPv4 / IPv6
APN roaming protocol IPv4 / IPv6

Did you ever find a solution with Ting? I switched to them recently and have also been unable to send or receive MMS. Customer Service was unable to resolve it. I’m using the same APN settings as you listed, with the exception of “dun;” my APN won’t save with that in the field, and I’ve read online somewhere that it’s not used/useful for anything anymore.

No. If the carrier says to leave them blank, they should be blank. (Unless the carrier has alternate APN settings to try, other than the published settings.)

I had no problem whatsoever with MMS with my previous carrier. Looking through Reddit, it seems lots of people have issues with Ting MMS. I guess I’ll have to switch again.

Reset your network settings. Somebody at Ting said they can get ‘finicky’. It seemed to fix the problem for me.

CS rep and I went through every kind of troubleshooting option already (including resetting to the network), to no avail. I’m waiting for Tech Care to review the chat transcript to see if they have any other ideas.

That’s odd. You’re using T-Mobile network Ting and not the Verizon version right?

Yes, that’s correct.

I see online that this seems to be a common problem with Ting.

I just tested Mint Mobile, and the MMS issue is the same: no dice.

I have the samsung galaxy s9 too. I have had the same text+photo problem since I activated the phone. I tried to resolve it through t-mobile and it can’t be fixed. Because I work in real estate I need the ability to text photos on the spot. I cant dilly dally around with this kind of bullshit. /e/ needs to fix this shit. I have since reverted back to my motorola one fusion+ that runs like a sonic spinning top… bam bam its done! Only issue is its infested with google’s crap. I went through and privatized all the apps and settings as much as possible. Very disappointed in wasting my money on the /e/ samsung.

Sometimes I have trouble sending photos unless I’ve selected the “300k Compression” setting. I think this was a problem with QKSMS however as opposed to Mint Mobile.
Personally I think /e/ ought to look into a different texting app as I find this one to be a bit limited.

1 Like

I use Silence from F-Droid as my default SMS/MMS app. It was working fine with /e/OS when I was on an AT&T MVNO. My MMS problem only started when I switched to a T-mobile MVNO.

I tried /e/'s default Message app as well as Simple SMS Messenger from F-Droid, but MMS didn’t work on those either.

To be clear, I’m using a Sony that I installed /e/ on myself, not the /e/-sold Samsung.

By the way, when I moved the SIM to a non-/e/ Android, MMS worked on that one.

Yes I tried my SIM in two other Motorolas and MMS worked perfect. I then switched the SIM back to the /e/ samsung and the same “failed to send” was there. I will try the Silence app you mentioned to see if its the app itself that’s the problem.

This is very strange.

I turned on TrackerControl and set it to log traffic. Then with Silence messaging app I attempted to send an MMS (failed), followed by an SMS (successful).

Following the above, I tested a successful SMS with /e/'s Message app.

EDIT: I was mistaken. This log is showing my periodic email fetching.

But shouldn’t the messaging app actions (SMS/MMS) show up in the traffic log, too?

Other actions, like opening a browser, show in the log as expected. Phone calls, too.

OK, I’ve got it working now. See:

1 Like

Hi Folks - i am having the same issue with MMS, with the Galaxy S9+, with the following /e/ installed:

i have been through and confirmed every APN setting for MMS with Optus and still cant send or receive MMS images or contacts with the phone.
when i put the same SIM in a standard android device, it works without even having to change any settings.
one thing i noted, was that Optus required a MMS Protocol (for Android): WAP 2.0.
i could not see any settings for this in the APN for MMS.
refer: Support answers - Optus

How do we submit a bug to the developers?


Hi @Spyder welcome to the /e/ forum.

Here is how to Report an issue.

(Sometimes a new user will find it difficult to to register. If you cannot login after 2 attempts, please send a request for help to

I am not certain if this issue is perhaps related? MMS can't be sent and received without mobile data on /e/OS (MMS lost) (#2155) · Issues · e / Backlog · GitLab

I have a Teracube 2e. When I try to text photos, it shows “Sending” for a long time then disappears. The time is attached to the photo but the person on the other end doesn’t receive. I have submitted several requests to Customer Service…no joy.

I kept playing around with it and voila…discovered how to text photos!
In text mode, I tap the “+” sign in the lower left corner of the screen. The 3d selection down is “Attach a photo.” DONE! Sadly, the Help Desk was unable to respond and tell me this tidbit! They are still “working” on my issue with the phone’s failure to send Group Texts.

I started using Telegram for this reason. Not everyone uses or wants to install it though.