Fairphone 3 : Update

Need help:
Tried to change the booting partition from b to a but it puts :

Slot does not exist. supported slots are:

The command > getvar current-slot shows me that the current slot is b.

Is it necessary that the device state is unlocked?

Is there key combination for reset? So only thing what could have to wrong on my side is that I had some struggle going from corrupt system warning into Fastboot mode, because often power buttons just rebooter normal, so I have long pursuing volume down and power etc.

Keeping the power button pressed for about 15 seconds will force a reboot.
Keeping Volume + pressed while starting/rebooting the phone will boot the phone into recovery mode. A factory reset is an option there, but you would have to actively select and confirm it.
Keeping Volume - pressed while starting/rebooting the phone will boot the phone into Fastboot Mode. You would need to connect the phone to a computer and know what exactly to do then to delete user data with fastboot.

When something went wrong, I’ve seen the phone boot into a prompt which offered a factory reset as an option, but you would still need to actively choose or confirm to do that. This was also mentioned in the forum announcement about this update …

I don’t think a key combo would do a factory reset, this would be much too dangerous, there would always be somebody accidentally resetting their phones.
If a data loss without user interaction really happened I would rather think the update somehow did it, which obviously would be one of the worst issues imaginable, but I don’t have the retracted file to try to check this, and the announcement only said …

Please quote the error message with the exact command you ran before.

I have done this so far grafik

Can’t say that I’ve seen this result of the command until now.

One thought … Minimal ADB and Fastboot is popular, but not always up to date.
Please make sure you use the fastboot command from the current Android SDK platform tools.

1 Like

Thx it now has worked. My fastboot was outdated.


Hello, my FP3 OTA offers a new update. After the last disaster, with updating via OTA, I’m very careful, to download and install.
In the folder https://images.ecloud.global/dev/FP3/ are even two new updates visible: one 0.10-p-20201021… and one 0.12-p-20201003… The latter one is shown in the OTA notifier. What should I do?

I just checked myself and I did not see any update after the 20200828 (0.11) version. No idea why we do not see the same files. …

Did you check the link (see above) also? I think, the OTA notifications will be rolled out after a specific “schedule”. Maybe my device is earlier scheduled than yours.

Funny, I just checked by myselve and you are right: no updates offered anymore. Maybe they has been withdrawn again.

Hello. Is the release date for FP3 stable at the end of this month still true?

Android security patch level is at early August 2020.

Hello at my Phone (IMG-e-0.13-q-2020120789006-dev-FP3) I have security patch level 05. Nov. 2020. When can I expect an update?

Information on the current update can be found here: Week 03 : 2021: Development and Testing Updates

It was planned for last week but due to errors postponed.

Thank you very much the OTA update (IMG-e-0.14-q) went very well.

No buttons in dialogue windows after update 0.14 Q
After the latest update to 0.14-Q I noticed, that the buttons on dialogue windows disappeared.

. Example: file manager app, delete confirmation dialogue. I hope this is not a feature, announced in the release notes as “UI improvements”. Does anyone else has this problem?

foundation.e.drive Version beta-1-build-o-20-07-20T1010 crashes

…another problem after update. It’s not urgent because I don’t use /e/drive. But it’s a bit irritating…

@Manoj what is with a stable release for the FP3?

ok, the update just popped up.

The update went well?

Yes without problems. :slight_smile: