Fairphone - FP4 - FP4 - Documentation Suggestions

Hi everybody
I’m new to Fairphone and new to /e/. I’m excited and eager to get it going but have no real clue… :slight_smile:
I’m getting (like many) all the way to point 6 and then I’m stuck at 7… Where can I find this “a/b thing”? can you tell us where we can see that in recovery? I can’t find it…

It only answers fastboot: unknown option – set-active=a

EDIT: Solved. needed to download a newer fastboot version

EDIT 2: Thanks Fairphonehulk, after flashing again, changing the partition it works perfectly.


and I get: fastboot: error: Device does not support slots

So I just tried the install and after its done it one time boots the E logo and then gets back to the bootloader. After that it directly boots in to the boot loader.
I would like to create an issue but I’m not allow to create a git account for it and my forum login does not work.
Any ideas on both of those problems?

I followed this guide
And installed IMG-e-0.21-r-20220112156786-stable-FP4.zip
Which gives me the suspicion that its a beta because the version is 0.21 and not 0.20 like it should be but its marked as the stable release in the guide.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


I have the exact same problem, i tried to re-flash everything again in case i forgot one command line but it didn’t help. The phone boots directly to the bootloader.

Same problem here… :frowning:

For all with the bootloop
Had same problem
Changed active slot and then it booted
Active was b and changed to a

fastboot --set-active=a


fastboot --set-active=b

The current active can be seen in recovery mode


fastboot getvar current-slot :wink:


I realize this is off topic but I just want tot say;

This is by far the most helpful / awesome forum I ever attended.

Love this mentality. Experts & amateurs alike…


try reboot bootloader on your phone or another cable and dont use any docks or usb hubs in between

My experience:
as long as I work on a started FP4 with adb commands I can use my USB/c-to-USB/c cable.
But when I am in the bootloader and want to issue fastboot commands the cable does not work anymore.
I have to use another USB/a-to-USB/c cable.

So in summary:

  1. it is important to have the latest (or at least a new) version of adb and fastboot installed on the machine
  2. it is important to have a good USB cable
  3. in case of bootload, the active slot has to be changed

These are the only factors that have caused problems so far. If you consider or check all this, the installation should work without problems.


Hi everyone,
Thank you for your help so far. Using another computer, I managed to unlock everything. Now I’m struggling with flashing it. I’m doing the following:
I copy all the codes in step 3 of the flashing process. Then I click into my Windows Explorer window (browsing into it as suggested in step 2). Phone is in bootloader mode.
Then I open up my cmd window, paste all the codes and wait. Immediately, I get notices that there is no such file or directory.
What am I doing wrong?
Thanks a ton!

This would be great if people having problems (edit: or not) could post their adb and fastboot versions. This way we could narrow down which versions are working or not.

I just downloaded everything, so I guess it’s the newest version.

Even then, it might be usefull to troubleshoot future problems if the “newest” version is not the same anymore.

I also say this because version number may vary amongst Linux users. (For instance I use Debian which ships old software.)

1 Like

I see. I use Windows and haven’t been able to figure out the version number. If you can give me a hint, I’ll check again and will provide it gladly.

Did you browse into the directory in the command interface? When using a command interface use the drive name followed by a colon to change drives (d: for example) and cd to navigate (cd d:\program file for example)

1 Like

Hi Ole,
Thank you. Correct me if I’m wrong: I followed your advice and when I enter cd c:\Platform Tools\platform-tools, I end up in the same place as when entereing “cmd” in the address field of my windows explorer while being in this platform-tools folder. Right? I think I arrive both times in the same place.
What I realized now (after being back from a job): I re-started my FP into FastBoot Mode. Now, I cannot reach it via the command tool. I first need to boot the phone regularly, make sure USB-mode is established and the device seen and then I can restart it in FastBoot mode. Is this “normal”?
If so, I’ll give it a try later with your cd-command and will try again.
Is it correct, that I copy paste all command lines from my browser directly into my command tool?

Thank you very much!

1 Like

Sounds like you were in the right place all along then. I havn’t installed /e/ on my phone yet, still waiting for it to charge. Have you put the img files in the platform-tools folder or subfolders?

Tanks a lot! I think this really should be in the installation guide!