Fairphone - FP4 - FP4 - Documentation Suggestions

This did the trick. Did i miss it in the doc? You just have to enter this before locking the bootloader again at the end. Thanks FairphoneHulk!

no, this is defacto not mentioned in it


Okay, I tried it and it works :slight_smile: Although, I encountered some smaller issues:

  • you need to add the path to adb and fastboot as described here for convenience, since then you can just copy & paste all commands from the list in section " Installing /e/ using IMG or image file, item #3". However, after entering the proper path into your ~/.bashrc, I had to log out and back in.
  • as far as I see, the item “Your device requires a code …” in the “Requirements” section at the beginning is redundant and can be removed
  • in the section " Unlocking the bootloader", there should be a link to the site where getting developer options and OEM unlocking is explained (item #4)
  • mention in the same section that there might be automatically two consecutive reboots (I was surprised that the phone rebooted once again just after showing the setup page of the phone)

Thank you very much, you saved my day :slight_smile: It finally worked. Even though I had linked adb to work everywhere, it somehow didn’t. So I copied all the files into my adb folder and voilà. In the end I had to point to active slot b (Thanks @FairphoneHulk and @AnotherElk ). Now it seems to work. Thanks to everybody and good luck for all the others. Your description should definitely be part of the guide for beginners like me :slight_smile:


I noticed that in the image for the FP4 neither a secure ntp server is set nor a secure captive portal.

both outputs return 'null

adb shell 'settings get global captive_portal_https_url'
adb shell settings get global ntp_server

so i set pool.ntp.org as ntp server and kuketz as captive portal.

adb shell settings put global ntp_server de.pool.ntp.org
adb shell 'settings put global captive_portal_http_url "http://captiveportal.kuketz.de"'
adb shell 'settings put global captive_portal_https_url "https://captiveportal.kuketz.de"'
adb shell 'settings put global captive_portal_fallback_url "http://connectivity.ecloud.global"'
adb shell 'settings put global captive_portal_other_fallback_urls "http://connectivity.ecloud.global"'

I am surprised that nothing is set by default.


No reaction!?

From e.foundation website

  • Connectivity checks do not use Google servers
  • We do not use Google’s Network Time Protocol servers

OK. That’s absolutely correct, because if i don’t use a server at all, i don’t use google servers either :rofl:

1 Like

Layman me thinks something has to be set, even if ADB doesn’t get it, else internet connectivity should be shown missing (even if it works in practice).
Time could alternatively be fedged from the cell network I guess.
Would be interesting which servers are being used in this situation.

You just stated what you found without a question or request for comment, and there’s a novel concept around called a “weekend” (perhaps somewhere for someone who can look this up in the sources or can be contacted for info) :wink: .



hope you do not expect an answer … :wink:

All things come to those who wait :wink: .


Hi - same here - changed to a and booted


So to summarize:
adb tools default debian stable

adb version
Android Debug Bridge version 1.0.41
Version 28.0.2-debian
Installed as /usr/lib/android-sdk/platform-tools/adb

fastboot --version
fastboot version 28.0.2-debian
Installed as /usr/lib/android-sdk/platform-tools/fastboot

After updating fastboot and adb my Linuxbox needed a reboot before again detecting the device in fastboot (fasboot devices -l)

Installed as documented here: Install /e/ on a Fairphone FP4 - “FP4”
resulted in looping back into bootloader
Magic Command fastboot --set-active=a saved my day

Thanks @FairphoneHulk and @AnotherElk


Thanks for pointing this out. An issue has been created here to track, resolve and close it.


But this issue ticket is only tagged for NTP issue, not for captive portal check issue

But both adb commands mixed together in this issue ticket

Feel free to update the issue on Gitlab

Is it the same user crendentials as in this forum? Or a complete different one?

It is different account

Same here
@Manoj could you add fastboot --set-active=a in the tutorial, at the end of:

Installing /e/ using IMG or image file

Please note that fastboot --set-active=a must be run with bootloader unlocked, so before the section:

Locking the Bootloader

1 Like

I am running this with the team that wrote the draft for the installation guide. Let the porting team guys verify this and then will be updating the guide.

The response from the team is that since both the slots are being flashed as part of the installation, there is no reason why adding an extra fastboot --set-active=a will make a difference.
The team is looking into the problem in more detail. Will update.

Sorry, but it’s not just a few people who have this problem. The statements that it can only be booted by this command are now piling up.

The statement “There is no reason to do that” I can therefore absolutely not understand.

It does not have to be written down as mandatory, but at least as a hint.
If everything goes well and the device boots, everything is OK, but if not and the device hangs in a bootloop, then you have to do it.

1 Like