Fairphone - FP4 - FP4 - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

1 Like

As for Step 5 …

Tip: All the console commands are run on an adb enabled PC and in the adb console.”

This could be misleading.
All the console commands are run in console/ terminal/ command line/ cmd.

The current wording implies all commands are connected to ADB, when fastboot commands are not (apart from being part of the Android SDK Platform Tools).
And an “adb console” could well be interpreted as the one you get with adb shell, which will not run the fastboot commands.

Furthermore, in the instructions ADB is only used to reboot the phone into fastboot mode aka bootloader, which the user can even do without ADB by using buttons on the phone. So “adb enabled PC” is greatly exaggerating the need for ADB, and the instructions already and correctly stated earlier
“Check that adb and fastboot are enabled on your PC.”

2 Likes

Great to see this finally available!

The long list of commands to run could also be put into something like an .sh file for easier installation.

I marked them all with the mouse and then inserted them into the terminal, and off it goes! No need to insert them one by one.

In general: no problems at all installing eOS on FP4 - thanks to all who did it!

1 Like

Many of us are stuck… how did you do it?

https://community.e.foundation/t/install-e-os-on-fp4/37983/5

Unlocking the bootloader

  1. Boot the device
  2. Enable and connect Wifi
  3. Enable Developer options
  4. From developer options, enable OEM unlock
  • Get the unlock code from this site and enter it
  1. Reboot on fastboot by running the command in the PC console adb reboot bootloader

6.Tip:* All the console commands are run on an adb enabled PC and in the adb console.

  1. Ask for unlock with fastboot flashing unlock

Works fine until step 7.
Linux shell says: waiting for device

Someone an idea?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Did you try all of those : https://www.droidwin.com/fix-waiting-for-device-in-adb-or-fastboot-commands/ ?

I selected reboot bootloader (volume up and down buttons and then press power) while I was in the bootloader that fixed it for me.

I finished the install successfully but in only boots into the bootloader now so I would wait a bit.
But I am curious if your install will work.

Hey, did anyone manage to successfully install /e/ on the FP4, now? Or are you all stuck in the bootloader-loop?

2 Likes

Hey Hulk,
I had the same Problems.
Please check if OEM Unlock was successfull an usb debugging works.
If you are enables usb debugging a Message apears (somethings like: to disable usb debugging klick here). In my case I think i klicked without reading the message an the usb debugging mode was gone…

Same problem here :frowning:

Hi @yoraps, replying to your post in the other thread (since we were asked not to post off-topic).
I managed to unlock the bootloader by activating WiFi. However, I am just concerned to flash /e/OS as long as people report that they are trapped in a bootloader loop and no solution is posted. Better safe than sorry … :innocent:

Hi, I’m on bootloop too no way to go back to stock rom ?

That’s strange all command are _a & _b despite of the system image called “Super” and no _a or _b, is that normal ? I used to use fastboot flash system system.img and not flash super super.img !

what do you think ?

1 Like

Maybe a noob question, but " 1. Unzip the folder and browse into it " - what do they mean by browse into it? I unzipped it, i unlocked the bootloader, locked it again without a problem, but i need more advice what to do with the files i downloaded and unzipped. (i cant believe I just should type the commands after unzipping)

1 Like

This means that you have to be in the directory where the files are located and if, then you just have to do the commands.
But don’t do it right now… we’re all stuck.

It was the USB cable. With another fastboot worked then. USB c/c did not a/c worked

For all with the bootloop
Had same problem
Changed active slot and then it booted
Active was b and changed to a

fastboot --set-active=a

Or

fastboot --set-active=b

The current active can be seen in recovery mode

4 Likes

@FairphoneHulk, did you manage to start the phone with /e/OS? Can I send kudos?


What is kudos?

congratulations, reputation, “chapeau”, a deep bow … :slight_smile:

You are right, b is active. How can i change?