Fairphone - FP4 - FP4 - Documentation Suggestions

What if you copy everything from your image file folder to the platform-tools folder and try again?

From your description it looks like the command line can’t find the fastboot command in your image folder, which would be normal if you didn’t either add the platform-tools folder to the PATH system variable or add the full path to the fastboot command everytime you use the fastboot command.
The other way around, like you mentioned, the command line wouldn’t find the images in the platform-tools folder if you don’t add the full path to your image folder before every image filename.
Just putting everything into the platform-tools folder and running the commands there should take care of that in an easy way.

1 Like

Thank you THAT WORKED!
Thank you so much!

As I said, this portion of the guide should be clarified for noobs like me :slight_smile:


Hi @junkston
Your post has entirely solved my problem :smiley: Thank you so much for sharing this information.

For all the others with the issue at point 6 “waiting for any device” on windows machines: Fastboot Not Detecting Device on Windows 10? Here's the Fix | Beebom

@Manoj Could you you please check this issue? I think the requirement of the installation of fastboot driver for Windows user is an essential (but missing) point in the installation instruction!


Did you install the driver to confirm this?

https://github.com/koush/UniversalAdbDriver says it’s “a single Windows driver that supports the ADB (and fastboot) interface for most Android phones.”

1 Like

yes, i installed the driver after a google search (blaarg) from a google drive (blaarg*2)

exactly where @roland.polster posted. i just posted not the link, because i did not know if outside-sources are allowed here.

the installation manual links to (at that time) a site where there stands “download driver”.
this is logical, i click on it and expect that i with this have all the driver i need, as there is not anywhere anything else is stated.
why should i click on the link to https://github.com/koush/UniversalAdbDriver ?
by this logic i should click download visor too?
i am a regular person, i dont click any links because they are there… (1st rule of internet, dont click links you dont know)

i think the main problem in this case ist, that the manual, or this part in particular, is written from the view of a person who

  • is a knowledgeable programmer
  • uses a existing library of tools and drivers
  • uses linux

no front, but to test if your manual works, dont take a intern, take someone from the street and check if
it works out :slight_smile:

1 Like

You shouldn’t, I just cited the place (linked to on the driver download page) where it says that the UniversalAdbDriver should cover fastboot, too, just to confirm whether it does or does not do the intended job in the scenario at hand.

In the former case the driver would be needed to be more prominently placed in the docs, in the latter case the docs would need to adopt a working solution.

1 Like

“waiting for any device” issue AND SOLUTION

I had an issue while installing /e/ on the FP4 using Windows 10.
The Phone was recognized in adb mode but not in fastboot mode and the following message appared: “waiting for any device”.

Luckily I found a solution which I want to share with you:
This was an USB driver problem, therefore I had to update the driver in Windows 10.

  • I went to the Driver Manager, there the device was shown in “USB-Devices” as “Fairphone” in adb mode. When I switched to the bootloader the device was shown in “Other Devices” as “Android” with a yellow triangle.

  • While the phone is in the bootloader, right click on the device (Android) in the Device Manager.

  • Choose update driver

  • Choose Search automatically for updated driver software → Windows doesn’t find any drivers

  • Choose search for actualized drivers on windows update

  • Choose show optional updates

  • click on driver updates

  • I updated three different drivers (LeMobile Android device and two others)

  • After that my device was shown in the device manager under LeMobile Android Device with the name Android Bootloader Interface and the the device was shown in the PC-console when I typed fastboot devices.

  • Furthermore the installation worked fine in the PC-console that I have started in the Folder with the .img files.

Maybe one could include that issue in the documentation, so people with the same issues wouldn’t spend time on searching for a solution?

Good luck!


I can confirm, that I had definetely installed the recommended adb driver from the installation instruction: https://adb.clockworkmod.com/

With this driver installed I was not able to perform any fastboot command e.g. “fastboot devices”. After the installation of the driver recommended in the instruction at the Beebom Homepage the command “fastboot devices” was able to find my device and I could continue to unlock the bootloader whitout any problem.


Exacxtly! This is what I’ve done according the description at this Beebom Homepage and what have solved the problem on my side as well.

Hello there,

And thanks to all of you that have answered a lot of questions to a lot of person !
I’m here with a new request however :slight_smile:

I’ve bee following to the point the tutorial, wich I find quite clear. I’ve encountered no trouble until the very last step : re-locking my bootloader.
No problem with the fastboot flashing lock_critical but when I finally lock it with the fastboot flashing lock as highly recommended (and I can see why :slight_smile: ) when my device reboot, it finally ends up in

This device is corrupt and will not boot.

Then a bootloader loop appears until I unlock it again, flash it all back in then keep it unlock and boot.

It seems that the flashing lock last bit erase all data in my device and so it does not work properly… any encountering of this problem ?

I’m on FP4, with all the correct tools to flash it as I can boot on eOS and it works just fine. I just have to keet the bootloader unlock and dont feel very safe with that option…

1 Like

Hi @Neruu2 welcome to the /e/ forum, but this thread is for Document Suggestions. Please try a search for your error, like this click on the link:- Search results for 'device is corrupt and will not boot Fairphone 4' - /e/ community.

After finally finishing Flashing my FP4 using WINDOWS 10 (which took me several hours)
I spended most time getting the FP4 hardware recognized by windows.
How to check if you have the same probleme like me:
Check in Hardwaremanager: is there a Questionmark on the Android Phone (-> a driver is missing, so phone will never be recognized with adb or fastboot)
How to fix: you need Google USB driver
The ONLY what worked getting the right USB driver was installing Android Studio and with admin permissing installing the “google USB driver”
(Windows Updates, Windows driver database etc. didn’t work for me)
see: Get the Google USB Driver  |  Android Developers

If there someone is interested i would try to make a tutorial for WINDOWS 10 user in german.

1 Like


yesterday I received my FP4. I directly tried the guide and it worked pretty well until, my bootloader locked up and the phone is a useless brick now since no OS is installed and I cannot unlock the bootloader again to flash something else. I guess what i f** up was what the warning meant at this point:

Right? If that is the case then I guess it would make sense to update the warning and add that this only bricks the phone when trying to lock the bootloader again. Because before doing that the phone was working perfectly fine. I know I was pretty dumb not really getting this warning…

1 Like

Can you still enter the bootlader?

Turn of you FP4, holding press Volume down key + plug in the cable?
If you can enter the bootlader this way, you should be able to edit everything with

fastboot flashing lock_critical
fastboot flashing lock

Don`t forget you must accept the change on your smartphone!
(Approve with Voume - then power)

I can still enter the bootloader. As it is already locked and no rom is installed there is currently no way to unlock it again to install a working rom…

And there is now way you can format the memory?
Even if you opend the phone, take the memory out and try it?

How should I “take the memory” do you mean unsoldering it from the board?

I don`t understand how that the bootloader can be locked and you can not unlock it again, with the (normal) commands. Does the computer can find your device? (check Hardwaremanager and test with device command). This was first my problem, not having the right driver on my PC.

Opening up is the last idea I have, sorry, if you can not write/change anything …
What is the exact error message, when you use the unlock command?

I’m afraid your only option is currently to contact support and send the FP4 to the FP repair shop and have it repaired for 30€ (as mentioned e.g. here: Trapped in fastboot mode with locked bootloader and corrupted /e/ OS - #128 by FireCubex - Fairphone 4 - Fairphone Community Forum).

1 Like

I’m using linux and it just happend. They kind of had an bug until now If I understand correctly. And that’s why you can or could log yourself out… Yes my computer finds my device as a normal fastboot device. The error message is that

FAILED (remote: 'Flashing Unlock is not allowed
fastboot: error: Command failed

Opening up is like I said no use to me as I cannot flash chips directly here at home. In the FP4 forum (Trapped in fastboot mode with locked bootloader and corrupted /e/ OS - #128 by FireCubex - Fairphone 4 - Fairphone Community Forum) they are many people with this exact problem with the solution like @ff2u mentioned below. Thanks by the way, I just wanted to write here so that maybe the help/warning text on flashing e.os could be updated to reflect this happend to me and many others. Since it only happens if you lock the bootloader again…