Fairphone - FP4 - FP4 - Documentation Suggestions

BTW the command has already been added to the installation guide.


A problem of wording, it seems.
The statement misses a simple “in theory”.

Practice had other thoughts, it seems, and at least a hint in the documentation will help users immediately.

The theory is sound, though.
If both slots were flashed with something which should be good for booting, setting an active slot by the user should only be necessary if the slots would somehow report as “INVALID” or similar, and then the question would be how it could come to this state.
(At least I’ve experienced this on the Fairphone 3 when messing around with the slots.)



Thanks for providing /e/OS for the Fairphone 4!
Installation worked fine for me, the only thing that I found could take away a bit of my confusion (probably because I’m not so experienced with development for mobile phones) is:

  1. From developer options, enable OEM unlock
  • Get the unlock code from this site and enter it
    4 bis. Make sure your device is connected to your PC
  1. Reboot on fastboot by running the command in the PC console adb reboot bootloader

Absolutely obvious in hindsight of course, but when I just focused on following the instructions, this little piece would have made the process smoother in my case.

FWIW, I found that before fastboot mode it didn’t matter how the device’s USB was configured, but once there the USB had to be set to allow file transfers or neither adb nor fastboot could even see the device.

I followed the guide on how to install /e/ on my Fairphone 4. Everything worked fine until step 6 (fastboot flashing unlock). There it always says “waiting for any device”, even though it can find the device before.
i downloaded the platform-tools and followed all the steps .I also added adb path to the environment variables. (i use an pc with windows on it)
i checked different problem solving solutions and tried them out (doing it on an other computer, using other cables, etc.) but nothing seems to help me get past that step.
can anyone help me with this problem?

Try another USB cable

i tried that. i even tried on an other computer

Did you see the post above your inital post?

1 Like

No problem at all in installing e/OS/ on FP4, a good week ago :slight_smile:

yes i had that problem first but then i did that and the adb works but the fastboot doesnt

i do have that issue, too (as described by admat). Everything worked fine until step 6.
adb recognizes the phone, fastboot won’t. (fastboot = )

after entering recovery mode and selecting ‘enter fastboot’ the command fastboot devices -l shows the device. unfortunately fastboot flashing unlock is not possible, i get

FAILED (remote: ‘Unrecognized command flashing unlock’)

then I tried fastboot oem unlock and got

FAILED (remote: ‘Command not supported in default implementation’)

after executing adb reboot bootloader ‘Fastboot Mode’ is in red letters (as DEVICE STATE - locked).
Is Fastboot Mode disabled?? How to enable it? It would be very helpful to have some comments on this within the manual as well.

very confusing… any ideas how to get this working?
thanks for any help in advance.

using macos montery + homebrew

1 Like

I tried another cable - and it worked.

First try was using the cable from my macbook.

Now I used a cable for external SDD and everything worked fine.

Maybe helpful information, how to check wheather the cable is suitable…

1 Like

Hello Everyone,
Same issue here, I am not able to unlock the bootloader. Everything worked fine until step 6.

I’ve already tried two different cables. One of them is the following brand new, fast, expensive and original Fairphone cable: USB-C 3.2 Long Life Cable - Fairphone 3/3+ | Fairphone

Unfortunately I don’t have more cables to try :neutral_face:

hi there, i am just a regular bloke, so don´t ask me technical questions :slight_smile:

i had the problem too, where i couldn´t get past the fastboot commands.

the problem lies, sorry to say, in the documentation:

Install /e/ on a Fairphone FP4 - “FP4”

under requirements the 3rd points link leads when you follow the rabbit after some steps to a link
where you have to download the drivers for adb and fastboot:

Tip: Windows users also will need the proper drivers installed on their computer. You can check the options available here

BUT there is only the driver for “adb”, the driver for “fastboot” is missing.

the irony is, that, by wanting to get rid of google i had to use it to get that missing bit, the most sources have the driver for fastboot on google drive…

I stuck at the same step “Flash /e/ with the following commands”, terminal (I’m on mac), when I tried the command, terminal say “command not found”. I understand that you give a solution who seems to work for people, but I don’t understand at all what you are saying. Maybe because I’m French, I don’t know, but can you explain your solution to me like I was really really dum? Thanks

Hi all with the < waiting for any device > issue in step 6 of “Unlocking the bootloader”: I had the same issue and using another USB cable did not resolve it.

For me the issue was that I had to run the fastboot commands as root. i.e. sudo fastboot ... in Linux

→ if you have the same issue in Linux, make sure to make yourself su during the installation, as there are a lot of fastboot commands and it would be a pain to add sudo before all of them → enter sudo su in the terminal before using the first fastboot command.

Kodus to @Lidwien who figured this out here :+1:

@Manoj : this should probably be mentioned in the installation instructions!

@roland.polster , @admat see previous post.

I would have mentioned you directly there, but apparently new users are only allowed two mentions per post :thinking:
(so the measure to avoid spam resulted in an additional post. nice :stuck_out_tongue:)

@Manoj more feedback on the instructions:

  • In “Downloads for the FP4” it says “Try the /e/ Recovery (limited functionality)” – this is very confusing and made me look for the “proper” download. Rephrase or remove?
  • In “How to Boot into bootloader mode” you could change the first sentence to “Note: This section will only be relevant later throughout the guide, when you need to reboot into bootloader mode.” to make it more clear what you mean (bold to highlight my suggestion, not to keep ;))
  • “Unlocking the bootloader”, Step 5., rephrase suggestion: Reboot [on fastboot]/[into the bootloader] by running the following command in the terminal/console: adb reboot bootloader
  • Please remove the tip below Step 5. It is in fact misleading, as pointed out by @AnotherElk! You already asked the user to have current adb and fastboot installed, so asking to do this in terminal is enough and avoids confusion.
  • Step 7: Careful, it is very easy to select the wrong option by staying on Volume+ a little too long. → suggestion, rephrase to sth. like: “Select […insert name (“Unlock Bootloader”?) …] using the Volume Buttons and confirm with the Power button.” (same for the other 3 times this is needed)
  • Step 8: you could remind the user to “… (see above)”
  • in “Installing /e/”, see my 2nd-last post: Please mention that fastboot might need sudo (/root) and if yes, do sudo su before running all the commands (on Linux, of course)
  • in “Locking the Bootloader”, step 3, you could again remind to “… (see above).”

Thanks a lot for the guide. The sudo needed for fastboot almost got me, but luckily I found the solution in this very forum :wink:

1 Like

Hello. New here.
I just got my fairphone 4 and was so looking forward to having a de-googled ethical phone!

I followed the guide but it did not work somehow. I read through this thread but did not find the answer.
I believe my problem comes up when I try and copy paste the many lines of code to flash and install. A am in bootloader mode, I have activated USB debug and unlocked the OEM with the code from the fairphone website.

I red about the “navigate to the folder where you extracted the IMG-file”- I have tried pasting all the lines when I start CMD in this folder, I have tried it in the platform-tools folder, and I have nevigated to the IMG-file using commands (cd… etc)

When I do it in the IMG file folder it says “‘fastboot’ is not recognized as an internal or external command, operatable program or batch file”
But when I run it in the platform tools folder it says "fastboot: error: cannot load (the inserted command - of course it cant find it).

I am a noob and I don’t know what I’m doing.
Windows 10.
I don’t know what version of adb

Can you see what I’m doing wrong? I think there could be some more clarity here in the instructions.
The best thing would have been a video.

Thank you in advance!

1 Like