Fairphone4 - VoLTE Telekom Deutschland (262-01) - not working, though it should?

I received my Murena Fairphone 4 with /e/os this week. So far I’m quite happy with it, but a big problem I still have, is that VoLTE is not working.

  • I am 100% sure my Subscription (Telekom Germany, 262 01) and SIM Card support VoLTE, it works in another phone.
    I even tried another VoLTE subscribed SIM card in my Murena FP4 and it also does not work.

  • I have access to a second Fairphone 4 with stock(?) Android. I’m not sure if it is really “stock” android, but it is loaded with the original Fairphone 4 software for my Operator. VoLTE is working on it with my SIM and the second SIM, so the hardware - assuming it is the same make/model and chipset - should support VoLTE with my MNO.

My assumption is, that this seems to be some config problem in the Murena and/or /e/os maybe?

Two observations:

  1. When i use the *#*#4636#*#* service key code, i can see that VoLTE is
    IMS registratio - not registered
    Voice Over LTE: not available
    Voice over WLAN: not available
    Video calls: not available
    UT Interface(?): not available

  2. Funnily, when I search the settings for “VoLTE”, i can find some entries, but if I click on those, it leads me to the normal mobile network settings and there is no options for VoLTE. So I think it is supposed to be there, but is not.

VoLTE is really crucial, as Circuit Switched Fall Back (CSFB) always takes 3 seconds and is really annoying. There is no date for a 2G shutdown in Germany yet and I think it is unlikely to happen in the next 3 years, but who knows for sure?

I would appreciate some comment, suggestion or help :slight_smile:

Thank you!

1 Like

Maybe you should keep an eye on VoWiFi/VoLTE not working on Fairphone 4 with /e/ (on Vodafone Germany and other networks) (#5452) · Issues · e / Backlog · GitLab

1 Like

Yeah, i found that in the meanwhile. Thanks anyway.

1 Like

For me VoLTE is working on Fairphone 4 with German Telekom (prepaid SIM).

However I have another problem, whenever VoLTE is enabled:
When calling some phone numbers (maybe mainly fixed network?) I don’t get a ring-back tone, instead there is silence until the callee accepts the call. When calling other phone numbers (maybe all mobile networks?) everything works as expected.

The problem doesn’t appear to exist for a Samsung phone with German Telekom (prepaid SIM).

After Volte was fixed, I had this too, for a while. No ringback tone on any number i had called.

Though for me this issue is fixed for a few months, since the last like 2 or 3 updates.

Are you on the last version?

I recently upgraded to /e/OS v1.11.

You might be right. I tested it with my home phone number again and this time I received a ring-back tone. Some days/weeks ago this didn’t work. I will keep an eye on it the next time.