Feedback for v1.12.3

Updated yesterday, terracube e2. Instantly calls dont work. Cannot recieve calls either.

Vendor Name: Fairphone
Device name: FP3
Device CodeName: 
Version of /e/OS or Stock which existed previously:  /e/OS 1.11 (stable)
Not rooted

Unfortunately, the location still isn’t working. After walking about 1.5 km to work and now being inside a building, the location in Magic Earth jumps around within a radius of 9 km. With version system 1.11, I was able to get good localization results by deactivating the Mozilla Location Service and installing the Local NLP Backend, but this is a setback. The Local NLP Backend also seems to not be activatable under 1.12.3. The location in the Here WeGo app continues to work accurately within 5-10 meters.

Vendor Name: OnePlus
Device name: OnePlus 6
Device CodeName: enchilada
Version of /e/OS or Stock which existed previously: 1.10 S
Is the device Rooted / Not rooted: Rooted

The update went smoothly. The battery drain issue caused by media storage is gone. :slight_smile:

There are two different 2e phones (thank Teracube for that) codenamed “zirconia” and “emerald”, so please …


1 Like

The new microG version that comes with 1.12.3 includes a major location overhaul. A good summary of the technical background can be found here …

It’s also mentioned in with a link to

Settings app kept closing after update. I had to factory reset (using TWRP - not possible using Settings because Settings app kept closing…)

  • Vendor Name: Sony
  • Device name: Xperia XZ1 Compact
  • Device CodeName: lilac
  • Version of /e/OS or Stock which existed previously" e-1.11-q
  • Is the device Rooted / Not rooted: Not rooted

When I received the Update notification, I downloaded it, exported it, copied the update to my laptop, then installed the update. After the reboot, the message 'Settings app keeps closing` appeared. Selection ‘App info’ of course tried to open Settings which of course crashed. I was not able to clear storage because that needs Settigs to work. So I had to factory reset using TWRP, lsing all my user-installed apps and data.

I’m very glad this is not my daily driver!

Thank you for the link, this is interesting, finally an explanation. However, the location service on my device hasn’t worked since version 1.6, I think. And for me it remains a mystery why Here WeGo finds enough GPS signals to locate sufficiently well.

If it doesn’t happen when device is unplugged, consider using another charger and/or cable.

Note 10+
Not Rooted

Worked fine via ota-update

Updated my S10e one week ago.
The OS works more or less as usual but:

  • The tracker menu of Advanced Privacy is unstable and freezes;
  • Tisseo ( doesn’t work anymore. It crashes with:
06-28 12:30:04.674  7403  7437 D LocationManager: registerLocationUpdates (callback) by
06-28 12:30:04.705  7403  7403 D LocationManager: Note app @ Location[cache 43.570292,1.384846 hAcc=1331.0 et=+46m3s26ms]
06-28 12:30:04.723  7403  7437 D LocationManager: registerLocationUpdates (callback) by
06-28 12:30:04.747  7403  7437 D LocationManager: unregisterLocationUpdates (callback) by
06-28 12:30:04.990  6125  6151 I ActivityTaskManager: Displayed +604ms
06-28 12:30:05.054  7403  7430 D LocationManager: getLastLocationWithReceiver by
06-28 12:30:05.057  7403  7403 D LocationManager: Note app @ Location[cache 43.570292,1.384846 hAcc=1331.0 et=+46m3s26ms]
06-28 12:30:05.326 24103 24103 E AndroidRuntime: Process:, PID: 24103
06-28 12:30:05.326 24103 24103 E AndroidRuntime:        at
06-28 12:30:05.326 24103 24103 E AndroidRuntime:        at
06-28 12:30:05.326 24103 24103 E AndroidRuntime:        at$onMapReady$9.q(MapFragment.kt:39)
06-28 12:30:05.332  6125  7192 W ActivityTaskManager:   Force finishing activity
06-28 12:30:05.460  6125  7181 I ActivityManager: Process (pid 24103) has died: fg  TOP
06-28 12:30:05.460  6125 12274 I WindowManager: WIN DEATH: Window{1b10a44 u0}
06-28 12:30:05.460  6125 12274 W InputManager-JNI: Input channel object '1b10a44 (client)' was disposed without first being removed with the input manager!
06-28 12:30:05.465  6125  7188 I WindowManager: WIN DEATH: Window{523c71f u0}
06-28 12:30:05.466  6125  7188 W InputManager-JNI: Input channel object '523c71f (client)' was disposed without first being removed with the input manager!
06-28 12:30:05.565  6125  6155 W WindowManager: Failed to deliver inset state change to w=Window{523c71f u0 EXITING}
06-28 12:30:05.832  6125  6154 W ActivityTaskManager: Activity top resumed state loss timeout for ActivityRecord{42bee5b u0 t-1 f}}

Hello Gianna,

Please advice on how to install this image. My Tab M10HD is model Lenovo TB-X306F currently running android 10.

Thanks in advance

Confirmed. Tisseo got hit by the new microG location thing.
App crashes on crDroid with microG 0.2.28. Logs also show a lot of GmsMaps related entries prior to Tisseo’s exception. App does show up in microG’s location access section with a little map.

Vendor Name: Google
Device name: Pixel 4a
Device CodeName: sunfish
Version of /e/OS or Stock which existed previously e-1.11-r stable
Is the device Rooted / Not rooted: Not rooted

No issues detected. By accident I saw today that pictures from camera are stored under ‘Camera’ and not under ‘OpenCamera’. It is easy to resolce, just change it back in the camera settings.

New feature in App Lounge where you can set if apps from other stores should not be updated doesn’t work properly (anymore). With v1.11 I have downloaded it and it workthen, now not so good anymore…

teracube 2e, emerald, upgraded from v1.10, now cannot make and receive calls, everything else works.

It happens too when device is unplugged.

I thought I’d deactivate Gestures to see.
It took several hours, but the problem came back.

Thanks for this report issue logged there

1 Like

New version: 1.12.3-s-20230615299639-stable-FP4

  • Vendor name: Fairphone
  • Device name: FP4
  • Device code name: FP4
  • Version of /e/OS or Stock which existed previously: 1.11 stable FP4
  • Device not rooted

Update resetted several settings like VPN and app installation (F-Droid) permissions. Some apps or services had high consumption of battery before update. After update, they still have (like mobile network).
Advanced privacy shows trackers for only one app any more. Before I updated, the list of app related trackers was very long. For example, my Browser was shown to have trackers but now ‘they are gone’ (not visible in Advanced Privacy)

New version: 1.12.3-q-20230620301517-star2lte (dev)

Vendor name: Samsung
Device name: Galaxy S9+
Device code name: star2lte (SM-G965F)
Version of /e/OS or Stock which existed previously: 1.11-q dev
Device not rooted

The update went smoothly, as nearly always, and no (new) major issue found since then.
Well, some issues by the way :face_with_raised_eyebrow:

  • a bit longer boot time, and even sometimes, I even get a white screen with a rotating progress for a few seconds before getting the normal “desktop”,
  • I had to set again twice the Camera target folder to get it back to my preferred one … a bit odd, but fixed now,
  • and probably more battery consumption, not all the time, but with some apps like Bromite and others, but not others, … not clear ; the phone gets hot in my hand after a few minutes, which I have never noticed till then ; unfortunately, the settings page that ranks the apps by descending battery consumption since last full charge does not give the answer of which is that hungry … in spite of the battery graph suddenly getting down with a strong slope.

On the good side … after a few days with broken GPS (just as most of the time since 1.2), it seems to work well again, at least last sunday and today all morning long … would it be that the massive location layer rework come with microG 0.2.28 have fixed this ? Hmmm … let’s wait for a few weeks before any premature optimism :wink: (but hey … :star_struck: :face_with_raised_eyebrow:)
Update: Confirmed GPS OK all morning long, on July, 2nd.

Mine is the emerald version. Until now the only issues i have is app lounge wont work with the exception of right after a restart. Not a big deal. Not being able to make calls makes the phone useless. I hope they fix it within a couple days or i just go back to a googled phone that actually works

1 Like

I don’t have emerald, but some generic things come to mind …

Did the update enable airplane mode by default perhaps?

You could try Settings - Apps - See all … apps - Phone - Storage and cache - Clear cache.

You could try whether turning off the phone (no reboot, real shutdown, it makes a difference), waiting a few seconds, then turning it on again helps.

Depending on where you are and which mobile network provider you use, VoLTE and Wi-Fi calling settings could be enabled/disabled for testing.

You could try Settings - System - Reset options - Reset Wi-Fi, mobile & Bluetooth (will of course lose your known Wi-Fi networks and passwords, but exists for reasons).

Stuff like this is not exclusive to any OS or device, but fingers crossed in any case.

1 Like