Feedback for v1.18

New version: 1.18-s-20231207360611-stable-FP4

Vendor name: Fairphone
Device name: FP4
Device code name: FP4
Version of /e/OS or Stock which existed previously: 1.17-s-20231109350748-stable-FP4
Device not rooted

All good except wlan connection is lost frequently when the phone is unlocked
I experienced this occassionally in prior releases but it seems to be far more frequent now.

Happy new year everybody and thanks for the good work team.

. Please add the following details

  • Vendor Name Gigaset
  • Device name GS290
  • Device CodeName GS290
  • Version of /e/OS or Stock which existed previously
  • Is the device Rooted / Not rooted? Not rooted

Working well, but I use only a subset of the funtionality.
Entering the sim PIN takes a long time before the keyboard reacts

Thanks for reporting the issue with random rebooting on the FP5. There is an issue already created for this but is marked confidential and would not be visible to all users. Will update what is the progress on the issue in this thread.

1 Like

For the 1st time there is a random issue. On native Mail app, emails are displayed on the main window but it is sometimes impossible to open an email. So strange…

Best regards.


The last two times for me I was using Mull (Firefox browser) so could be related

Hello @JA13, this is a known bug in /e/OS 1.18. There is a bugticket in the /e/OS Gitlab, they are working on a fix. There is also a dedicated thread in the forum.

1 Like
  • Vendor Name: Fairphone
  • Device name: FP4
  • Device CodeName: FP4
  • Version of /e/OS which existed previously:
    1.17-s stable
  • not rooted

The loud sound while calling is corrected, many thanks for that. I have a problem with Camera (v1.51.1) I can’t reach the third lens manualy. I can do that usually.

This is an intended bug correction, there are only two lenses in the FP4 (the regular one and the wide angle). In the past, lens3 in OpenCamera was in fact again the regular one.


As for the probable follow-up question … The third circle is the ToF sensor.

1 Like

Many thanks for your answers ! : )

Same with FP3+ after upgrading to 1.18

1 Like

Vendor: Samsung
Device Name Galaxy S10+ SM-G975F
Device CodeName: beyond2lte
Version of previous e/OS: 1.17-s
Not rooted

Generally everything fine
Screen turns itself on and stays on. That is definitely not intended and timeout is set to 1 minute
Few settings and permissions got reset and have had to be set again
I use App Manager from f-droid (io.github.muntashirakon.AppManager) version 3.1.4
it lost access to App Usage or stopped displaying anything. That didn’t happen right after update, but I cannot get it back.
I have USB debugging, Rooted debugging, Wireless debugging and ADB over TCPIP enabled and this is how it is getting access to most of the functions.

GPS rollover problem still bugs me a lot. Every reboot and I have to set impossible date of 21st November 2038. It is NOT fun, especially, when this will revert itself back (WiFi OFF, Mobile Data OFF, Airplane Mode ON). Why do I need to set date past next GPS week rollover to get correct date on GPS? This really makes no sense! Does it have anything to do with when SIM card was manufactured? It used to reset to correct time, when no SIM card was inserted, but that stopped working in december, before updating. Could we fix GPS week rollover? Obviously we are not going back in time, so what is the point to allow GPS to travel back in time to year 2004?

Vendor Name: Fairphone
Device name: FP3+
Device CodeName: FP3+
Version of /e/OS: 1.18-s stable
Not rooted

Same, regardless of the device too apparently, Sennheiser Momentum 3, Car system (Opel Corsa).

Also got a couple of random reboots.

Thanks to the Team!

  • Vendor Name: Google
  • Device name: Pixel 7
  • Device CodeName: Panther
  • Version of /e/OS or Stock which existed previously: stock ROM android 13
  • Is the device Rooted / Not rooted: not rooted

Everything seems to be working perfectly

Found another issue tonight. I have Apple Air pod Pros paired. Tonight I was listening to music. I saw I had a voicemail so I dialed in to retrieve, The sound shifted to the earpiece on the phone instead of playing through the AAP. I then tried to switch the voicemail to speaker, and it would not shift at all. Then, when I hung up, my music started to play through the phone speaker instead of my AAP.

Hi all, I had trouble with the update process, but it seems to have been solved now. Here’s what I went through:

I had the following setup:

Vendor Name: Fairphone
Device name: Fairphone 4
Device CodeName: FP4
Version of /e/OS or Stock which existed previously: 1.17
Is the device Rooted / Not rooted: Not rooted

The updater was downloading the 1.1GB update (/e/OS 1.18, 7 Dec 2023) update just fine. Then, I can click the “INSTALL” button. It asks me:

Apply update
You are about to update to /e/OS 1.18 - 7 Dec 2023.
If you press OK, the device will begin installing in the background
Once completed, you will be prompted to reboot.

So I press “OK”, and the app immediately crashes. I get the message:

Updater keeps stopping
App info
Close app

Where “App info” leads me to a page that has prefs on the Installer app, with at the bottom:

Version 12

Upon searching the web a bit I tried deleting the storage and cache of the updater but that did not give any different result.

Only after a manual restart, it now finally indicates that it is running 1.18. So the classical “did you try turning it off and on again” worked, but for the average user this might be a problematic hiccup.

Vendor Name : Fairphone
Device name : FP4
Version of /e/OS previously : 1.17-s-…-stable-FP4
Device Rooted and Magisk works well no problems

thanks :slight_smile:

Vendor Name: Fairphone
Device name: FP4
Device CodeName: FP4
Version of /e/OS which existed previously: 1.17-s stable
the device is not rooted

The sound from the earpiece is no longer as loud during calls. Thank you very much for that, I can make calls discreetly again :wink:

Otherwise as noted by others, searching the calendar crashes the application.

Vendor: Murena
Device: Fairphone 4
CodeName: FP4
OS before update: /e/OS 1.17-s-20231109350748-stable-FP4
Rooted: False
Update went fine, some issue though…

1# Screenbrightness issue still there, it dims without any reason. When the sun is out, it is almost impossible to read the screen.
I have turned off any setting related to this, but no improvement.

2# Ghost inputs issue still there as mentioned in the FP4 topic. It is less, but still there…

3# Microphone issue, a lot of people complain about they can hear me badly when talking. This is with phone on my ear and when using the speaker option. When I’m a little further away they can hardly hear me talking. This issue is already present since I started using the FP4 in Dec last year.

#4 Not able to select manually another Network provider, message: “Couldn’t find networks. Try again.”
For now the workaround with 4G works…

#5 The camera is not able to focus well as reported by outsidethebox and here Camera has focus problems after update to eOS v1.15 - #3 by mungo

#6 Making a video recording with my FP4 and a message came in, but instead of e/os muting the sound of the message and just give the notification in the screen. The sound of the message is now recorded in the video…

Very annoying as it is a very loud sound and can be very clearly heared when playing back the video.

#7 On the last versions the loudness on the phone could not be turned down, no I can hardly hear people with the loudness on MAX.

#8 Went to a neigbouring country and it would not get the network… Could only make calls, but internet not available. Tried 2G to 5G, no result…