Feedback for v1.3

Me too:

I have a Fairphone 4 and have upgraded from 1.2 to 1.3. Thanks for providing frequent updates for this os. I have thoroughly enjoyed since getting my FP4 a few months back. I have already had three flawless over the air os updates!

This time I have a small issue (so far) as I am having a minor issue with wifi.

I have a wifi symbol showing no connection to wifi both at the top right of the screen beside the battery percentage and also in the pull down menu. It also gives a written error message that it has connected to wifi but there is no internet. The funny thing is that wifi works fine and I am writing this from the same phone showing me that “no internet” message and the empty wifi icon with an x on it.

So the wifi seems to work normally except ithe icons and pop up messages show occasionally asking if I want to try another wifi network since the system thinks this and my other network dont work.

Interesting: I’ve seen something similar this evening.

My oneplus 3 running 1.3-r has been very stable until this evening when I brought it back to my home WiFi zone. Earlier, this evening WiFi status in settings was “connected, no internet” and I could not fix that after looking at various posts & solutions here: reboots, developer options, etc. Turned off mobile data while testing.

Set the phone aside for a while. …

Came back to the phone just now. It still shows WiFi icon with an x at the right of the status bar. In WiFi settings, status is now connected though.

Mobile data is still off. I’m reading this thread and responding using my phone, over WiFi, despite the status bar icon showing I have no internet via WiFi or mobile data.

Oneplus 3 running 1.3-r-20220825212931-dev-oneplus3

1 Like

The Teracube 2e stable update is held up due to this issue
The device stable build is still on v1.1
While the team is working on resolving the issue, we do not have an ETA to share.


This is possible theoretically.
“x” or not “x” is dependent on a connectivity check trying to reach certain addresses in the internet for a short answer. If these addresses are somehow unavailable or if this check might fail in a different way, the rest of the internet could work fine on the phone while the “x” would be displayed due to the failed connectivity check.

The connectivity check and how /e/OS wants to handle it is mentioned in this white paper.

Also see, mentioned in the white paper.

If this is not just a temporary phenomenon for you, it would need investigation. Could be a firewall App on the phone or your Wi-Fi router firewall is blocking the connectivity check addresses, could be there’s indeed an issue on your phone, in which case you could open a GitLab issue to get in touch with the /e/OS developers about this …


Samsung S7 :

  • All pictures disapeared from “OpenCamera” but hoppefully they are still on my murena account.
  • People I call still complain about earing their voice in echo : this issue
  • I am using my bluetooth headset to avoid the echo, but the sound is very noisy during calls. No sound problem with other uses.

Poco X3 Pro user here. The CTS Profile still does not match as part of the Safetynet test. I’d really love to see that fixed so I can properly report on what banking and shopping apps work without the need for Magisk and its modules.

Just for completeness concerning my post, that was not an eOS problem, because the latest version (of Simple Dialer) have an option (disable by default) to show always on whole screen the income calls. I think this was my problem, solved today.

1 Like

My issue has actually gotten worse as my phone will no longer connect to wifi. It detects there are many wifi networks (since I am in a condo unit) but does not connect no matter how/how many times I try to any of my three available networks. I am currently using cellular data which still works to write this and also connecting physical ethernet cable still works as well.

Edit: I can now access wifi if I “forget the network” and re-enter credentials. But it still give me a message once I connect: ( “network name” has no internet connection. Tap for options ). Even though I am writing using wifi which still accesses the internet.

@AnotherElk Thanks for the background information! Very helpful.

Using termux, I am able to wget the updated connectivity addresses mentioned in and I receive the expected HTTP 204 responses. AFAIK the connectivity checks should pass.

@diefuel, my situation remains the same as yesterday. WIFI Settings show that I’m connected to my home WIFI network but it reports there is no Internet. Status bar continues to show WIFI icon with an x. Restarting the phone or toggling WIFI and mobile data does not change the behaviour. Pings and traceroutes from the router itself all succeed and other devices inside my home network report no connectivity problems.

I downloaded and installed termux on my phone with mobile data turned off. :slight_smile:

My phone is connected to WIFI and working. Status being shown seems to be the only issue. I will open a GitLab issue if it persists much longer.


Are you blocking the network connectivity check endpoints? Any custom DNS?

If not directly, do you have Snort or Suricata on a hair trigger?

I’m not blocking the check endpoints in my phone or on my router. Until this problem arose, I was using default DNS config on the phone: “Use network DNS”. Since this started to happen yesterday, I have experimented with in the phone configuration. Did not make any difference and I have reverted to the network provider’s DNS.

Not using Snort or Suricata. (had to look up what those are)

The testing I did with wget on the phone indicates that the connectivity check endpoints are accessible from the phone and, because I turned off mobile data, those requests were going out over my WIFI / router.

No networking config changes were done in my home network recently. I don’t think anything like that is the cause of how the status indication is now working.

1 Like

Hi everybody,

I installed 1.3-202209052160 by OTA on a Samsung S7 SM-G930F (bought at the /e/ shop with /e/ installed on it.
My issue: The Signal messenger app stopped working with the update (App crashes at every attempt to start the app).
I have tested different ideas: Restart of the device/Advanced Privacy Off/Update of the Signal App/deactivate microG Cloud Messaging → No success!

Any hints/ideas?

Thanks in advance!

1 Like

Hi @Huberstoni, and welcome to the forum. Had you also try to clear the app cache? However, I must said I don’t use Signal and didn’t try it myself.

1 Like

FYI I was going to open an issue on GitLab as suggested but GitLab registration is rejecting the email address I’m willing to use to create the account… Should I create a gmail account to open an /e/ gitlab account? :slight_smile: Sorry, that won’t happen.



@nottolino Okay, thanks! Will do. Perhaps that info should appear on the GitLab registration page.

1 Like

with v1.3 on my Pocophone F1, I regularly have no connections via wifi.
Wifi is connected but no connections to internet or my local servers.
I just have to turn off and on wifi to get back to connections.
Note : I don’t activated Advanced Privacy as I use Blockada.

1 Like

Thanks @jobal for your idea!
I have tested it (deleted the cache of the Signal App) but unfortunately with no change…

The app still does not work after the update…

I updated my Murena S9 to /e/OS 1.3 and I decided to use it as my main and only phone …

Setup of all applications including email, tusky, element, zvv, sbb, nextcloud worked without problems. I don’t use eCloud, I have my own Nectcloud.
Moving Signal worked by backing up on the old phone and importing backup on the S9 with use of SD card.
Moving WhatsApp has been more hazzling as I needed to copy files from application folder, but worked.

System is stable and works well except for:

  • Location is problematic. While Maps shows correct location, ZVV and SBB have dificulties, location in SBB app not working at all.
  • One bug: in Settings, Akku: disable fast charge. After reboot this setting is again enabled.

I’m now waiting for /e/OS S coming out so I can hopefully flash my S10e.