Feedback for v1.5

I’m experiencing problems with release 1.5.
About phone: FP3
/e/OS version is 1.5-r-20221028230215-stable-FP3

Since I upgraded from 1.4 to 1.5, my battery drains within a day with the same activity as before (almost no apps opened).
Directly after the upgrade I did notice the WiFi connection keeps connecting and disconnecting. In the log of my DHCP server, it was about once every 8 seconds. Maybe this resulted in excessive battery usage?

Positive note: I do like the improved, less annoying sound when plugging in the charger cable :slight_smile:

After reboot no more fingerprint issue. :grinning:

update from 1.4 to 1.5 fails, updater crashes after successful download of 1.5
bootloader not unlocked

Did you already try to turn off the phone (not just reboot, real shutdown) and turn it on again?

For anything else more version info would be interesting …

It seems the trick helped. No more issues with Wifi so far.

Thx again @TheMajorTom

Does anyone successful connect to a private DNS like either with Wifi or mobile data?

Tried a real Android 12 (S) install from scratch today … wiped system, wiped data before … same issue.
Tried to install the prior microG build with Exposure Notifications via adb install -d … same issue.

Installed 1.5-r-20221030230467-dev-FP3 from scratch … issue is gone, microG with Exposure Notifications works after installing it. And Lawnchair 12.1 installs and works just fine, too (I missed checking that again with the new Android 12 install).

I’m staying with Android 11 (R) now for a while, it seems.


One item I noticed since the upgrade to 1.5 is that the face detection sensor (that turns the screen off when you have the phone by your ear) takes about 1 second to react now, which means sometimes I activate various apps/menus with my ear.

To be entirely honest, I’m not sure this is a 1.5 issue, as I’m comparing a 1.5s on a Samsung S10+ with 1.4r on a Samsung S7edge. The S10+ never had 1.4 or the r version. the S7 got upgraded to 1.5r and has the delay now, but it doesn’t seem to be as long as the S10 (or it’s just my imagination).

Ok, it’s my first time doing this, so hope I got the correct infos…
I updated my FF3+ today to v1.5 (previous version was…v1.4, I think ?)
I had two issues
After the update, the “display recent apps” button didn’t work and showed a “trebuchet keeps on crashing” notice. I could solve this one thanks to @raphm 's earlier message, by putting in a default laucher app (mine was OpenLaucher). Thanks !

The other one was that I lost mobile data (couldn’t connect to mobile data, but the wifi worked). I reset the APN settings for my carrier and it seems to work now.

As for now,haven’t tested everything yet, but the rest seems to work. Curious to see if the battery is going to stay at more or less the same % of use as before…

Hi AnotherElk, thanks for your reply.

I understand you were asking about the Android version, right? It’s Android 11.

I did not know there would be a difference between a reboot and a real shutdown. Did it yesterday and surprisingly enough the battery did not need a recharge until now.

Issue with update to 1.5 Android 12
Device: Fairphone 4
Version: 1.5.1-s-20221102231514-stable-FP4 with Android 12
MicroG: (f1daeaa)-noen
I have now the problem that apps like birday can’t find Birthday dates of contacts in the phone storage.
The permission to get contacts are enabled and i try birday com.minar.birday Version 4.0.1 and Geburtstagskalender+Erinnerungen dev.cwolf.birthdaycalendar Version 2.0.12 with the same issue, both apps in current version.

Issue after updating to 1.5 Android 10
Device: Fairphone 3+
Version: 1.5-20221031230909
MicroG: (f87cb98)-noen

Since I updated, my bank app does not works seamlessly. After the 1st (re)install, it works fine but if I close it and reopen it, it gets stuck on the opening screen. To access it again I have to got the app info and delete its stored data and clean cache. Then when launching it again, I have to redo the whole process as if I just installed it (giving my credentials, get and enter a validation code sent by e-mail, etc…).
I tried disabling Advanced Privacy and modifying microG settings with no luck. As far as I know this only happens with this app on this phone.
Possible hint: I also tried installing it on my old phone (a Cubot Quest not on e/ but on which no google account is set) using Aurora Store and got the exact same behavior with, that’s new, an error message stating “this app won’t work properly except if you accept Google services request to Contacts and SMS. To continue, select Settings > Authorizations and authorize the above listed items” (translated on the fly from french)

Updated Samsung Tab S6 and S10e phone to 1.5.1-s. Restored/Moved all accounts and data from S9 with /e/OS 1.5-q with only one exception:
moving the data of WhatsApp seems to be impossible.
Anyone got this done?

If you have a dev build on source and destination devices, and access to a machine (real ro virtual) running linux, then Android Backup and Restore Tools will do the trick.

Ok, so I was talking too fast when I said it worked now…
I updated my FF3+ to v1.5-r-20221028230215-stable-FP3,
I noticed today that some phone calls don’t get through? Like, they’re not even listed as missed calls or anything, they just don’t exist, as if no one ever called. But some other calls work. Any idea ?

Also, the mobile data must be randomly switching on and off, because I’m getting updates/notifications I shouldn’t have. I tried to switch off the phone and then switch it on again, but it didn’t change anything.

No way to install it, i will have to dig a bit to learn how to do it :worried:

Edit: I panicked, went to open a support ticket for FP4, and read that maybe Safe Mode could fix the problem. I rebooted into SM, the sensor was working ok, rebooted in normal mode again, and it’s working again. I have no idea what might have happened.

I just restarted my Fairphone 4 today and was greeted with a totally new launcher - very slick, but also unfortunately with lots of bugs. Suddenly my keyboard is more wonky, and in the Hey app is just not working properly (it won’t allow me to press the spacebar to go to the next word, and yield weird autocomplete results).

But most importantly, the fingerprint sensor seems completely dead! I can’t unlock my phone, or access my banking features.

Yesterday, my FP4 + e/OS yesterday was a great combo with 99 % of what I needed, and I was recommending it to everybody. Today I’m bummed to see that this update broke so many things, I’m traveling this week and I’m worried I’m going to have problems because of it.

How can I troubleshoot this issue myself, or hopefully fix it??

I love /e/. But my family who bought a murena phone because me and my son told them how nessesary it was is not that happy. Issues that have followed are f.eks: Unstable sendig of MMS, most of the time I get an error message, Problems sending emails from the mail app. The magic earth app have trouble finding where it is because it relies on wifi positionings rather than GPS. I have downloaded maps from my country, but when advanced security is on, it is impossible to use magic earth. To get more people interested in degoogled os, things like that has to work.

You don’t need to disable Advanced Privacy. All you need to do is configure it to use real location (rather than a fake location) - this will fix your magic earth “problem”.

Unfortunately, the “Allow notification dot” option under any app’s notifications section (settings-> apps-> notifications) doesn’t seem to have any effect.

I have disabled it for multiple apps to no effect - I still get the notification dot on all the apps, when they have updates or notices.

Does anybody know if this has been logged as a defect already?

That seem correct, but what is the point of advanced security when my location are exposed? Why can’t Magic Earth, trust more the GPS than wifi location?