Feedback for v1.6

Screen usage is BACK in my Battery usage overview

:+1:

This was so helpful, thank you !

1 Like

Do it wiith the terminal on your computer.

Went smoothly on my TeraCube 2E Emerald devices.

Update did NOT work for me on Pixel 5

  • Vendor Name : Google
  • Device name : Pixel 5
  • Device CodeName : redfin
  • Version of /e/OS or Stock which existed previously : e/OS/1.5.1-s-20221103231515-dev-redfin
  • Is the device Rooted / Not rooted : Rooted

Tried to install 1.6s from the updater, can download, when I click on Install, it shows “preparing for first boot” for less than a second and back to “install”. Install error message is shown in the notifications.

Using adb, all the steps to upgrade happened correctly, recovery is updated to 1.6, however when I reboot after the installation, the version remain 1.5.1.
https://doc.e.foundation/devices/redfin/install

What can I do next ?

EDIT : Solved, see replies

I guess the system app “Dynamic System Updates” does the updating. You might want to empty its cache and storage in Settings > Apps > All apps > System Apps > Dynamic System Updates > Storage and cache and give it a new try afterwards.

Thanks, just tried, no difference.

1 Like

Do both the Updater (app) and Settings > About phone > /e/OS version show the version as 1.5.1?

Same here. Still 1.5.1-s on my FP4

3 Likes

for me, it does. 1.5.1-s on the both sides

Yes, for both. 1.5.1

1 Like

Issue opened here:

1 Like

Same here unfortunately :slight_smile:

Where did you get it? On my Teracube 2e Emerald, update 1.6r stable is not available yet. Manual download is not available too. Only 1.6r dev.

1 Like

SOLUTION :
If you find this in the logs :

12-08 15:07:43.494  1275  1275 W update_engine: [WARNING:dynamic_partition_control_android.cc(441)] overlayfs overrides are active and can interfere with our resources.
12-08 15:07:43.494  1275  1275 W update_engine: run adb enable-verity to deactivate if required and try again.

The problem is that I used adb remount and wrote to dynamic partitions. This uses overlayfs and effectively breaks updates until you remove all the changes.

For more information, you can also refer to Android Documentation at Implementing Dynamic Partitions  |  Android Open Source Project

The fix was simple, I ran :

adb root

adb enable-verity

result :

enable-verity only works for userdebug builds
Overlayfs teardown failed with error Invalid argument
Now reboot your device for settings to take effect

adb reboot

Even though I thought the enable-verity command did not work, the phone restarted and showed the system was updated to 1.6-s as I already did the update process before.

Full story :

FP4, still 1.5.1s, no update available so far…

5 Likes

I used the option in Developer Mode to change the update channel for the System Update app.

Been great here thus far, but caveat emptor

Have just updated from 1.5s to 1.6s (Samsung Galaxy S10+) and it went without a hitch. Even the download was really fast (previous to 1.4, it took a VEEEERY long time to download the update and the download would time out 10-20 times before completing).

Haven’t done any exhaustive testing, but at first glance, everything seems to be working fine.

Does anybody know where the what’s new/release notes page for 1.6 can be found? (I’m sure I asked this question before, for 1.4, but I managed to lose the URL).

1 Like

Installed without problem on a Xiaomi MiMIX 2 (chiron), Android 11.
Thanks /e/ Team for the good job! :smiley_cat:
@centaurus: Releases · e / os / releases · GitLab

1 Like

You can donwload it here : /e/ image ROM download and install it with the terminal, works perfectly :wink: