Feedback for v1.7

FP3+ v1.6r to 1.7r (stable).
Updated OK and working fine currently.

However, there does appear to be a significant issue resulting from the changes introduced to App Lounge, specifically this from the release notes:
“Replace Google play app with fdroid app if the app is available in both sources.”

There now appears to be no way to locate the Play version of an app if there is also an F-droid version.

This presents a significant issue where the two versions offer different functionality.

For example, for mapping I use the Play version of Vespucci as it offers aerial imagery from Bing which is higher quality than other available options. The F-droid version has recently removed the ability to use Bing.

I’ve tried unticking ‘show open-source apps’ in settings but the F-droid version still appears. I used to be able to find the app by adding ‘google’ to my search, but now only the F-droid version shows.

So, what happens when the app is next updated? Will my installed (Play) version show or will I be unable to update without changing version and losing important functionality? What if I need to reinstall it?

(I know there are other ways to install apps but I shouldn’t need to resort to these.)

I’ve seen this issue raised as a general concern in earlier discussions about the proposed changes so thought it would be properly addressed.

Have you doublechecked status and settings of “advanced privacy” ? Especially the “fake my location” function.

1 Like

Yea, that was it. All fixed. Deleting my post.

1 Like

(post deleted by author)

Galaxy Samsung 8 rooted
From 0.23 to 1.7. No ota, I downloaded the zip file.
1.7 is faster good job, thanks for the update !

I miss my long click on task buton to split screen in 2 but it’s realy ok so fare.

Vendor Samsung
Device Galaxy S7
Device CodeName: SM-G930F
Version of /e/OS or Stock which existed previously:1.6
Device not rooted

After S7 upgrade today I still could not install Izly app!
The installed app got removed since v.1.4 update, but some folks can still use it. I turn off all 3 Advanced Privacy switches, but still the app refused to install (see posts here)
Could some system options block this app ?
Or is it related to microG and google account i do not have ?
All help is welcome

Are you saying you have an apk file available but it won´t install?
It should prompt something along the lines of “allow or deny potentially unsecure sources” for install if the apk is not sourced from an apropriate store.
Or are You saying you do not find the app in aurora store or app lounge?

You might find online ressources for download of an apk that maybe works for install (in that case it is your own responsibility whether you trust the source or not)

edit: sorry, I did not read all of the linked conversation first…

I had the same problem on my S7. No problem with my S8. I did exactly the same intall procedure. I think it comes from the /e/OS version installed on the S7.

1 Like

Samsung S7 Edge, not rooted, updated from v1.6-q to v1.7-q

refer to improvement AppLounge: Replace Google play app with fdroid app if the app is available in both sources

There are apps with DIFFERENT versions in fdroid and play store (e.g. Nextcloud Talk, FairEmail) with functions only available in play store (Talk: system notifications; FairEmail: connect to Outlook 365). Forced to update via fdroid kills availability of these app functions.

Stop using BitDefender, we are not on Windows :sweat_smile:


Choose Hypatia instead, it won’t suck your data neither your money. :smiley:


faq does not read like this feature is source-dependant, see faq 14, 156 and 173 (but I might miss something)

It is also possible to get fairemail directly from github, works well and should be the most complete version in terms of available features (requires deinstall if old and reinstall of new version/source - previous backup of settings recommended)

(edits to avoid bloated link-boxes)

Issue opened here relating to my post above.

1 Like

Which bank, which app?

Thank you but I think yes: look at the third last point of FAQ173 and at FairEmail | F-Droid - Free and Open Source Android App Repository:

Note that OAuth was not approved by Google, etc for the F-Droid build. For this you’ll need to use the Play store version or the GitHub release

B.t.w.: I was authorized before oct 22.

Certainly! I did this on the previous phone. But what is the point of a store if I have to install and update manually?

Anyway: I think there should be an option in AppLounge (system-wide or per app).

1 Like

Well, I rolled back to v1.6. There were bumps, as there always are with rolling back but I managed to overcome them. The Migrate apps helped a great deal and made things a lot easier. There was a learning curve and Migrate failed on really secure apps like Briar and Signal (both text apps), Clock (never found anything that could back up my alarms :slight_smile:) and one of the games (Cats and Soup) but for the most part, it restored everything properly. Some of the permissions weren’t restored correctly and Migrate doesn’t back up system settings but, all in all, a more positive rollback experience then I was expecting.

Hope you figure out the overlay issue and put out a new version soon. I’ll keep an eye on the change log for the fix and won’t upgrade until I see you’ve fixed it.

Some links to Migrate on the Google Playstore that may help people who want to roll back. It’s also installable from the App Lounge -

FP3+ v1.7r stable, not rooted.

Still seeing variable boot times as initially reported for v1.6r with the bouncing dot lasting from 10 seconds to over a minute.

Looks like it’s targeted for v1.9.

Following on from this, I’ve spent this afternoon re-installing /e/OS v1.7 by reverting back to the stock Fairphone OS and then installing /e/OS v.1.7 over it. I didn’t do this beforehand.
This seems to have solved the issue with the night light (it now comes on and adjusts screen colour temperature automatically), but not the other issues. If other FP3 users have the same issues I suspect they’re to do with Android rather than /e/OS.

Vendor Name: Samsung
Device name: Samsung S8 SM-G955F
Device CodeName: dream2lte
Version of /e/OS or Stock which existed previously: 0.23
Version installed now : 1.7-r-20230110250404
Is the device Rooted / Not rooted: Not rooted

  • Add the end of the update, I got a notification Finishing the update with a progress bar. I waited, but nothing happed. Did not disappear after rebooting several times. Although the progress bar changed back and forth after reboot.
  • AppLounge : When I update an app, it gets stuck after downloading. Apps ar not updated after reboot. Also updating one by one does not make a difference.
  • Shades of folders should be uniform (see picture from gcher495)
  • Screenshots can’t be edited. The edits are not being saved. Other images can be edited

OTA update, seems OK on Fairphone 3 here.
It even seems Osmand starts faster, and its early convergence before getting GPS signal is way faster (tried in the same known wifi background). Citymapper still fails (like before indeed, I think it started crashing around v 1.6 or even v 1.5)