Feedback for v1.7

Have you tried to re-install e-1.7-s ?
(you may have to re-download it because “delete update file after install” is the default setting in the system-updater feature).

you mean wiping the device and re-installing it from scratch? That would be my very last option: I’d like to try to somehow recover the system without loosing data, if possible.

NO, i am talking about a dirty flash over existng without wiping anything

So that would be “reboot to recovery” instead of “reboot to bootloader” next time the phone crashes and gets into recovery mode?

I installed /e/OS 1.7 on a fairphone 3 (1.7-r-20230110250404-stable-FP3) yesterday and I have/had some issues already explained:

It happened to me after installing /e/OS 1.5 also. Yesterday, after the first reboot, the screen was completely yellow/green with horizontal lines each ~ 2 cm. After the second reboot, screen a little blue and some vertical lines, third reboot the display was perfect.

Same here. The message app still crashes when I select a conversation. I tried cleaning app cache, restarting the phone, cleaning “trebuchet” as it was suggested and it worked perfectly on /e/1.5 (didn’t go through 1.6 it seems).

(I wanted to try sending and receiving mms and consequently isn’t possible as I cannot see and answer messages: under 1.5, the issue of sending and receiving mms without activating “mobile data” appeared again and I couldn’t check “developers options”, there wasn’t anything in the list when I clicked on it).

Did someone find a solution for the crashing message app? I think I read through all the comments :sweat_smile:

Samsung S7
Android v10

My camera crashes more than one would expect.
I cannot use speaker mode, the other end report an echo. In addition an echo also seems to exist when in normal use mode too.

Thanks for a great privacy phone !

In my case, I believe the vertical-line problem is completely unrelated to /e/OS after all, as I’ve found mention of this on old Sony forums showing a line in the exact same position running the stock ROM.

Hi @Denis_O, it is worth going slowly. I am not sure if you are the first to report on the OTA Android version Upgrade for the Samsung S8 on this forum.

I believe there were some difficulties arising in Testing, but the #ota-upgrade did seem to receive considerable testing there. You can check out a recent #development-updates for further brief synopsis of the OTA Android version Upgrade.

With exact descriptions of your device and Android versions you might also receive support from

Not sure if there’s a better place for this question…if there is, let me know where I should ask.

  • Vendor Name: Teracube
  • Device name: 2e
  • Device CodeName: emerald
  • Version of /e/OS or Stock which existed previously: 1.0
  • Is the device Rooted / Not rooted: I didn’t root it, I’m not sure if e foundation rooted it before sending it to me though

I have a Teracube 2E ordered from the e foundation with E/OS already installed about a year ago. I periodically got update notifications and installed them, the last was 1.0 on May 16, 2022. Never had any installing updates

A couple days ago, I got a notification that there’s an update and when I went to install it it said it was version 1.7 and had the date 2/10/23. I tried to install anyway, but it restarts it’s in Recovery Mode and gives a few options: Reboot system now (restarts without updating), Apply update, Factory reset and Advanced.
Then it says “E: footer is wrong
Update package verification took 0.0s
E: signature verification failed
E: error: 21
Installation aborted”
Other than reboot system now I haven’t tried the other options because I’m not sure what they’ll do.
Has anyone else had the same issue? Or knows if it’s alright to choose Apply Update.

I’m also wondering why I didn’t get any notifications about updates 1.1-1.6 and if that has something to do with why it isn’t working?

Would like to update my phone, but am not sure what I need to do and I don’t want to brick it or lose my data. Any help/advice will be very appreciated

That’s a known issue for that model, with and w/o speaker on
@Manoj can you provide some feedback on whether that is worked on or alike? there’s a number of gitlab issues as well, they are mentioned + spread over the above linked thread. S7 is a great phone imho and some users purchased it from /e/ shop years ago. Therefore it would be great to know … :slightly_smiling_face:

In case nobody has an immediate idea about your specific situation, perhaps the search has something … Search results for '"error: 21"' - /e/OS community

@AnotherElk, thanks I took a look to see if I could find anyone with a similar issue, but didn’t try that search which turned up enough information to put me on the right track.

Waiting to hear back, but am hopefully I be able to get my phone updated before hitting the anniversary of my last update.

GS 290
/e/ OS 1.7/20230110250405
Not rooted

I have an initial installation via Easy Installer. Everything went smoothly and it continues to run without any problems. One minor annoyance is notifications from the app stores. I have F-Droid, App Lounge and Aurora. If an update comes somewhere so you see the notfication. Unfortunately, it remains active after the update is installed. The remedy is to stop the service and restart it.

Finally got the 1.7/Android 11 upgrade for Samsung G8. The update was absolutely seamless and the result is a huge step up. In particular the Norwegian mobile payment app Vipps, public transport tickets on Ruter and the door control app Unloc all now work. /E/os 1.7, for me at least, delivers 100% of the functionality I need :slight_smile: huge kudos to everyone involved.

1 Like

Same bug on sms app. The app crashes when I click on a message to open it.
Fairphone 3+
I tried to clear data & cache but the bug is always here.

About GPS no more working on S9+ for some apps since 1.2 (#5984) · Issues · e / Backlog · GitLab,
on feb. 8th, 2023, the bug was no more active : GPS working as expected in Naturalist and TracBook apps + no more “Bad GNSS date time” error in GPSTest.
But just waiting for it to be back, as it always did since the beginning …
See follow up with 1.8.

I solved my problem by :

  1. force Message app to stop
  2. renaming Message folder
  3. running Message app created a new Message folder
    Now Message app works well.

Vendor Name: Fairphone

  • Device name: FP3
  • Device CodeName: Where is it?
  • Version of /e/OS or Stock which existed previously: /e/OS 1.6
  • Not rooted

Issue: In the message application, when I click on a discution thread the application crash

Note: I don’t have backup because I don’t know how to do it, why you don’t make it automaticaly before any upgrade? because many people don’t now how to do it, especially on smartphone. I have the impression to be trapped.

Thank you soooo much! It worked for me as well.

Concerning the missing Izly app, I’ve made a topic about it here : Missing IZLY app on Samsung Galaxy S7
Any help is welcome