Feedback for v1.8

This is a problem that was introduced with the 1.8.1 update for me. Before, the problem did not exist (FP3+ from 1.7-r stable to 1.8.1-r stable).

I have detected a bug !

If you go to Parameters > Update and clic three vertical dots Show release notes, there is an error 404 Page not found.

The link is https://gitlab.e.foundation/e/os/releases/-/releases/v1.8.-s but should be v1.8.1-s · e / os / releases · GitLab

This same bug happened to me yesterday … I would say for the first time since I’ve been on e-OS (nov. 2019) … but not 100% sure … may be 1 other time a long long time ago.
S9+ SM-G965F - e-OS 1.8.1-20230207257879-star2lte (Q dev)

Hi!

I’ve tried to install eOS, of the two versions mentioned in the subject, with the help of TWRP. This failed, badly. The settings app always crashes, when doing so. And TWRP wants me to “Enter Password for User [0]”, but doesn’t accept any password I’ve defined. I’ve tried several eOS and TWRP versions.

Now I can’t make any nandroid backups, and I can’t root the device. I need to use the e-Recovery (that works).

Can the recent versions of eOS make work with the recent versions of TWRP?

Bye, Volker

  • Fairphone
  • FP4
  • Updated from 1.7 to 1.8.1-s-20230203257059-stable-FP4
  • Not rooted

The update went ok, but it took like two hours. I tried keeping the screen on, but it was so slow, that I eventually gave up and just let it do the upgrade in the background. In the end, it worked out ok.

Gigaset
GS 290
Updated from 1.7 to 1.8.1-20230203257075-GS290
Not rooted

Update at the late hour. Everything went smoothly and took 15-20 minutes. The new version gives no cause for complaint.

  • Vendor Name : Oneplus
  • Device name : 8T
  • Device CodeName : kebab
  • Version Stock rom which existed previously : OOS 12, downgraded from OOS 13
  • Is the device Rooted / Not rooted : Yes

Vendor: xiami
Device: redmi note 9 pro
Codename: miatoll (joyeuse)
Version: e os 1.7
Rooted with magisk

Perfect update with no problems

Same here with FP3+ (not rooted) and 1.8.1. Freezing 3 times during the day. Also battery drain to zero. I guess I have to reactivate my FP2 for the next month :frowning:

FP3
1.8.1-s-20230203257074-dev-FP3
Not rooted

The phone often freezes for several seconds since the update. A few times I had to reboot the phone by pressing the On-Off-button for more than 10 seconds.

Vendor Name: OnePlus
Device name: Nord
Device CodeName: avicii
Version of /e/OS or Stock which existed previously: 1.7-r-dev
Is the device Rooted / Not rooted: Rooted

Update yesterday without issue, stay tuned

Thanks for the tip. Do you know why splitting screen is so complicated now? It used to work perfectly with a long press on the square button.

  • Samsung
  • Galaxy S8 (SM-G950F)
  • release before update: /e/ 1.7
  • Not rooted

Symptoms:

  • Notification “Finishing system update” with the progression bar at random stages is constantly displayed.
  • Camera saves pictures with a green overlay
  • Was unable to mark an SMS as “sent” until reboot (but the SMS was sent before it was maked as sent)
  • unable to answer phone call (“Accept” button unresponsive
  • Device keeps rebooting randomly (espacially when external power is connected)
  • unable to update any application (data gets downloaded until progression reached 100%, but it doesn’t switch to “install” after that)

Also, regarding the new way of splitting the screen, I dont get it. What is meant by “now you have to long press the icon app over the window app.”?

I don’t know but in LineageOS with android 12 it’s the same way and /e/OS it’s a fork. It can also be a change from android version.

When you push the square button you will see an icon over the floating window.
English isn’t any of my native languages, sorry.

Vendor Name: Samsung
Device name: Samsung S8 SM-G950F
Device CodeName: dreamlte
Version of /e/OS or Stock which existed previously: 1.7-r-20230110250404-stable-dreamlte
Version installed now : 1.8.1-r-20230204257076-stable-dreamlte
Is the device Rooted / Not rooted: Not rooted

Not having any issue stated by @Denis_O.

Issues experienced :

  • Split screen (Tiling) disappeared
  • The small colored light indicating notification/charging never lights up anymore

Otherwise, everything works great ! Well done :slight_smile:

Came here to confirm this! The link is pointing to the wrong URL.

The way to enable this has changed, see e.g. here (I can confirm it works on 1.7-s-20230111250406-dev-FP3) …

https://smartphonetutorials.com/split-screen-android/

1 Like

No worries, so indeed it works that way:

  1. open a first application (A) normally by shortly tapping on the icon
  2. quit application A, then open a second application (B) normally by shortly tapping on the icon
  3. tap briefly on the square button, then scroll to the first application from the recent apps list
  4. once found, tap on the icon located at the top of the app and select “split screen” from the menu
  5. select the second app you want to display on the lower part of the split screen by scrolling from the app list again. This time, just tap on the app instead and you’re done.
3 Likes
  • Vendor Name: Samsung
  • Device name: Galaxy A5 (2017)
  • Device CodeName; a5y17lte
  • Version of /e/OS or Stock which existed previously: e-1.7-r
  • Is the device Rooted / Not rooted: Not rooted

More a Question here, there I may missed the answer: Did this Phone get an update to e-1.8.1-r?