Feedback for v1.8

  • Vendor Name: Sony
  • Device name: Xperia XA2
  • Device CodeName; pioneer
  • Version of /e/OS or Stock which existed previously: e-1.8.1-s
  • Is the device Rooted / Not rooted: Not rooted

Everything works fine as far as I can tell! I nice job from developers!

Hi.

After I installed eOS 1.8.1, the BlissLauncher crashed and crashed and… It crashed and was restarted and crashed again and so on.

I was able to download Nova Launcher from apkmirror.com and install it over ADB. Then I set it as the Start Launcher (in the App Info of BlissLauncher). After a reboot, it worked with Nova.

My device is a Xiaomi Redmi Note 8T, codename “ginkgo”. It wasn’t rooted when this happened. Before, I had tried to install former versions of eOS, but failed because of incompatibility with TWRP.

Bye, V.W.

Fairphone 3+ updated to V1.8 but having battery drain issues. Previous version normally would finish the day with approx 30% battery left. Since uograding to V1.8 battery drain noticeably higher, having to charge phone before end of day. Tried removing battery, restarting phone etc, no difference.

1 Like

Fairphone 4
Update Version: 1.8.1-s-20230203257059-stable-FP4
Previous Version: whatever the previous e/os version was.
Rooted: No

Issues: Nationwide (UK) banking app no longer loads (no app update) even after clearing cache/storage and reboot.

Is there a ticket for the problems encountered on the FairPhone 3+ following this update?

My FP3+ looks OK; it can still last more than two, even three days.
Is there any app that shows a weirdly high usage % in the stats given by the Battery section of the global settings? I think some users clear the cache of some apps (even sometimes of the Bliss Launcher?) to get rid of such post-update issues, but I never had them myself so I can’t tell much.

Hi,

today I got a message that my sd-card should be formatted because it wasn’t readable (my main storage, keeping pics and so).
There are some 15 GB of music on it and my recent photographs, two reasons to regret loss as well as copy-time.
So I shut down the phone, took out the sd, inserted in my laptop - all readable, all fine.
Put it back in again, rebooted - all fine.

Then I installed v1.8.1 on my FP3+ today (previous was 1.7., not rooted).
Went smoothly, except the missing of a reboot option which I replaced manually.
Looked for the battery, and found this:


The portrait view presented this, though:

49 days?

I have recently kept record of my charging cycles to optimize battery capacity, so I’m sure that it got fully charged on February 4th, 12 days ago.

What is wrong with the phone?

Vendor: Fairphone
Model: FP3
Version: 1.8.1-stable
Previous version: 1.7-stable
Rooted: No

App Lounge keeps crashing and is unusable. Advanced Privacy crashes occasionally, but I’ve noticed this behaviour previously.

Yesterday, I had a tiny scare when the Gallery did not show my pictures, Telegram FOSS could not send any and Signal immediately crashed upon opening the image selection.

Has this release been tested thoroughly?

Another restart, after the one initiated by the update, seemingly fixed the problem. I’ll continue observing the system behaviour, though.

Meanwhile I am charging slowly. During this - lasting but battery saving - process it appears that the display of the actual loading graph keeps being a mess and it is additionally lasting a bit for it to refresh, some five seconds at least.

As I meant to demonstrate the difference between the battery graph and the percentage on the top with a screenshot (79%/80%), I became aware of a defunct Warpinator-app.
As I use Linux Mint, I used to exchange data between telephone and desktop with it, which worked flawlessly ever since.

Now I do not get a connection in spite of being in the same WiFi, as my desktop says it’s waiting on the correctly recognized phone, displaying name and IP adress, but the phone says that there are “no devices for sharing available”.
Trying on.

Update: After rebooting it works again.
Here is the screenshot:

As you see, the percentage differs.

After fully charging all seems normal again, no mess in the graph, no made up days.

Gallery app suffers from a serious issue since 1.8.1 on some devices.

The bug is already opened on Gitlab: https://gitlab.e.foundation/e/backlog/-/issues/6658

Another observation of something that I haven’t experienced before the update: Upon deactivating flight mode this morning, my phone notified me about an issue with my MicroSD card (SanDisk, 64 GB, in use for about four months).

When I tapped the notification, the configuration wizard appeared, asking me to format the card, which I promptly declined. The SD card thus remained inaccessible, e.g. through the File Manager app, and couldn’t be selected as a storage location in other apps, such as OpenCamera or Signal.

Once again, a restart mitigated the problem but all the ruckus made me wonder if the OS is very reliable after all.

1 Like

Just some minutes ago Android felt so loved and complete because somebody out there still thought it was very reliable. It was but a brief dream.

Don’t expect overall software quality on consumer devices. Always expect the unexpected … or at least let’s say don’t be surprised about the unexpected.

3 Likes

About GPS no more working on S9+ for some apps since 1.2 (#5984) · Issues · e / Backlog · GitLab, after updating to 1.8.1 around Feb., 11th or 12th, the bug goes on staying inactive (has been so with 1.7 at least since Feb. 8th) : GPS working as expected in Naturalist and TrackBook apps + no more “Bad GNSS date time” error in GPSTest.
Now waiting for it to be back in a few days, as it always did since the beginning (no more than around 2 weeks inactive) …

Sorry, but that’s nonsense. I work at a software development company and if we were to ship products this reliable for our customers embedded devices - some of them even Android based - then we would soon be out of our jobs.

Of course, your approach to forming expectation is just as valid.
There’s only potential for negative surprises this way, though. Perhaps I just want to have potential for positive surprises. Not that I could recall many of those, but … potential.

2 Likes

Ah, okay. Then this was just a misunderstanding on my part, informed partly by the fear that something would happen to my saved files.

corrupt sdcard after ota update is often reported and I’ve seen it myself. SD card not useable - #3 by Herve5 … it’s hard to debug as you’d need the recovery and system itself on debug settings to print early boot logs to see what’s happening in both environments. Reboots help because a filesystem check on boot is run that can fix things depending on kernel fs driver version

2 Likes

if you’re into docker there’s an easy debug app (“battery-historian”) to see what is waking up the device. Could just be some short sync interval somewhere - Moto battery drain comparison - #15 by tcecyk

After cleaning cache of all apps ui runs smooth again. Try:

3 Likes