Feedback for v1.9

Maybe try to purge cache and data from those apps, enable temporarily trackers in advanced privacy. Then reboot the device and try again.

1 Like

Thanks, I just purge cache and data for the 3 apps.
It solve issues for “notes” and “applounge”.

Camera still have the same behaviour, even without privacy settings. For the moment, I will use “open camera” which seems working well.

Vendor Name: Xiaomi
Device name: Mi 9T
Device CodeName: davinci
Version of /e/OS or Stock which existed previously: 1.8.1. / 1.7 / 1.3
Is the device Not rooted

Links to my trouble reports

Camera without function Xiaomi Mi 9T - #10 by Gianna

Feedback for v1.7 - #150 by Gianna

Xiaomi MI 9T (davinci) - /e/OS-Q eRecovery mass failure

Nothing has changed since /e/OS version 1.3. All errors are still there and can be reconstructed.

I still can’t install the /e/recovery and have to use the TWRP recovery.

Still the triple cameras (wide, ultrawide, telephoto) and the motorized pop-up selfie camera are not recognized and get error messages. Also the known camera app alternatives do not work.

Side note: The Google infected PixelExperience davinci-13.0-20230221-1523-OFFICIAL ‘stable’ works flawlessly.

Please note the “previously” (if not everything else) :wink: .

Can’t confirm on my Fairphone 3 running 1.9-s-20230311268558-dev-FP3. Mail is running just fine, but I updated from 1.7-s-20230111250406-dev-FP3, not from 1.8.1.

Did you try to reboot the phone again to see whether this makes a difference?
You could also clear the Mail App’s cache in Settings - Apps - Mail - Storage and cache - Clear cache.
(Don’t clear storage there without a backup of your Mail settings and without your mails being located safely not on the phone.)

1 Like

Sorry about the previously… but I did make a feedback about 1.8.1 s dev also : it was very slow and buggy.
v 1.9 is not.
I tried to clear cache but it didn’t solve my issue. Then I installed k-9 Mail and it works just fine. Then I tried to clear cache and data of Mail. It allowed me to set it again. I worked for a while and then again it start closing immediately after launching. So I’m simply using k-9 Mail for now till further release.
With this compromise (using k-9 Mail instead of /e/ OS Mail app), v 1.9 s dev is very fast and snappy on FP3+.


Vendor Name: Fairphone
Device name: Fairphone 3
Device CodeName: FP3
Version of /e/OS or Stock which existed previously: /e/OS 1.7-s-20230111250406-dev-FP3
Is the device Rooted / Not rooted: Not rooted

No issue with updating, now on 1.9-s-20230311268558-dev-FP3.
The following things work for me:

  • Call / be called
  • Send SMS / receive SMS
  • Notification LED
  • Alarm
  • Internet via Wi-Fi
  • Internet via mobile network
  • Wi-Fi hotspot
  • Location
    • Settings - System - microG - Self-Check: all ok, including location permissions
    • Settings - System - microG - Location modules - Mozilla Location Service: enabled, configured for using Wi-Fi and Cell
    • Settings - Advanced Privacy - Location: Exposed
    • Settings - Advanced Privacy - Manage my location: Use my real location
    • Settings - Location - Location Services - Wi-Fi scanning: enabled
    • Settings - Location - Location Services - Bluetooth scanning: disabled
    • Settings - Location - App location permissions - “Allowed only while in use”: Apps are listed
  • Compass
  • Screenshot
  • Main camera (original FP3 Camera module, not +) photo + video
  • Selfie camera (original FP3 Top module, not +) photo + video
  • USB connection to PC / MTP
  • MyPhoneExplorer 2.0
    (nightly 27.01.2023 - for sync with Betterbird instead of Thunderbird)
  • Bluetooth (music playback, data connection)
  • Exposure Notifications
    • Needed to be installed again according to documentation
    • Needed permissions again according to system notification and respective message in Settings - System - microG - Exposure Notifications
Vendor Name - Fairphone
Device name - Fairphone 4
Device CodeName FP4
Version of /e/OS or Stock which existed previously 1.8.1 - s
Is the device Rooted / Not rooted - not rooted

Fine !

Thanks to the team.

  • Vendor Name
  • Fairphone
  • FP4
  • /e/os 1.8
  • rooted

update took some time but worked flawlessly - pleased to see that the (not working) lense is now gone (was no problem, just annoying). camera delay with moving objects seems faster now (will check this further).
thank you for the good work! never felt so satisfied with a phone/sw-combination :wink:


  • Vendor Name Samsung
  • Device name A3 (2016)
  • Device CodeName a3xelte
  • Version /e/OS previously 1.8-q-dev.
  • Device Not rooted

1.9-q-20230312268823-dev-a3xelte OTA download took longer than usual. I saw the download stop around 90% but was able to get it to resume. Actual update no issues.

Camera app (v 1.50.1) crashes on launch. As Post # 104.

Clear storage makes no difference. I did not notice the issue at first as I find Secure Camera performs better.

Edit It tuns out Secure camera takes stills but fails to take video.

In a logcat Camera Errors start at this point.

03-20 10:59:55.956  2360  2360 I ExynosCameraInterface: INFO(HAL_camera_device_close[234]):camera(1) TORCH_MODE_STATUS_AVAILABLE_OFF
03-20 10:59:55.956  2360  2360 I ExynosCameraInterface: INFO(HAL_camera_device_close[236]): out
03-20 10:59:55.956  2360  2360 D ExynosCameraInterface: DEBUG:duration time(    5 msec):(HAL_camera_device_close)
03-20 10:59:55.956  2360  5570 V Camera2WrapperCbThread: Process: Exit Thread
03-20 10:59:55.958  2254  2254 I hwservicemanager: getTransport: Cannot find entry in either framework or device manifest.
03-20 10:59:55.961  2403  2651 I CameraService: disconnect: Disconnected client for camera 1 for PID 2403
03-20 10:59:56.012  2403  2651 E CameraProviderManager: isHiddenPhysicalCameraInternal: Failed to getCameraCharacteristics for id 0
03-20 10:59:56.012  2403  2651 E CameraService: supportsCameraApi: Unknown camera ID 2
03-20 10:59:56.013  2403  2651 E CameraProviderManager: isHiddenPhysicalCameraInternal: Failed to getCameraCharacteristics for id 0
03-20 10:59:56.013  2403  2651 E CameraService: supportsCameraApi: Unknown camera ID 3
03-20 10:59:56.013  2403  2651 E CameraProviderManager: isHiddenPhysicalCameraInternal: Failed to getCameraCharacteristics for id 0
03-20 10:59:56.014  2403  2651 E CameraService: supportsCameraApi: Unknown camera ID 4
03-20 10:59:56.014  2403  2651 E CameraProviderManager: isHiddenPhysicalCameraInternal: Failed to getCameraCharacteristics for id 0

On the issue with the camera app being reported across devices…pl add your comments and logs where possible to the GitLab issue … dev team has been made aware of this issue being reported by multiple users

Hi @aibd there is already an issue on this #6761, you can add your comments under it. The testing team has closed #6782 as it is a duplicate.

Same thing on my a5xelte

Je confirme reproduire ton bug.

Have updated my samsung S10 plus from 1.8.1 to 1.9.
One weird thing is that I got the 1.9 update available a week ago, then about an hour later it disappeared, to reappear a couple of days later, permanently this time.

Does anybody know what is the logic/algorithm for updates availability? - I notice my S7 edge (running q) received updates at least a couple of weeks after my S10 plus (running s) gets them. I also see that some people in other parts of the world start upgrading days (or even weeks) before they are available on any of my phones.

Returning to the upgrade - the upgrade itself went ok and the phone is working well after upgrade. However, there is one issue: this version was supposed to fix advanced privacy (tracker management/blocking) in Shelter. Although I didn’t see it in the list of items fixed/added to the 1.9 version, I noticed that now Advanced privacy in my main profile (the personal profile) finally shows the apps from the work profile too (the Shelter’d apps). However, enabling or disabling tracker blocking on the Shelter apps doesn’t seem to have any effect - they are always blocked (unless I turn the tracker blocking feature completely off).

English bellow

Après de nombreux essais avec différents recovery: /e/recovery, TWRP, OrangeFox, Lineage recovery, j’arrive toujours à la même chose en mettant à jour vers 1.9-s. Quand je redemarre sur /e/, la version reste sur 1.8.1-s.
Que je fasse la mise à jour via OTA ou adb sideload, c’est la même chose.
J’en venais donc à me demander si l’image proposée sur le site est bien la bonne.

Pour en avoir le coeur net, je télécharge pour l’installer via adb sideload.
Le reboot se passe bien sur Lineage ce qui prouve que je réalise bien les bonnes étapes de mises à jour.
Mais, LineageOS est en version 1.8 datée du 03/02/2023 !!!

Le problème ne pourrait pas justement venir de l’image de Lineage du coup ? soit c’est toujours la 1.8, soit c’est bien la version 1.9 mais sans que les éléments l’identifiant aient été changés ?

Merci pour vos aides.
Pour rappel :

Vendor Name Xiaomi
Device name Mi10T Lite
Device CodeName Gauguin
Version of /e/OS or Stock which existed previously 1.8.1
device Not rooted

English version

After many tries with different recoveries: /e/recovery, TWRP, OrangeFox, Lineage recovery, I always get the same thing when updating to 1.9-s. When I restart on /e/, the version remains on 1.8.1-s.
Whether I update via OTA or adb sideload, it’s the same thing.

So I was wondering if the image proposed on the site is the right one.

To be sure, I download to install it via adb sideload.
The reboot goes well on Lineage, which proves that I am doing the right update steps.

But, LineageOS is in version 1.8 dated 03/02/2023 !!!

Couldn’t the problem come from the image of Lineage ? either it’s still 1.8, or it’s the 1.9 version but without the elements identifying it have been changed ?

Thanks for your help.

As a reminder:

Vendor Name Xiaomi
Device name Mi10T Lite
Device CodeName Gauguin
Version of /e/OS or Stock which existed previously 1.8.1
device Not rooted

Could also be build type (aka release channel) related, usually dev builds are out for a few days or a few days more, then stable builds follow (where applicable, not all devices get those) …

  • Vendor Name Fairphone
  • Device name Fairphone 3
  • Device CodeName FP3
  • Version /e/OS previously 1.8.1-r-stable
  • Device Not rooted

The OTA upgrade to 1.9-s-stable showed up around noon, both download and installation went smoothly. After rebooting the device through the updater (no notification about a pending restart was given) the fingerprint sensor did not work as expected. Another reboot solved this issue, however, and the phone works flawlessly. Even the abnormal battery draining has somewhat disappeared.


Not rooted
The version upgrade to Android S came OTA with the update to 1.9.
All went smothly, taking approx 30 min including download.
Everything is working fine, as far as I can see.
Thank you to the team!

1 Like
Vendor Name - Fairphone
Device name - Fairphone 3+
Device CodeName FP3+
Version of /e/OS or Stock which existed previously 1.8.1
Is the device Rooted / Not rooted - not rooted

After checking effectlessly for a few days the update dropped in today.
Installation went smoothly, this time it asked for a restart.

First impressions:

  • Instant information was that my SIP-account got deactivated in Android 12. Though I regret that as I use it for communication on events with a DECT/SIP environment, I appreciate it a lot to be informed right away.
    Solved this by installing Baresip+, which seems to work flawlessly so far.

  • I noticed the restart of the battery statistics (no data from before the update).

  • Being new to Android 12 I found it strange that now another button opens the screen (sound down instead of power).

  • The fingermark sensor was useless as it didn’t work though accessible in the Settings, a fingermark was saved and the function turned on. Instead it didn’t open neither the phone nor the corresponding apps. I could solve that temporarily by recording a new fingermark, which changed the behaviour to the known.
    Sadly I deleted the “old” fingermark as to avoid confusion.
    Now there was one fingermark recorded - but the single one did not work anymore.
    It was impossible to record another one (adding greyed out), so I tried to delete the new one being able to record another to regain access to the ticket wallet and unlock the phone by fingertipping - to no avail: Deleting had no effect as the fingermark kept reappearing in the settings.
    So I tried a reboot (though I know that this doesn’t qualify as a repair technique) and luckily there was the old fingermark and the add-option was available again. Left two in the settings now.
    Seems solved so far.

  • Android 12 in general seems faster than 11 was, though a few things (design and paths) seem uncommon to me, and as for design I find few options to change, e.g. the clock on the lock screen.

We’ll see how the battery usage develops.

Thanks for the good work.

Here’s a useful one for the clock …

1 Like

Thanks for the hint, though it doesn’t make a difference.
The clock is still left bound and no other options are available (font, bounding, 12/24 hrs…).

Also the drop down menu at the start screen seems unchangeable, though it seems to me like a waste of space: There was more information ready before on less space and easier to access.