Feedback for v2.1

Thanks a lot for this comprehensive answer.

Right after posting, I switched off the phone, removed the SIM card and inserted it into an old phone for testing. SMS receiving was down on the old phone as well.
After 10 minutes, I received a flurry of pending text messages. SMS receiving was active again.
I placed the SIM card back into the Fairphone, and SMS receiving is still active.

Problem solved. Some of the steps I took match actions you suggested.

The cause of the problem remains unclear : software/data glitch during the update? SMS service failure on the provider side? Anyway, I’m glad to receive text messages again :slight_smile:

Warm thanks for your help.

1 Like
  • Vendor Name: Fairphone
  • Device name FP4
  • Device CodeName (what is this?)
  • Version of /e/OS or Stock which existed previously 2.0 …
  • Is the device Rooted / Not rooted - Not rooted
    FitBit app quit working - when I select to log in using existing google user, it immediately exists saying there was a problem. Other apps where this also occurs indicates that the internet is not available. Other apps are using internet fine, both cell and wifi.
    GBoard - similarly the voice typing which sends data to google, quit working. Other keyboard features are still functional.
    I’ve tried uninstalling/installing fresh these apps, cleared cache & data, manually set all permissions to allow, shut down and rebooted the phone many times, etc.
    Previously my phone had /e/OS 2.0 (something) and these were working fine.
    I really need these to work.
    Is there a way to revert back to previous version of /e/OS?

Galaxy Tab A7 10.4 2020 (Wi-Fi) SM-T500 gta4lwifi

Hello Ben_H
I experience exactly the same problem - you might have seen also the errorcode #401100 shown by the fossil app. I had many exchanges with the support of fossil and they are super quick and friendly, but so far no solution.
Going back to the prior e/os version does not seem to be an easy task to me. Did you manage to solve this problem?

Did you flash these with adb? Could you help me by giving the complete commands?

Please do only this - and nothing else - do not delete or format anything - and in the order described below:

Download both *.zip files.

Unzip only recovery-IMG-e-2.1-t-20240605406922-dev-instantnoodlep.zip
This contains the three *.img files (1., 2., 3.)

Then boot your OP8pro into FASTBOOT mode and execute:

  1. fastboot flash dtbo dtbo-e-2.1-t-20240605406922-dev-instantnoodlep. img
  2. fastboot flash vbmeta vbmeta-e-2.1-t-20240605406922-dev-instantnoodlep.img
  3. fastboot flash recovery recovery-e-2.1-t-20240605406922-dev-instantnoodlep.img

  1. Now reboot into e-recovery to verify the installation
    Use the menu to navigate to and to select the RECOVERY option

In /e/Recovery select Apply Update and in next screen Apply from ADB
On your PC console type the below command:

  1. adb sideload e-2.1-t-20240605406922-dev-instantnoodlep.zip

  2. Reboot to system

Happy upgrading without data loss :crossed_fingers:

1 Like

Hi there
Multiple feedback at once :slight_smile:

  • Fairphone 4
    Upgraded to /e/OS 2.1 : working really great so far !! Thanks Team !

  • Galaxy Tab S6 Lite (Wifi)
    Installed /e/OS 2.1 from scratch … some issues :

  • BlissLauncher3 :
    Apps icons and widgets are off-centered to the right, slightly in portrait mode, a lot more in landscape mode.
    Apps from the dock are misaligned with its “shadow” : they’re slightly up, both on the normal dock and on the floating dock in the multitasking view.

I tried to report the bug on the BlissLauncher3 Gitlab, but I could’nt find where to fill the issue. I’m not in the Testing Team, should I be to do so ?

  • Conflict with Lawnchair 14
    I installed Lawnchair 14 beta 2 (FOSS Pixel Launcher clone) on both Fairphone 4 and Galaxy Tab S6 Lite.
    Works very well on FP4.
    Is in conflict with BlissLauncher3 on the tablet : even when I select Lawnchair 14 as my default launcher, BlissLauncher3 seems to try running, and I get error messages of BL3 crashing.
    The navigation bar (for gestures) keeps flickering. Very annoying.

That’s it for today

Keep Up The Good Work !

Nicolas

Bliss reports are tagged at Gitlab as Launcher.

2 Likes

Xiaomi 11 Lite 5G NE lisa 2109119DG

  • Vendor Name: Xiaomi
  • Device name: 11 Lite 5G NE
  • Device CodeName: lisa
  • Version of /Stock which existed previously: MIUI 14 Global 14.0.11 (Android 13)
  • My device is Not rooted

The installation instructions for /e/OS-T V2.1 show all the necessary steps correctly, so that ‘lisa’ started without errors.

The /e/documentation should be updated, as it still refers to stock Android 12, …

… although Android 13 (MIUI 14) and Android 14 (HyperOS) stock firmware have long been released.

WARNING! Since HyperOS (A14), the Xiaomi waiting time for unlocking the bootloader has been extended from previous 168 hours (7 days) to at least (720 + 72 hours (30 + 3 days). See also here :arrow_heading_up:

Could you please share a github link of this clone? If I copy the official github page for Lawnchair 14 in Obtainium I only get a 2018 release. Also on FP4 with v2.1.

Vendor Name: Fairphone
Device name: FP5
Device Code Name: fairphone-fp5
Version of /e/OS: /e/OS 2.1-t-20240603406607-stable-FP5
Is the device rooted: Not rooted (from the /e/OS Store)


I have used my FP5 daily since the latest update and it keeps restarting at random, even during calls. It has happened when I was in a call, when I browsed my files, when I texted in Signal, browsed the internet +++

I have used the factory reset function, but still have the same problem.

@StigtriX what steps did you do to securely backup all your files/apps before you did the factory reset? Do you advice to factory reset when i have problems with this update?

@fairiphono
I just saved my backup for contacts, Birdly, Notally and NewPipe + pictures to my Linux PC and Proton Drive. I don’t mind reinstalling the other apps I use, as they do not contain data that I can lose.

Hi. On my FP4 (2.1-t-20240603406607-stable-FP4) with Lawnchair (but version 1.2.1.2001) a long tap on the raw bottom-left make a system reboot.
Can you reproduce this behaviour?

I’ve noticed that I can’t hide the persistent “Your Pebble is connected” notification for the Pebble app since I updated to 2.1. I can turn them off for the app in Settings, but they still show up. I can long-press the notification, tap “Turn off notifications,” and then toggle off the slider and tap “Apply,” and the notification goes away… But only for a short while. Then it comes back and when I do the same thing again, the slider is back in the “on” position, like the first time didn’t take. And I’ve been doing that for over a month.
If I long-press the notification and tap “More” instead of “Apply” then it takes me to the Settings screen where I can see that notifications have already been disabled for the app, but they’re still showing up.
I tried uninstalling and reinstalling the app and it didn’t help.

A couple of issues:
Google
Pixel 6 Pro
Raven
It was an Amazon refurbished - so I suspect the most recent “official Google” version.
not rooted

I just received it two days ago, and immediately loaded /e/ 2.1. The install went fine, except that the sideload hung at 15%. After an hour, I decided it wasn’t going any further, and restarted the sideload. It loaded fine the second time.

I relished the idea of de-googling a google phone.
First question: The phone has four cameras, counting the front facing, and one with optical zoom. /e/ only allows access to the front and one back camera. Which one is it? Is there any way to select? Is there any way to control the optical zoom?

Bleeding Edge question: I tried a number of sip phone apps, as my wireless service is data-only. The sip phone apps connect to a asterisk server at my office (basically, making it an extension on our phone system). But although I made each the ‘default’ phone, calling out still defaults to normal cellular service through the old phone app, and not through the sip app. How would I disable (hopefully remove) the old phone app?

Speaking of bleeding edge, I have also loaded Android Auto (so much for deGoogling). It all seems to work, except for the default phone issue.

Thanks for great work. No to install the ‘personal cloud’ software.

  • Vendor Name: Google
  • Device name: Pixel 4 (Mod. G020M (Global, International))
  • Device CodeName: flame
  • Version of Stock which existed previously: 13.0.0 (TP1A.221005.002.B2, Februar 2023)
  • My device is Not rooted

Android T (13)

Relocking failed (three attempts)


:warning:
Can’t find valid operating system.
The device will not start.

Locking the bootloader

In /e/OS recovery main screen:

  1. Select Advanced
  2. Select Reboot to bootloader

Once the device is in fastboot mode:

  1. Verify your PC finds it by typing:

fastboot devices

Tip:* If you see no permissions fastboot while on Linux or macOS, try running fastboot as root.

  1. Download the avb custom key
  2. Erase the previous key fastboot erase avb_custom_key
  3. Flash the new key previously downloaded fastboot flash avb_custom_key pkmd_pixel.bin
  4. Lock the device fastboot flashing lock
  5. Use the volume key to select Lock the bootloader

Reboot the device

  1. Use power button to Start the device

The installation was carried out step-by-step according to the /e/Documentation. Relocking was carried out as described above (quoted from the /e/Documentation)

Relocking failed (three attempts)

The avb custom key blocks the reboot. After I had unlocked the bootloader again, /e/OS-T started without failure.


INFO

Then I installed iodéOS 5.2 (7/2024) on the same device. There, the avb custom key is integrated in the CustomROM and does not have to be installed separately. The Pixel 4 (flame) started flawlessly with iodéOS 5.2 and the bootloader locked again - just as it should be.

Yes, but it doesn’t pass safety net ?!

The LineageOS installation instructions for this device, do not mention relocking the bootloader. This usually means that - for LineageOS at least - it is not possible to relock the bootloader and have the device work.

I know that the /e/ OS installation instructions do say you can, and the list in this post also says it is possible for this devcie and Pixel 4xl . But errors in the /e/ documentation are not unknown, and there is no evidence or citation given in the forum post, which also says that relocking is not possible for Pixel 4a, which is pretty similar to this device.

Given all of that, I think it is likely that relocking the bootloader after installing /e/OS (and having the device work after relocking) is not possible.

(I’d be happy to revisit this assessment if anyone has successfully relocked the bootloader after installing /e/OS and has /e/OS working).

LineageOS does not support unlocking the bootloader on any Google Pixel device. Other Android CustomROM distributions, however, do, e.g. CalyxOS, iodéOS, GrapheneOS.

Yeah, the /e/documentation is very buggy. I only use it to test it. Otherwise I install /e/OS my way.

It’s strange that an device-specific ‘avb custom key’ of the Google Pixel 5 (redfin) is identical to that of the Google Pixel 4 (flame) und Pixel 4 XL (coral):
** identical file name, identical download URL:**

P 5 (redfin): 2. Download the avb custom key
https:// images.ecloud.global/stable/pkmd_pixel
P 4 (flame) 2: Download the avb custom key
https:// images.ecloud.global/stable/pkmd_pixel
P 4 XL (coral) 2: Download the avb custom key