First use experience on Xiaomi Mi A1

Hi everyone!

This post documents my first experience with installing and using /e/. Some suggestions, some random notes.

I already had unofficial LineageOS 16 (Pie) and TWRP (3.2.3-0) on the device and installed e-0.2-201811242083-nightly.

a) I found a typo in the installation manual but can’t fix it because I don’t have the permissions.

b) The installation seems normal for Android but it’s too hard for the target audience. That’s no problem in beta but are there plans to create a GUI client that helps users install the system? I think that would help a lot.

c) The manual does not mention that you should verify the sha256sum.

d) First boot works without problems.

e) Impression of the desktop: too much stuff there (for my taste). I’m used to disable stuff but I hoped /e/ would have more sensible defaults.

  • F-Droid missing. How am I supposed to get updates?
  • two keyboards (AnySoftKeyboard and AOSP Keyboard)
  • two flashlights (“Lights” App and System Feature)
  • “Magic Earth” instead of OsmAnd? I assumed /e/ would be a Free Software project. Am I mistaken?
  • Signal is the only SMS-client. I like it and use it that way but I don’t think it should be the default. You can’t use it without registering and agreeing to their TOS.
  • Telegram is nice but I see no reason to have it preinstalled.
  • Even worse than having too many things installed: some things can’t even be disabled (e.g. the Flashlight, Mail, Notes).

f) /e/ forked some apps (io.eelo.browser, io.eelo.mail, foundation.e.weather). Are there particular reasons for forking instead of contributing to upstream?

g) Account Integration: after entering the /e/-Account tasks, notes, mail, calendar and contacts work fine. I think the “/e/ Address book” menu entry when adding an Account is not needed. Even photos get synced automatically.

h) The Dialer App has “Phone number lookup” enabled and uses Google as lookup provider.

i) FM Radio works. :+1:

j) I didn’t test: Infrared, Bluetooth, MiraCast

k) Encryption does not work. I had the same problem on LOS 16 and had to manually shrink a partition to make it work.

It’s a promising start. I wouldn’t recommend it as a daily driver yet, but neither does the project (it’s beta).

The inclusion of a proprietary application makes me worry about the direction of the project. To me Free Software is a precondition for safe, privacy respecting and empowering computing.

Yours,
Hex

edit: picture sync works.

1 Like

Thank you for your feedback. Regarding the proprietary Maps app (Magic Earth), we have a statement about this at: https://gitlab.e.foundation/e/wiki/en/wikis/maps

For the problems, you have found, it would be great, if you open gitlab issues, as explained here: https://gitlab.e.foundation/e/wiki/en/wikis/issues
Some of them are not yet mentioned there.

One reason was, that the other projects have a different focus than /e/ and would probably not include changes that seem necessary for /e/.

Please open a bug report for this on gitlab. This sounds serious and has not yet been reported.

I created issues regarding encryption and phone number lookup.

1 Like

Hi hex-m,

I tried to install the rom to my Mi A1 phone and encountered error. Can you provide instructions on how you mean by should verify the sha256sum?

Hi @spg what build of Stock ROM are you on currently?
To install /e/ have you tried the instructions given here https://gitlab.e.foundation/e/wiki/en/wikis/device/tissot/install

Hi @Manoj,

My current stock ROM is 8.0.

The link you have given is what I followed. Surprisingly, I used the same method when I tried lineage-15.1-20181222-nightly-tissot-signed and it works.

I have shared the link of an old /e/ official ROM. Pl can you try flashing that and let us know.

Hi, I’m trying to flash /e/ to a Xiaomi Mi A1 right now, could anyone help me? I followed some of the directions on the https://gitlab.e.foundation/e/wiki/en/wikis/device/tissot/install install page, and I’m having trouble understanding how to get adb and fastboot to work. Would anyone have commands I can paste into the terminal?
I’m running Ubuntu 18.04.2 LTS, if that helps at all…
And my A1 is running Android pie.
(not pi/e/, yet, :wink:)

EDIT: I got the bootloader unlocked now, trying to flash /e/!!! wish me luck, it’s my first time!

still no luck, I’m doing something wrong. I’m gonna let everything chill for about an hour then try again

EDIT: Please, someone, give me step-by-step directions because I’m really lost.

Isn’t the link above step by step directions?!

yes but I can’t figure out how to set up adb.

If I had a clue what you’ve tried or what errors you’re getting, maybe I could help. Otherwise, I can only suggest duck duck go “how to set up adb”.

Thank you so much @ithink314!!
Actually, I was trying to hurry too much. I slowed down, read everything 3 times, and now it’s working ok!!!
I think I’m about 3/4 through the process, I’ll update when I’m done. This is so exciting! Getting into adb is truly an addictive feeling, makes me feel like a hacker!

1 Like

I got /e/ installed! I’m trying to get Pi/e/, I think it’ll be successful! I’m so happy!!!

And now, officially: /e/ team and devs, thank you!!! You’re amazing!

EDIT: after 20 min, I still couldn’t get Pi/e/. I’ll wait for the ota update!

2 Likes