FP2: Updater does not update anymore

For quite some time, I am using e OS on FP2, and it works reasonably well.
However, since April 2022, the updater does not update the OS anymore, which is a security issue. My installed version is 0.23-20020412177701 (according to Installer). This ia Android 9.
According to theDownload section for FP2 there are newer versions, the latest being Android R from 2. December 2022.
To update my phone, am I supposed to use that image to install it like a new OS (with resetting the whole phone), or is there a way to have my phone updated through the installer, without wiping it?


No. At least not via the Updater.

If you’re feeling adventurous (and in the light of having to be prepared to wipe anyway), you could try to simply install the new version without wiping first.
Worked for me to get my Fairphone 2 from Android 9 to 10 at least, although I wiped the cache partition following a hint here … https://forum.fairphone.com/t/e-q-is-out-for-fp2/69555/7?u=anotherelk


Development of /e/OS Android 9 has stopped, that’s the reason.


Great, thanks @AnotherElk and @MRTN for the valuable inputs. Now I understand why I don’t get any updates anymore. So I will update it to R (beta)/11. I’ll try the adventurous way first, as worked for AnotherElk with Q/10.

1 Like

Be sure to backup all your personal data in advance…

1 Like

Thank you. As @AnotherElk pointed out in Week 25, 2022 : Development and Testing Updates - #12 by Libre, backup is a vast and at times depressing topic, that’s why I don’t like to install a new version. And having synchronized images and addresses automatically I don’t have to do it regularly anyway. Even more challenging when you only have to do it every few years.

And it has stopped partly because it is no longer possible to make Android 7, 8 & 9 builds of Lineage OS (at least not using the documented methods)

1 Like