FP3+ easy installer just stops

Hello!
As I am not really a computer crack, I wanted to use the Easy installer to install e/os on my Fairphone 3+.

My computer is a Dell (refurbished, of course :wink:) and I use Windows 10 and have a Bitdefender antivirus software (maybe that is relevant).

The easy installer recognizes my Fairphone 3+ so up until that I did everything right apparently.
It then downloads the IMG-e-latestFP3.zip file and tells me that it’s installed successfully. The next page shows:
OEM
update to the next version
with this link: https://www.fairphone.com/en/bootloader-unlocking-code-for-fairphone-3/ (I unlocked the bootloader according to description)
I press sound lower/start until Fastboot mode appears.
And then nothing happens and there’s no more buttons to go further and no more descriptions. The last picture is of the phone and two green arrows where the keys for lower/start are
and it again tells me to go into fastboot mode.
My phone shows the fastboot mode with a green START on top, then „Press volume key to select and press power key to select.“
But the last thint on the menu is „Device state – locked“ (is this maybe the problem? How do I unlock it?)

Now because I’m no expert, I probably will have difficulties installing this with all the commands… Any advice appreciated! :blush: Thanks in advance!

Anne

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi Anne,

I prepared an answer already!

How to Easy Installer for Windows stuck after booting the Fairphone in fastboot mode

From Telegram:
Anne: “my phone the green START appears but nothing happens + Everything worked until they wanted me to start in fast bootmode,”
Anonyme: “You have started the Fairphone in fastboot mode, you see the green “START” but nothing happens”

That might be something else, please come back if the first link is wrong for you!

1 Like

Dear Iain, I did accordingly and fastboot mode started the installation. But now it stopped midways… the phone does not budge any more, it’s dead and I cannot restart it by pressing the start-button. Any idea what I can do to resolve this? Thanks!

Unbenannt

Anne, you have documented this well, I think I know the answer, but I am going to step back and let someone with Fairphone experience take over. The phone is fine, sorry if you get no answer till the morning.

No worries, that’s absolutely okay. I am really thankful for this forum, will definitely donate when it’s done. Can I shut down my computer for the night without destroying anything then? :wink:

Absolutely, no problem :slight_smile:

Great, thanks. Have a good night! :slight_smile:

1 Like

It is a problem.
Edit: Ok, it seems not to be a problem for the Easy Installer.

The description you linked to doesn’t actually unlock the phone, this one does currently …

(Fairphone rearranged the unlocking pages in the past at least once, this could be an incomplete part which only gets you the unlocking code and lets you enable the unlocking that has still to be done. How did you find this page?
I don’t know much about the Easy Installer process, perhaps it is supposed to do the rest of the unlocking?)

Assuming you did the enabling part in Fairphone OS according to the incomplete description, just get the phone into Fastboot Mode and continue following the complete description from point “3. Unlock your bootloader”.
(If the Easy Installer doesn’t do it itself.)

If the phone doesn’t want to start or reboot, try to force a reboot by keeping the power button pressed for about 15 seconds, or remove the battery for the same time and insert it again, then start the phone.
When rebooting or starting the phone, remember to keep Vol - pressed along the way to get into Fastboot Mode.

Not in her case. The screenshot shows that she’s well past the point where the installer has done the unlocking.

Best thing would be to provide the log file as described in Howto troubleshoot issues with the easy-installer

1 Like

When the installer was at the point of your screenshot, what did the phone look like? It should have been like this:

grafik

Can you provide the log file as requested in my previous reply, please?

3 Likes

Dear Ingo,
thanks ever so much for your help!

The file was too big so uploaded it on my drive for you: https://ecloud.global/s/J7nNKLEmje7W6na

Thanks again! I hope this can be fixed, as the phone is still dead… :wink:
Best, Anne

PS: In the beginning of the installation, the phone looked like that, but then the blue dots appeared and it went dead, black screen.

Ok, in the log I see that the bootloader was successfully unlocked.

As part of the unlock one has to confirm on the phone that the unlock is ok and then the phone reboots.

And if I understand the log correctly, after that the phone was detected in fastboot mode with bootloader status “unlocked: yes”.

All correct up until here.

The next step then would have done the flashing. It first starts with wiping the user data and that command failed because the phone was no longer in fastboot mode.

This is consistent with “but then the blue dots appeared” which sounds like the phone tried to boot into the normal system. Which IIRC doesn’t work when the bootloader got unlocked but no wipe/factory reset was performed.

Do you remember when/why the phone went out of fastboot mode? If I don’t misinterpret the log the phone was already in the right state but somehow didn’t stay there.

To get things working again: are you still able to get into fastboot mode?

Dear Ingo,

I don’t know when the phone went out of fast boot mode exactly.
Yesterday the phone was just dead, but when I plugged it in again right now, I was able to get into fastboot mode.

Shall I go through the installation process again with easy installer? And if so, is there any advice on what I should do differently?

Best, Anne

Yes, you could try again with the installer. It will be a little different this time because the phone doesn’t boot normally at the moment.
First is to get the phone into a state that it will be identified as FP3+ by the installer.

  1. start with the phone off
  2. press and hold the Power + Volume Up buttons until you see this screen
    image
  3. now (short) press Power + Volume Up again to see this screen
    image
  4. press Volume Down until the “Apply update from ADB” is highlighted like this
    image
  5. press Power to enter sideload mode (we don’t need the sideload functionality, but only here the install can detect the FP3+), it should look somewhat like this
    image

Now start the installer and just click next until the step where the FP3+ gets detected. The installation files should still be there so you don’t need to wait for the download.
Then the installer should ask you to reboot to fastboot/bootloader mode.
Press and hold Power + Volume Down untill you see this screen
image

The installer then should be able to pick up from there.

3 Likes

Dear Ingo! It worked, great! Thank you so much! I will donate next :slight_smile:
Have a great evening, greetings from Berlin! Anne

3 Likes

Glad there were no new problems!
Have fun with /e/ :slight_smile:

2 Likes

I’m so impressed by Ingo’s skills everytime I witness them :star_struck:

2 Likes