FP3 installation : stuck in fastboot mode

Hi everyone,

I’ve just tried installing /e/ on my Fairphone 3.
I followed these instructions

Everything went fine (i just had to put fastboot flash boot_a boot.img instead of fastboot flash boot boot.img because there was this error) until the very last step, when I entered

 fastboot flashing lock

the Fairphone rebooted and ended up on a screen saying :

Your device is corrupt. It can’t be trusted and will not boot.
Visit this link on another device : g.co/ABH

at this point, it was impossible to do anything, and the phone was just rebooting and showing this last thing. I tried to restart it, and now the only thing it’s doing is to boot in fastboot mode. I tried everything (‘Start’, ‘Restart bootloader’, ‘Recovery Mode’, ‘Power off’), it just keeps on coming to the fastboot mode screen.

I tried unlocking the bootloader to begin again the installation, but it’s showing an error after the line fastboot flash system system.img :

Writing 'system'     FAILED (remote: 'partition table doesn't exist') 

So now i’m kinda stuck with my Fairphone in fastboot mode.
What are your thoughts on this? How can I manage to properly install /e/ ?
It looks like there’s no partition on the phone anymore.

I tried this : https://support.fairphone.com/hc/en-us/articles/360043835931 (but with a Virtual Windows 10 machine since I only have a Macbook right now, so it didn’t work …) but my goal would be to install /e/, and not to finish up reinstalling Fairphone OS.

Thanks for your help,

What does fastboot getvar current-slot say now?

It says :

current-slot: INVALID
Finished. Total time: 0.006s 

I would suggest fastboot --set-active=a … since you flashed the slot A boot partition already.

Then try to flash the partitions again and append every partition with “_a” this time, just like you did with the boot partition. This will force slot A for the flashing.


Thanks a lot it’s working :slight_smile:



ihave the same problem FASTBOOT MODE is STOCK i have treid anything but notting works

please can you tell my what to do.

it say INVALD
and the nex step i do fastboot --set-active=a…
my computer says fastboot unknow option

what can i do?

What does fastboot --version say?

version eac51f2bb6a8-android

Internet says that’s ancient, so it would be no wonder if it doesn’t know some more recent options.

Make sure you use the current Android SDK Platform Tools.

i have download android sdk platform tools. and what must i do now?

Unzip the ZIP file to the folder you are operating in with the command line, then use the fastboot command there.

If you’re using Linux or macOS on the computer, you might want to add a ./ in front of it to make sure the command line uses the downloaded command instead of the older one (resulting in ./fastboot etc.).

i can not find are zip folder i yuse a microsoft computer

  1. You downloaded the ZIP file platform-tools_r31.0.3-windows.zip.

  2. You execute the fastboot command in a command line, the command line prompt shows you in which folder you are doing that. Usually it would be in C:\Users\yourusername, but depending on what you did until now, you could be in a different folder by now. Only you know or can see that (unless you post a screenshot).

Now you have to bring the two together. platform-tools_r31.0.3-windows.zip is a ZIP archive, its contents need to go into the folder your command line shows you.
Just right-click the file in Explorer, choose extract everything (or similar) and then use the assistant coming up to extract the contents to the folder your command line shows you.
Then try to execute fastboot --version again in the command line, it should say something different than before.

1 Like

i dont no more how to fix this.

Its in fastboot mode

can you help my i am not relly tecnichal but a step by step i think that whil help my

Thanks Greetings jdv

To get any further, the current task is still the same: Get a recent fastboot command to work on your computer. Did you do that?

hello thank yo that you will help my.
first i have remove a lot of rong downloads. so i whant to start fhres.

what must i do?
I have downloaded platform-tools_r31.0.3-v and this is in my folder downloads.
all thing taht i download go to this folder is that good?

my downloades go to a rong folder the download folder that is rong.

so where musth i instal the downloads? os c.and than?

It’s as good as any other folder as long as you know where it is.

Ok, let’s try it this way …

  • In Explorer, go to the downloaded platform-tools_r31.0.3-windows.zip and right-click it, then choose “Open with” and then “Windows-Explorer”.
    Explorer should show you a folder named platform-tools then.

  • Now copy this folder platform-tools to C: (just drag it there with the mouse).

  • Press Windows + R (as in Run)
    In the window that comes up then, just enter cmd and click OK. This will run cmd and open a command line.

  • On the command line execute cd c:\platform-tools
    The command line prompt should change to c:\platform-tools> then, and now the command line will operate in that folder.

  • Execute fastboot --version, what does it say?

1 Like