FP3: Latest Update 2020093076095 makes phone going to blackscreen / freeze

exactly - it does nothing.

oh, thats really great! was not aware about it. Will give it a try. Thank you very much.

Just some update. Yesterday I closed some open apps (slide them away). Suddenly all gets stuck and the FP3 said “System ui is not reacting”. After stopping it (the dialog had an option to do so) the FP3 was unusable. It is clear to me that if I stop “system ui” this happens.

It seems like that I am the only person who has problems with it :wink: Might depend on installed apps etc.

I try to roll back today via fastboot.

Hm, if I:

adb reboot bootloader

I got into fastboot mode.

If i then use
fastboot getvar current-slot, it says:
< waiting for any device >

Its a driver-issue -> Windows (https://developer.android.com/studio/run/win-usb)
Perhaps I should run this with a linux-distro not @windows :wink:

And another one.

fastboot getvar current slot

-> current-slot: b

fastboot --set-active=a

-> Slot a does not exist. supported slots are:
nothing standing here after this

btw. device state is locked, if this is relevant.

Sounds like an incompatible version of fastboot, go here https://developer.android.com/studio/releases/platform-tools download and try again.


Yes, same error message over here, current platform tools fixed it …

fastboot worked.

I was on current-slot: b

i did a:

and a:
fastboot reboot

Version @phone is still the same 20200930

Hm… it was worth a try.

Will it always boot form “A” Slot now?

Yes, until the next OTA update changes that … or you via fastboot, or the phone after several unsuccessful boot attempts on slot A.

I’m not sure why the same version would be on both slots. Did you confirm you’re on slot A now? Did you update manually perhaps?

If you were on slot A on an older version before, and then did an OTA update to the 20200930 version, then the 20200930 version couldn’t be on slot A, as the OTA updater shouldn’t be able to update the active slot.

fastboot still says that I am at current slow b. Do I have to write the change somehow?

I mean: After I do a

fastboot --set-active=a
Setting current slot to ‘a’ OKAY [ 0.020s]
Finished. Total time: 0.034s

Edit: Tried this again … now it says: Cant load Android system. You continue to get this message, factory data reset and erase a device.

Try Again,
Factory reset.

Now its getting some kind of a thriller. I like this very much lol :wink:

Factory resetting now… (make the FP3 clean (sorry I mean great) again… I should anyways have done this earlier) :wink:

Now I am at version 20200828.

I assume something does not work at my first try switching the slots.
Then there might be an compatibility issue between the versions, cause it does not boot? (possible?)

Now I start configuring the FP3 again. :wink:

Anyways learned some things about the phone -> 2 Slots.


PS: The FP3 is a great device. I bought it at release and it can cover all my needs. In combination with /e/ it is even better! Thanks for that!


And another update: Problems still persisting. Phone get stuck sometimes when a call comes in and I try to answer it. MicroG Services crash from time to time…

So it might be another issue and it seems like it has nothing to do with the latest update of /e/

I do not really know what went wrong with the last update but I can say that for me it works perfectly fine :slight_smile:. I never had any of the problems that were described in the forum (e.g. booting errors) and I also use a FP3…

I am unsure whether it was the update, as said, cause I rolled back to an earlier version yesterday and still have got issues. Might be hardware-related.

Yes but as we use the same device it seems also kind of strange … either you have a damaged hardware or maybe “something in the background” is configured wrongly

I am thinking in the direction of damaged hardware…

The good thing is it’s a FP3 so you can easily and also cheaply repair it, however it might be very hard to locate the damaged part …

If you happen to have Fairphone Angels with Fairphone 3 expertise and parts in your vicinity, you could ask them whether a parts swap to identify a hardware defect could be arranged.

Else reinstalling Fairphone OS, confirming the issue persists and contacting Fairphone support would be the way to go.

just reinstalled FP-OS and updated to the latest version. Doublechecking how FP3 is “doing” now.
I will come back to you with any news.

This is similar to what I had. I set the slot to ‘a’ and rebooted, the phone then bootlooped and told me to try again or to factory reset.

I set it back to ‘b’ and I’ll wait for the update that’s coming soon.

Wonder why the slot system didn’t work

I reverted back to stock a few days ago, as said. (Android 10 - latest FP Update). What I can say so far, that I did not have a single crash. Phone is working.

battery-usage is very high compared to /e/.

I am now wondering what caused the issues, cause I never had any problems with /e/ till the 2020093076095.

Why the switch to the version before also made issues after factory reset is some kind of strange to me?

At the moment I am unsatisfied with the stock-rom and would like to go backt to /e/, but will it be stable?