FP3+ no USB conection via fastboot, unlocking bootloader not possible

Hi all,
i allready told the problem in the german section, but as we found no solution to this special problem i would like to post it here in detail for the whole comunity again.

I recently got the new FP3+ and i would like to put /e/OS on it. I successful unlocked the bootloader following the instructions from the faiphone homepage.
I can use “adb reboot” to enter the fastboot mode. Then i´m stuck.

With the command “fastboot devices” the FP3+ is not found and i also can´t use “fastboot flashing unlock”.
I tried the easy installer and via adb with fastboot but the problem seems to be the conection fastboot <-> FP3+

Greetings Wogrim

You are using the fastboot command from the current Android SDK platform tools?

Hi AnotherElk,
i downloaded fastboot with the android studio yesterday, but to confirm i just tried the version from your post. It´s still not working.

What PC OS are you using?

Hi,
i´m using Win 10 Pro Built: 19041.vb_release.191206-1406

Install universal drivers look here

Then check in the device manager while phone is in fastboot mode, if you see a yellow triangele follow these steps:

Right mouse on this and choose update driver:
e-1

Choose let me pick…
b2bc0c081325ae31189fab92aae46d98063b797c

Select Android device:
e-3

Select Android ADB interface:
e-4

Click yes:
e-5

e-6

Check is device is not yellow triangled anymore:
e-7

Go do your fastboot thing and be happy :slight_smile:

6 Likes

I think I have to correct this (from the input of the earlier attempt in a German topic). What you did successfully is allowing to unlock the bootloader by entering the unlock code in the developer option on the stock ROM. That is not yet the actual unlocking.

2 Likes

Wow thanks andrelam. That was the problem.
Now fastboot is working. I havent continued yet but i hope now it should work.

Also thanks Ingo for the clarification with the bootloader.

edit:
The easy installer wasn´t working because the device had some issues with adb while running on android. But with the now really unlocked bootloader and working fastboot i flashed /e/OS. It is running now smoothly. Thanks again for your help.

Greetings Wogrim

3 Likes

Can you elaborate on that a bit, maybe in the other topic about the installer not working? Because I’m thinking it might show an opportunity to improve the installer.

I will send the log and explain the problem as good as possibl but i have no more time today. Probably tomorrow.
Greetings Wogrim

1 Like

I have the same problem on a new FP3+. The device is found on adb devices if its on, but not in the bootloader. Andrelam’s solution did not work for. I see the yellow triangle, but when I let Windows search for the driver in platform-tools it cannot be found. :frowning:

To avoid the popular adb/fastboot confusion … Please confirm fastboot devices doesn’t work for you with the phone in bootloader/Fastboot Mode.
(The adb command doesn’t work in Fastboot Mode by design, only the fastboot command does.)

I see that I read Andrelam’s guide wrong. I didnt use the option “Let me pick from a list of available drivers on my computer” but instead let Windows search for it in the “platform-tools” folders. I tried it again and now its working, even with the Easy Installer.

Thank you guys.

3 Likes

Hi,
I got to the point of updating the driver


but when I select the folder, I get this screen…
I installed universal ADB driver and Android Studio. Do you have an idea what am I missing?
Thanks in advance!

Hi soagnes,
did you try: “Let me pick from a list of available drivers on my computer”? This was the point where i could find the drivers.
Greetings Wogrim

3 Likes

This step is a bit unclear:
You have to click “Let me pick from…” I don’t know why i had the path highlighted at the moment of the screenshot, but that is a bit misleading.
e-2

2 Likes

Maybe to make it more clear replace your image with one where the correct option is highlighted?
b2bc0c081325ae31189fab92aae46d98063b797c

1 Like

[quote=“andrelam, post:16, topic:23351”]


i…» Je ne sais pas pourquoi j’ai mis le chemin en surbrillance au moment de la capture d’écran, mai
[/quote]

Hi, same problem : I still have this windows appearing saying the device can’t start…with a “code 10”.
Anyone know the problem?

Here is something that worked perfectly for me:

Hi,

When I do that, I cannot find the “Android Device” on the list. Neither a “SAMSUNG Android Phone” like it’s said here… I tried with “Mobile devices” but then I cannot find any ADB driver.
I did install the universal driver for Win10.

By any chance, would you have an idea ? It’s blocking my easy-install ^^’

EDIT : problem solved, the solution is here (TL;DR : FP on Fastboot, Windows update, optional updates, drivers updates, Android Composite ADB Interface)