FP3+ no USB conection via fastboot, unlocking bootloader not possible

Thank you very much for your reply.
I have tried to install “LeMobile - Other hardware - Android Composite ADB Interface” with Microsoft Update Catalog.
but :
1- I only got ‘Android Bootlader Interface’ and not ‘Android Composite ADB Interface’ (I don’t know if that matters)
2- Actually I tried to install " LeMobile Composite ADB Interface"; “Android ADB Interface”, “Android ADB Recovery Interface” and “Android Composite ADB Interface” but I got each time “'Android Bootlader Interface” in my ‘Device Manager’
→ the package has the same name each time “20957253_e729b520abd50003f26bdc147fcfb048082ad4bf.cab” (I don’t know if that means that it’s the same data)
3- The installation was running in an endless loop “Installation des pilotes” for 20 minutes
→ after a restart of my PC it did install the pilot smoothly in less than 5 seconds

I have restarted ‘easy-installer’, unfortunately my FP3 is still not recognized.

May I ask you to confirm that I use the good process when I do it?
-My FP3 is on page FASTBOOT MODE (SECURE BOOT = disabled ; DEVICE STATE = unlocked), with green START at the top (is this setup the correct one ?)
-on ‘easy-installer’ I’m on the page ‘Détection de l’appareil / A a recherche de votre appareil…’
→ and I wait… Should I do something else ?

As I said, I tried to install eOS last week. At the time my FP3 was detected and the installation started, and went to 100% (I guess). After 1h during which nothing happened I restarted my PC and FP3.
Actually I did it 2 times :
1- first time the FP3 restarted on Android standard, I had update the Android again, unlock for developper again, etc and I restarted the installation
2- second time : the FP3 restart on Fastboot mode only (no Android standard available). If i click for START, I get a screen saying :
“<!> The boot loader is unlocked and software integrity cannot be guaranteed. Any data stored on the device may be available to attackers. Do not store any sensitive data on the device.
Visit this link on another device: g+co/ABH
Then it loop with a restart every 10 sec, and land on the same page.

→ Do you know how to resolve this issue ?
Thank you very much for your help

Sorry, no knowledge about FP3+ here …

Some similar threads : FP3 installation : stuck in fastboot mode - #23 by JBdV, Device is corrupt, can't be trusted - FP3 - #9 by 7eries, Easy Installer failed - Fairphone 3 blocked on fastboot mode

Hello smu44,
I got a solution (in French) - I succeeded in installing eOS on my FP3. It works!

Please find a traduction in english:
1- download the latest version of eOS here You can use Q or R. R is the most recent and works well.

2- download platform-tools for windows here

3- Extract the file platform-tools zip downloaded, then open the resulting folder

4- Put the file eOS in the folder platform-tools and extract it (eOS) in this same folder.

5- in the folder platform-tools, click on button ‘Shift’ and right click, select “open Powershell window”

6- put your FP3 in fastboot mode and connect it to your PC with a USB-C cable that can transfer data. Then in the Powershell window, type ./adb devices , your FP3 should be listed (note : my FP3 was not listed but I followed the remaining instructions)

  1. Then, simply copy-paste the command line below in Powershell, one after the other (Caution, it will erase the data!)

Note, on Windows one need to use ./ at the beginning of each command line

./fastboot -w
 ./fastboot flash system_a system.img -S 522239K
 ./fastboot flash boot_a boot.img
 ./fastboot flash vendor_a vendor.img -S 522239K
 ./fastboot flash dtbo_a dtbo.img
 ./fastboot flash vbmeta_a vbmeta.img

 ./fastboot flash system_b system.img -S 522239K
 ./fastboot flash boot_b boot.img
 ./fastboot flash vendor_b vendor.img -S 522239K
 ./fastboot flash dtbo_b dtbo.img
 ./fastboot flash vbmeta_b vbmeta.img

 ./fastboot flashing lock

After the command ./fastboot flashing lock confirm on your FP3 that you want to lock your bootloader.

The FP3 restart and eOS should be correctly installed

1 Like

The solution in French : Easy-installer no longer recognise my FP3 - can't install 'Android ADB interface' or 'Android Composite ADB interface' - #2 by Bryophytae

1 Like

Bravo ! :clap:

Pour info tu peux revenir à l’interpréteur classique à partir de PowerShell, en tapant simplement cmd.exe :wink:

There’s either a typo or mistake in this step. When the phone is in fastboot mode, adb commands do not work (they only work in recovery or system mode). I guess you meant ./fastboot devices which would be correct.

1 Like

That was my mistake in the post I wrote in French, apologies. I will bring attention to this under my comment in French right away.

I would edit it if I could, thank you for explaining the correct command !