FP3 update gone wrong factory data reset

well… I don’t even have any apps anymore now…

OK, you can stay, but when running into issues, go back to 0.11

For others reading along later … No, you didn’t have to do that, at least not before trying to simply boot into the prior state of the OS on the other slot …

You can still try that now to get back to 0.11, but even if it works this will not bring back your Apps and data thanks to the factory reset.

1 Like

One doubt. I have 0.12 too. No problems till now. Should I wait to the update or if i dont downgrade ot will be impossible?


I just had this issue too, and I tried to switch to the other slot as @AnotherElk suggested in another post, but I encounter the same error message. With a different screen though:

  • for the slot containing the new version, /e/ seems to want to discourage people to go heads-on with factory reset, because they now have a custom screen with no reset option;
  • while for the other slot, I have a LineageOS recovery screen that still proposes to factory-reset.

How should I proceed since neither of my 2 slots work? Is it possible to describe the steps (I have adb and fastboot installed, but I don’t know any of the commands I should run to do something) to get it back working?
I saw in e/backlog#1920 that it can be due to an incorrect boot.img, so is it possible to replace it? (and how?) Or to get back to a previous version without factory-reset?
Please mention if the method proposed can lead to data-loss, and how I should proceed to back-it-up if it is the case.

Thank you.

@AnotherElk do you think this is what I should do? (Talking about the message I am replying to)

I think I have the same issue. After installing 0.12, my phone said “can’t load android system. Your data may be corrupt. If you continue to get this message, you may need to perform factory data reset and erase all user data”.

I have no clue what to do now. This is a huge disaster for me, since I really really really rely on my phone tomorrow.

Can I do anything to make it work again and not lose all my data?

Assuming you want to keep your data … I don’t know, I didn’t encounter this problem myself yet.
I did a few slot switches myself successfully already when testing stuff, but I’m not affected by this current version 0.12 trouble, I simply (and luckily) wasn’t quick enough to install that version before it got retracted.

I see you asked the developers over there directly. If you have the time to let them answer and possibly figure something out, I would say this is your best shot.

In case you left your bootloader unlocked (I know, who even does that?), you could fastboot boot the TWRP recovery and see whether it would still be able to backup your data partition and let you copy the Internal Storage via USB (TWRP doesn’t backup the Internal Storage, but it does MTP mode for a USB connection). Together with a fresh OS install there would be a chance for a successful restore.

You can try to boot into the state of the OS before the update, see here.
Apparently this doesn’t work in every case, I don’t know why, sorry.

Your phone can fail you at any most inconvenient time, regardless of you doing or not doing something like updates, it can simply break. Time for Plan B?

Try both slots, use the ‘start’ button to boot, try multiple times! I know this sounds crazy, but this method worked for a user i helped on the telegram support channel.

1 Like

I might be, yes. To be honest, I didn’t expect something like this to happen. I don’t want to blame anyone, but could this not have been prevented, as soon as you knew it doesn’t work, by taking down the update or sending around a email to warn people, so they don’t install it?

They did …

… Did you get notified just now that the update was there?
Did you buy your phone with /e/ pre-installed (= “stable” channel, getting updates later) or did you install /e/ yourself (= “dev” channel)?

I’m pretty certain the same question came up here before, but I can’t find it at the moment. It’s not like they did nothing, but according to Murphy’s Law they will of course somehow not use the one channel you expect them to use.

Yes I did, yesterday evening.

I tried to do it myself but couldn’t really, so a friend of mine basically did it. Which is why I am struggling with using the command tool, despite this instruction you send me (English is not my original language, I will try to find an instruction in German) .

Weird, I only installed it yesterday night at like 12:30 am

Uh sorry, that question wasn’t addressed to me, sorry, I only saw that now

Ok, since @16NoCo got it, too, that would mean they went ahead giving a supposedly fixed OTA update to a limited number of users, if I understand the current state of affairs here correctly … https://gitlab.e.foundation/e/backlog/-/issues/1920#note_64046 … but it would mean that the supposed fix isn’t a fix, that would be bad.

Yes it was, so all is fine, I only cited another post in which the retraction of the broken updates was confirmed. (Edited a bit now to make it clearer.)

Hi, I have the same problem, but I did the factory reset and spent 2 days restoring my FP3 to the old status. During the system updates I was shown three files: One file with 1.1 GB, two files with about 800 MB. The 1.1 GB file did not work, one of the other two files worked, but “shot down” my FP3. Please send an email to the community, in which you list the updates and the risks involved. This would probably make many users happy. Meanwhile I’m a bit annoyed, because Fairphone offers the FP3 with /e/ OS, but apparently I can only install the dev version on the FP myself (my FP3 was shipped with Android) and not the stable version. Since I’m not a tech freak, I rely on an OS working reasonably well when it is provided. What additionally annoys me: Fairphone sells a Camera+ module, but it doesn’t work with /e/ OS. Apparently I threw 60 EURO out of the window, because it doesn’t look like there is a corresponding update. Even the torch doesn’t work anymore… Despite all these annoying flaws I’m quite happy with /e/ OS.

This is the stable verion, but has a different signature so you cant just dirty flash it, would require data wipe again :frowning:

Fairphone don’t offer this.
The e foundation offers this, and they have a partnership with Fairphone.

Correct. But be aware that /e/ is Android, too.

“The e.Foundation has made available a developer version of its /e/ OS for Fairphone 3”
… yeah, sounds reliable. /e/ is still in beta state, so anything goes.

There isn’t … yet. They’re working on it.
And you get annoyed too easily :wink: .

1 Like

You are right: I should be more patient. But let’s face it: the whole digitalisation process has given us more work and not less - as is always claimed, isn’t it? But that is a different discussion… :wink:

I feel you, I am annoyed, too. Doesn’t mean that I blame anyone. The only thing I am not too happy about, to be honest, is that I could still download the update hours after they knew what this does. I really feel like someone could have informed us or just taken the update down again.

But I still love the idea of /e/, I just wished they would have far more funding and could finally build a OS which goes far beyond the beta version and is really reliable