FP3 update gone wrong factory data reset

Hi All,
Just FYI as it is done now… lost so many things… :frowning_face:
just had to do a factory data reset after installation of the latest update
“Can’t load Android system. You continue to get this message, factory data reset and erase a device.”

The update is now /e/OS0.12-2020093076095

How can I reinstall all the apps?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

pls forget 0.12 it’s broken and isn’t available any more. Pls flash 0.11 again

So I should remove 0.12 and install 0.11?

yes pls …

I don’t even remember how I did it…

fastboot flash system system.img
fastboot flash boot boot.img
fastboot flash vendor vendor.img
fastboot flash dtbo dtbo.img
fastboot flash product product.img
fastboot flash vbmeta vbmeta.im

I never thought I would have to do that again…

What If I keep 0.12… what would happen?

you can run into issues with several apps. I just have had 3 users which where running into issues weeks after installing 0.12

well… I don’t even have any apps anymore now…

OK, you can stay, but when running into issues, go back to 0.11

For others reading along later … No, you didn’t have to do that, at least not before trying to simply boot into the prior state of the OS on the other slot …

You can still try that now to get back to 0.11, but even if it works this will not bring back your Apps and data thanks to the factory reset.

1 Like

One doubt. I have 0.12 too. No problems till now. Should I wait to the update or if i dont downgrade ot will be impossible?


I just had this issue too, and I tried to switch to the other slot as @AnotherElk suggested in another post, but I encounter the same error message. With a different screen though:

  • for the slot containing the new version, /e/ seems to want to discourage people to go heads-on with factory reset, because they now have a custom screen with no reset option;
  • while for the other slot, I have a LineageOS recovery screen that still proposes to factory-reset.

How should I proceed since neither of my 2 slots work? Is it possible to describe the steps (I have adb and fastboot installed, but I don’t know any of the commands I should run to do something) to get it back working?
I saw in e/backlog#1920 that it can be due to an incorrect boot.img, so is it possible to replace it? (and how?) Or to get back to a previous version without factory-reset?
Please mention if the method proposed can lead to data-loss, and how I should proceed to back-it-up if it is the case.

Thank you.

@AnotherElk do you think this is what I should do? (Talking about the message I am replying to)

I think I have the same issue. After installing 0.12, my phone said “can’t load android system. Your data may be corrupt. If you continue to get this message, you may need to perform factory data reset and erase all user data”.

I have no clue what to do now. This is a huge disaster for me, since I really really really rely on my phone tomorrow.

Can I do anything to make it work again and not lose all my data?

Assuming you want to keep your data … I don’t know, I didn’t encounter this problem myself yet.
I did a few slot switches myself successfully already when testing stuff, but I’m not affected by this current version 0.12 trouble, I simply (and luckily) wasn’t quick enough to install that version before it got retracted.

I see you asked the developers over there directly. If you have the time to let them answer and possibly figure something out, I would say this is your best shot.

In case you left your bootloader unlocked (I know, who even does that?), you could fastboot boot the TWRP recovery and see whether it would still be able to backup your data partition and let you copy the Internal Storage via USB (TWRP doesn’t backup the Internal Storage, but it does MTP mode for a USB connection). Together with a fresh OS install there would be a chance for a successful restore.

You can try to boot into the state of the OS before the update, see here.
Apparently this doesn’t work in every case, I don’t know why, sorry.

Your phone can fail you at any most inconvenient time, regardless of you doing or not doing something like updates, it can simply break. Time for Plan B?

Try both slots, use the ‘start’ button to boot, try multiple times! I know this sounds crazy, but this method worked for a user i helped on the telegram support channel.

1 Like

I might be, yes. To be honest, I didn’t expect something like this to happen. I don’t want to blame anyone, but could this not have been prevented, as soon as you knew it doesn’t work, by taking down the update or sending around a email to warn people, so they don’t install it?

They did …

… Did you get notified just now that the update was there?
Did you buy your phone with /e/ pre-installed (= “stable” channel, getting updates later) or did you install /e/ yourself (= “dev” channel)?

I’m pretty certain the same question came up here before, but I can’t find it at the moment. It’s not like they did nothing, but according to Murphy’s Law they will of course somehow not use the one channel you expect them to use.