[FP3+] Upgrade to 1.5 with Android 11: Lost access to SD card data


Since I’ve upgraded to the latest 1.5 with Android 11 on my FP3, I’ve lost access to all of the data that was stored by applications configured to use external storage (SD card).

I know it’s a common issue with Android 11 but I don’t get the behavior that is expected.
I can have access to <sd card>/Android/data using a file manager with the right permissions, but I only get a list of files corresponding to each app instead of folders like before. Each file is 0B.

Even if I connect to a computer and browse from there, I can’t access the data like before, and I still get a list of files.

I can reconfigure my apps to store their files outside of Android folder in the SD card, but my main issue is that I’m unable to get my storage space back. It seems that there is indeed data present in Android/data, but I just can’t access it or delete it in any way to get some storage space back.

I’ve not seen this behavior in all posts I’ve read about Android 11 changes and workarounds of this problem.

Can somebody help?

Screenshot_20210213-205708_Permission controller

At first - I’m still using 1.4
After your post I’ve try to find some more information about this Android 11 problem/new security feature - As result:

Generally: Android 11 set all files in the data folders (intern and extern) to “hidden”, but if you connect the smartphone directly to an PC, you should see any file! Maybee set option " show hidden files" in your PC-filemanger.

If you have problems with apps, using the “android-data-space”:
Try to switch the permission setting (see screenshot) and/or (re-)grand the framework access.

This information are from the german Samsung Forum (I thing page 9): https://eu.community.samsung.com/t5/galaxy-s20-serie/zugriff-auf-sd-card-android-data-unter-android-11/td-p/2403871

Additional Information (for rooted devices):

Maybe we can get some support from our e-developers?? :wink:

Please let me know if you can fix the problem, in the other case I’ll never update my FP3 to eOS 1.5 :wink:

In my case the update from 1.4 to 1.5 (also Android from 10 to 11) did just create a lot of useless directories on the SD card. But all my data survived and are still unchanged on their old places. I deleted all the new directories because I will not use them for nothing. (OK, some resurrect later …)

Do you use also a FP3?

Me? Of course, FP3 (no +) from the shop, stable, OTA updated.

Thanks for your replies, it did not help solving this issue though.
In the end, accessing my SD card on my laptop via an adapter was the only way to see and access the “real folders”. I’ve managed to access my previous data this way.

For some reason, accessing via MTP (USB), is always just giving me a list of unreadable files, 0B in size, default timestamp…
Via all of the file manager apps I’ve tried, with full storage permissions, I get the same list of empty files, except with “Files by google” (how privileged…), that shows only a single Android/data/ folder: its own.

This is quite inconvenient and definitely not the expected behavior of Android 11, I hope this can get fixed in future eOS versions.

No matter which file explorer I use (Mixplore, TotalCommander, X-plore): They all have root access, file and media access permisson and permission to access the subfolders of Android on both internal storage and the SD card. Access on the internal storage works, but as described above on the SD card there are only 0 byte entries with the subfolder names. They cannot be accessed other than via mnt/pass_through/0/
Is there really no way to access these folders in the normal way with /e/OS-r?

They cannot be accessed other than via mnt/pass_through/0/

you mean there you can read the files? if so, that path is using FUSE - so if you don’t see 0-byte entries and can read them instead, the userspace (exfat) driver would handle a filesystem issue better than the kernel exfat driver

Sorry, I don’t know what FUSE is nor about the different drivers. I just found that workaround on the internet and it works here.