FP3 with E os-can't unlock bootloader

Hi, I have followed the directions from FP, but it never asks me to input the code, just asks me for my pin. I am not able to unlock the bootloader. I would like to switch back to the FP os, because the phone screen isn’t working properly-it randomly reacts as if it has been touched.
Any help would be appreciated. Thanks

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

It seems (in the Fairphone forum) the phone would need a working internet connection when trying to get the code. Could this be the issue here?
Is there any error message?

Warning : Keep in mind that unlocking the bootloader will delete the data on your phone, so make a backup first if necessary.

  1. Enable developper options in Settings > About phone > Build number, tap on it 7 times

  2. Go to Settings > System > Advanced > Developper options > OEM unlocking and enable it. This will require you to input your pin / code / pattern.

  3. Connect your FP3 with a USB-C cable to your computer, and enable USB debugging in the phone developper options. Authorize the connection to the computer in the popup that appears.

  4. Open a command window in your platform-tools directory, and check that your phone is detected with the command adb devices. If you are using Windows, adding ./ at the start your commands might be necessary for it to work. It would look like ./adb devices

  5. If your FP3 is on, use the command adb reboot bootloader to put it in fastboot mode. If it is off, another way is to press the power and volume - buttons

  6. Unlock the bootloader with the command fastboot flashing unlock. Now, when in Fastboot Mode, your phone should display in red on the last text line DEVICE STATE - unlocked.

You can now flash the original Fairphone OS. However, before you do this, may I suggest you try doing a clean flash of /e/ ? This might solve the problem, if it isn’t hardware-related.

1 Like

I appreciate all the help. I did already try using the “e installer” to do a clean install of “e”, as I really liked it. Now I need to prepare the phone to send to Fairphone. My original problem is the phone screen isn’t working correctly.

I have managed to unload the bootloader (though by using the e installer). My starting point now, is that I have an unlocked bootloader. I have tried repeatedly using the instructions to flash the FP OS (using the Linux instructions). I did get as far as after running the “sudo ./FP3_flashall” command I got the response “sh: 1: ./linux-x86/fastboot: not found”
Any suggestions are greatly appreciated.

I do not know much about this, but it looks as though fastboot is not installed. You can check this with dpkg -l |grep fastboot

Also make sure that the most recent versions of adb and mtp-tools are installed correctly.

If it turns out that fastboot is installed, then I do not know how to help you and hope someone can.

Alternatively, if it returns nothing, you can install it by first updating apt with sudo apt-get update and then sudo apt-get install android-tools-fastboot

Then I suppose you could right click on the fairphone OS folder and open it in a terminal window and try the commands (or their alternatives should they not work) mentioned on steps 5 and 6 of the Fairphone website instructions.

I hope it works, if it does not I am sure someone more knowledgeable will be able to help you :grinning_face_with_smiling_eyes:

Hi, Thanks for the suggestion. I tried all of it, but am not getting very far. I did stumble across a “how to” that talked about installing TWRP, and then reloading the fp os. I read the comments and it ended most recently with the FP how to, which i’ve walked through more times than I can count. I just tried the easy installer again, and now it isn’t finding my phone… It is a bit of a challenge. :wink:

Check out this reply and the replies that follow it. Although the situation is not identical, there is the same problem with sh: 1: ./linux-x86/fastboot: not found This reply by @Ingo_FP_Angel suggests to either extract or download everything again.

Thanks for the tip, that’s very helpful. I will try it out in the next couple days. I really appreciate your help.

1 Like

just try

sudo fastboot oem unlock

the code u obtain here => Bootloader Unlocking Code for Fairphone 3 - Fairphone