FP4 bricked after failed OTA update (1.17-s -> 1.19-t)

Hi all. I’ve been pretty happy with my FP4 and e/OS but recently I noticed that I haven’t received any updates since Nov 2023. So I investigated a bit and found that the -s line was replaced with the -t one, and regular OTA update won’t make the switch.

So this is what I did:

  • Donwload the OTA for 1.19-t (dev) from https://images.ecloud.global/dev/FP4/e-1.19.1-t-20240113373116-dev-FP4.zip. The old version I was on was 1.17-s (dev) as I recall.
  • Installed the OTA by rebooting to recovery, starting ADB sideload, sending the file via USB (on Windows 11).
  • Rebooted after the successful update (last log lines were something like “Step 1/2” and “Step 2/2”. Until this point I assumed everything went well…
  • The reboot process shows the “Fairphone” banner, blank screen, banner again, then the Fastboot menu with the following information:
SERIAL NUMBR - [redacted]
  • I noticed immediately that the Bootloader and Baseband version is empty. Not sure if this is normal, but probably not a good sign. Also it shows device state locked, but I didn’t think of that as a problem.
  • From this menu I can only select “Start”, which brings me back to this point after the power cycle (same as “Reboot bootloader”); or “Recovery mode”. The latter allows me to use ADB commands, but not much else.
  • I figured something went wrong with the update, so I tried rebooting in various ways a few times. But of no help, I only get Fastboot or Recovery/ADB.
  • Since the update seems to have failed, I now tried to sideload the original 1.17-s image that I got from the FP4 website. That gives me an error message in the log that the “downgrade” was denied. After this, I still only get Fastboot/Recovery.
  • Tried again (two times I think) to flash the 1.19-t image. At some point the Receovery menu said that I need to reboot first to install more updates (I don’t think this message showed up during the other sideloads before, but maybe I’m wrong). Still no change.
  • Did a “format data/factory reset.” No change. With that step I’m definitely sure that I lost all the data on my phone, welp.
  • Finally tried a shot at flashing the full system image with fastboot, but it complains about “Flashing is not allowed in Lock State”. I get similar errors when I try other commands like switching the boot slot.

Now I’m stuck at this point. Did I brick my device? I have no idea how this could have happened :frowning:

Thanks for any help/suggestions!

Hi, if I have understood correctly, then the build /dev/FP4/e-1.19.1 is probably faulty … read here

Thanks for the hint! I downloaded the 1.19.1-s (stable) OTA image and sideloaded it. That gave me some warnings about failed signature verification and system downgrade, but since I already wiped my data I just accepted these and went through with the update.

Reboot to recovery, then bootloader… I see the “e” animation now and the phone seems to boot fine. Wish I had tried this before factory reset (but maybe would’ve had to wipe phone anyway) … but well, at least its not hard-bricked.

I still would like to understand why the first OTA went through but then failed to boot. And with the system downgrade from stable to dev, would that have wiped the data too or not? From my understanding, a downgrade can result in data loss as well.