Galaxy A3 2017 (Treble) SM-A320FL

Après les premiers tests, les choses ne fonctionnent pas trop mal. Les bugs décelés:

  • pas de son lors des appels via bluetooth comme avec l’installation précédente
  • impossible de supprimer la barre de navigation au bas de l’écran, ce qui est vraiment dommage parce que cela fait perdre un part de l’affichage.
    Il reste encore à tester l’appareil photo et la caméra…


Si on peut supprimer la barre et utiliser les boutons physiques :

  • paramètres (settings)
  • Phh treble settings
  • Misc features
  • Force navigation bar desabled


Effectivement après un redémarrage la barre a disparu.
Et l’appareil photo fonctionne, ainsi que la caméra.

J’ai loué une voiture il y a peu et les appels en bluetooth fonctionnaient, pour ma part.

Pour la camera, la vidéo n’est plus fonctionnelle avec e-0.19-q et il faut régler le format d’image pour faire des photos non déformées (réglages par défaut beugués).

Mais il n’y a pas de support à espérer chez LOS pour notre processeur, hélas.


Bluetooth fonctionne en multimédia, mais pas en téléphonie. On entend le bip des touches sur le bluetooth, mais dès que la communication est établie, plus rien. Si quelqu’un sur le forum a une solution (ou une simple idée) je suis prêt à tester.
Il ne manque plus que cela pour que tout soit parfait (ou presque)

C’est bien dommage que plus personne ne porte d’intérêt aux téléphones avec un petit écran. Surtout avec une qualité d’affichage très bonne comme le A3. Si j’ai galéré pour installer /e/ sur cet c’est pour avoir un téléphone de cette taille et je n’en ai pas trouvé de supporté directement.

Je vous propose soit le Sony Xperia Z3 Compact, ou le Z5 Compact, qui bénéficient tous deux d’un support officiel.

Ou bien, le XZ1 Compact (lilac), qui est d’une taille similaire, mais plus récent, mais qui n’a qu’un support non officiel (Android Q, R s’avère difficile à construire).

Comparaison chez GSMArena:

(Merci à M. pour son aide à la traduction :slight_smile: )

And here’s the English version: How about the Sony Xperia Z3 Compact, ou le Z5 Compac which are both officially supported by /e/.

Or the XZ1 Compact (lilac), which is roughly the same size but more recent, but has only unofficial support (Android Q at the moment, R is proving tougher to build :frowning: )

And a comparison from GSMArena:

1 Like

Hi guys, if you could continue in English it would be much appreciated (as I won’t need to copy-paste to translate) :grinning: Merci

Apologies - I failed to spot the OP and much of the thread was in English. Saw a post in French and replied in French :slight_smile: . I’ve edited my post to add the English text too

1 Like

Hi everybody,
I thought that Z3C and Z5C were too old. About XZ1, the problem is a little bit le same as with A3 2017.
The problem that at this time there is no new compact phone

My Nokia with Windows was out of use. I read that Galaxy A3 was supported by /e. So I bought one (but a 2017) for less than 100€. It was a mistake because only 2016 ils supported.
Now I try to make it operate!

Well with the procedure I described my A3-2017(SM-A320FL) is working pretty well.The battery seems also to last longer compared to the original OS, the phone is fast, stable and considering you can find it used for 30/40€ I bought also a spare one just in case.

There are some behaviors/settings that I still have to understand (well same applies for the original OS), but all in all it is fine for everyday use.
One thing I don’t understand is why I can’t share files via Bluetooth, but it is not bothering me too much.

I really agree with it. For me the last problem to solve would be bluetooth calls.

hi! thanks very much for providing such detailed instructions :slight_smile:
How do you know if files downloaded on xda-developers forum can be trusted ? (i don’t know at all this website, that’s why I ask)
What would be the procedure to come back to the original Android OS if something does not work well during the procedure? In particular, do you have any advice concerning the data backup?

Disclaimer: I’m not an expert user, just someone who spent some time in trying to install eOS on the A3-2017. I just report my experience(s) which might not be the best one(s).

Well frankly speaking I just trust them. As far as I know xda-developers is a reliable source, but from there you just take a couple of scripts (usually only the re-partitioner) and if you want you can have a look to them as they are shell scripts.

For the back-up you can look here and here.

To restore the OEM OS you need to either have a back-up and/or download the right ROM for your device/ country and flash it via Odin. For example mine is the following: sammobile

I hope this helps, but I know Android world is not so straightforward and (at least for me) it is a new world. So take your time to research and read :wink: and maybe a second hand cheap phone to make some test.

1 Like

Thank you very much for the swift answer; as you suggest I’ll take some time to do my own research and make sure I control what I do :smile:

Just wanted to say that I decided to take the risk and install /e/ os on my (daily driver) A3 2017. Wish I did it earlier, everything works perfectly and the install process was ok for a tinkerer like me. I am a bit bothered by the “Bliss” launcher which is not usable in my opinion, but I guess this is tweakable (it is a shame that I can’t use Trebuchet as the default one for whatever reason, it is even preinstalled).
Anyway, thank you everyone for this thread, I couldn’t have done it without your help.

Hi, @Twisty

I like Bliss,

but you can try OpenLauncher or any other from F-droid

I tried almost all of them but I really prefer Trebuchet. It is just perfect for what I want it to do and as it is the default with lineage os it integrates very well with the rest of the system (top bar in particular). I ended up sticking with Bliss, but would definitely switch to Trebuchet if an update allows me to do so.
Back to the topic of this device in particular, the only thing that didn’t worked well was the encryption. When I try to enable it, it is stuck in a boot loop. I had to format data and use my backup to get it back working. I also tried with lineage os treble images (that I don’t use because I trust /e/ os more than unofficial lineage images) and it has the exact same behaviour. I don’t keep much sensitive data on my phone, but for the banking app I would prefer this option to be enabled. I don’t think it can be fixed but if anyone has advices on this I am all hears.

Small update: connecting the phone with the car audio system via Bluetooth I have been able to make a phone call via Whatsapp by doing as follows:

  • answered the call
  • went to the phone Bluetooth settings → tap on the paired car → disabled “Media audio”

Maybe this can work also for someone else.

Does anyone have issue with the video recorded with the built-in camera app? I noticed that the videos recorded can’t be correctly reproduced:only one frame is shown and the duration is way longer than the reality. The sound on the other hand is fine.