Galaxy S3 i9305 reboots by itself, please help

Hello everyone. I’ve installed /e/OS on my Galaxy S3 i9305, following this guides:

Did not root the device. I used Odin to flash TWRP to it, then installed /e/OS.
The problem is - after few minutes of inactivity, the phone restarts itself for some reason.
What could be the problem? Thank you in advance

There was also a patch available, that I did not flash, because the link for the patch is broken
Could this be a problem? The patch is for the sim card usage, I use the phone with no simcard right now and still, it keeps restarting itself.

Hi @LeviYi3 welcome to the /e/ forum.

I do remember this device coming up before, but I do not know it. In searching for help, please first look here Samsung - Galaxy S III (LTE / International) - i9305 - Documentation Suggestions

Then a more general search of the forum Search results for 'i9305' - /e/ community

Getting Started on /e/

I have tried to flash the stock rom, then flashing the patch, then flashing /e/OS.
Still, the problem persists, after a few minutes (maybe even 1 min.) the phone reboots by itself.
Should I try an older version of TWRP? Or maybe flash a lineageOS instead of the original one first? But I can’t find lineage for i9305 anywhere.

Info about i9305 | LineageOS Wiki

PS sorry, I misread or misunderstood you. The seems to have flashed without error after you flashed a stock ROM !

The patch just downloaded fine for me. One thought, when you do download it, I see it named system(sim_support).zip I would suggest you name it to remove “( )” – say in case the brackets might fail syntax idk.

There’s probably some important app on the phone that tries to do something after some time of inactivity and crashes doing so.

If you can connect the phone to a computer with a USB cable and turn on developer options on then you can start “adb logcat” on the computer and probably see in the output what crashes.

1 Like


I had (I still have but don’t use it anymore) also a Samsung Galaxy S3 LTE (GT-I9305) but I have never been able to use Lineage OS or /e/OS with it.
Each time I tried to install one of them, I lost IMEI number so the phone was unusable (IMEI was back when re-installing stock ROM).
I never found a way to have a usable install.