Galaxy S4 GTI9505 Problem to replace driver with zadiag.exe

I’m new here and English is not my native speech, so please excuse my mistakes.
I have an Samsung Galaxy S4 GTI9505 (Android 5.0.1). Developer options is activated, USB-Debugging too.
Threre is no OEM unlock-button in the list of the developer options.
So I tried to replace the driver with zadiag.exe without OEM unlock. I set into download mode and connected it ot my PC (Win 10).
The device was shown in the list as AMS8x60. Then I started to replace the driver. After a minute I received the message “Driver Installation failed” “System Policy has been modified to reject unsigned drivers”.
Who can help me with this problem?
Best regards

What do you mean wih “driver”?
Is he bootloader unlocked ? Whit locked bootloader, you won’t be able to do any changes on your phone

Hi Harvey 186,
thank you for replying. In the installation guide (e/documentation, point 5) ist discribed “install the drivers” (using zadiag.exe from the Drivers folder of the Heimdall suite). This process doesn’t work in my case.
In the description there is no mentioning of unlocking a bootloader?

Pls have a look here for ZAdig installation.

Regarding bootloader unlock. It seems that the OEM setup is enough on Samsung devices

Install the zadig driver is one thing.
After that, you need to use Heimdall or Odin to install TWRP by flashing the recovery partition of your ROM.
Then you need to use TWRP to install /e/OS by flashing the system partition of your ROM.

I don’t really know the windows process, my personnal expériences was with a linux PC

Yes, that’s right, but all step by step :wink:

Not all Samsung devices have an “OEM unlock button”. Especially the older Samsung devices up to S5 and S6. My GT-I9505 doesn’t have this option either. So simply ignore this point.

If you work with a WinPC I recommend the very user-friendly tool Odin3 instead of Heimdall. With it the wrong on /e/OS ROM becomes too easy. Read more …

Hi archje,
thank you for your asststance. I was successfull installing the e-ROM. It worked with Odin + TWRP. The instruction on the page is not very good and too complicated.
Best regards

I’m very pleased to hear that, @andykamp. Welcome to the /e/ club.