Galaxy Wear doesn´t work on my S7 with /e/ os

I use a Samsung Galaxy watch. When I try to connect with my smartphone, I can only use Galaxy Wear. But this app doesn´t work on my S7. There comes an notice, that my Os is manipulated and that Wear could not be used with it.
My S7 is rooted with Magisk. But to hide root doesn´t make a different.
Any idea, how to use Galax watch still with my S7? Or if a different setting has success?
Thanks for your ideas or tipps.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Android wear watches are needing original Goolag Play services. So no way to connect. Sorry :frowning:

Just try a standard /e/ OS ROM with microG (without rooting, without Magisk).

Currently, two /e/ OS ROMs are available:

It can’t do more than not work. This has been shown time and again in tests with banking apps that also rely on G°°gle Play services.

1 Like

this is a general error message because you are using an custom rom with microG and not a stock rom with original goolag services.

OK, thanks. I will try.

Edit: also without root/ magisk no chance to bring Galaxy Wear to run.

Pity. Samsung’s proprietary software also doesn’t allow the use of Samsung DeX with custom ROMs.

As I have written, it has to do with goolag play services. You can use what ever goolag play service free OS. You won’t be able to connect. I have tried thousand times. Than I have sold my watch and now using a Amazfit with WatchDroid on phone and everything is fine

The Wear OS thing has been a long open issue at the microG GitHub, since 2014 to the present. Not much progress though.

You mention Galaxy Wear (Wearable?) but don’t mention your watch model. Wear OS is a Google OS used on a wide variety of phones but a number of Samsung (Gear?) watches use the Linux-based Tizen. Or at least used to. Not sure if it’s still around.

Anyway, quick search shows the issue is common on custom or rooted ROMs. One thread concerning your issue seems to have a working solution on the first page. Give it a check and see if it works.

Galaxy Wearable App on Rooted Phone Help | Samsung Galaxy S9 -

I moved my ASUS ZenWatch over to AsteroidOS. Now usable after a Bluetooth issue I reported was fixed. Not too bad.

1 Like

I tried the solution with the “Magiskhide props config”. The Wear App starts. Also the linkage was possible. Wear needed long time to link successful to the watch, but it works. Great. Now I have no longer a S7, now I have a Google Pixel 3 :wink: Thank you very much for the tipp.

1 Like

good to know. Again something new learned :slight_smile:


I was curious also on this topic as I have a Samsung smartphone and a Galaxy Watch 3 as well as Buds Pro and read that the Samsung Wear App does not work with custom ROMs and checks if you have a Samung device - it works on non Samsung devices.
There is a solution using Magisk, however I don’t wanted to use this solution and try to edit build.prop using ADB instead.

Finally I was successful with this steps:
First you need to enable Developer Options and enable USB Debbuging as well as root access option using ADB in the Developer Options.
You also need to have ADB available on your OS (I used Mint Linux).

Then connect your smartphone with an USB Cable to you PC.

Check if your device is recognized: adb devices
Restart ADB as root: adb root
Download build.prop to your PC: adb pull /system/build.prop /home/YOURHOME
(adapt YOURHOME or use another directory to store the build.prop)
Now you can edit build.prop using your a text editor: change ro.product.brand“ and „ro.product.manufacturer“ from „samsung“ to e.g. „htc“
Upload build.prop to your device: adb push /home/YOURHOME/build.prop /system/build.prop
Fix permissions: adb shell chmod 644 /system/build.prop
Reboot your device: adb reboot

The Samsung Wear App should work now on your Samsung device :slight_smile:

I just got my Watch4 and wanted to connect it to my phone. /e/ 0.22 Samung Starlte S9.

The phones passes safetynet. I installed Samsung accessory service, and Galaxy Wearables.
I’ve hided root with Magisk zygist.
Samsung Wearable does start. It installs Galaxy watch4 manager. I can bluetooth connect.
But after that I set some permissions. But it hangs on the screen: “Ter beoordeling voor u” (“for your review”). I can only press Not agree/Agree. Agree does not work. Nothing happens. It keeps on this page. There is no information what to agree too. Just white/empty.
I read somewhere that it has something to do with googles terms of service.

I’ve set props to google phone pixel 6 pro.
I’ve also tried to systemize these samsung apps.
But the initialization process still hangs at this screen.

Does anyone recognize this? Is there a solution to bypass this screen?
I’m almost at the point of installing stock rom here :frowning:

did you try my solution? However I have a Galaxy Watch 3 with Tizen OS

Yes I did. But that helped for the first part. But then the process stops with an empty Google terms page.

Unfortunately I did not manage to get Samsung Wearable, Health, Wathch4, Health monitor, running on my S9 on /e/. I liked /e/ a lot, but wanted to use my new watch too. So finally I decided to remove /e/, install Stock, rooted with Magisk, hided some apps, and removed some bloatware. Now everything is working. But I hate this Vendor lock in.
Anyone who wants to know how I managed, see: link.