Getting SIM network unlock PIN request after installing E/OS

HI all. Have successfully installed e/os on a Galaxy S5. Recently upgrade to 1.3 with no issues. Apps seem to work. Tried installing my SIM card (Canadian carrier FIDO) but get a SIM network unlock pin request at after boot up. Have contacted previous carrier (Telus) and they have supplied the unlock code but it does not work. I have tried multiple times and searched online for answers but don’t seem to get anywhere. I have turned off privacy settings in case that is preventing connection. This SIM card works with my other Motorola phone which i bought unlocked. Would really like to use this as a regular phone. Any suggestions would be greatly appreciated.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

If you have not spent too much time setting up the phone you might consider doing a factory reset with the SIM on board.

Thanks for the reply! Does the factory reset mean i will have to redo the e/os install again or just delete any data and apps? I Contemplated that but was not sure what state that would leave the phone.

Good question! … but the phone is set back to /e/ but with no user data. So /e/ will be fine and your update to 1.3 will remain.

If you have synced your phone to ecloud / Murena, that is expected to be restored when you add your phone back to your account.

One more question. Is the procedure different for Factory Reset with e/os loaded instead of Samsung and carrier setups? Just not sure of the steps at this point. I know the standard is power, volume up and home to bring up the menu but not sure if that will be the same.

The method to reach recovery is unchanged, Volume up + Home + Power.

You will find the Recovery changed, either TWRP where Factory reset is found under Wipe, or an /e/ Recovery where the menu is smaller and hopefully Factory reset is fairly intuitive to find.

It is also found within the device at

Settings > System > Advanced > Reset options.

Thanks again for the help! I will give this a try and hopefully get over this hump.

Unfortunately the Factory Reset did not work. Still not accepting the carrier unlock pin. I am going to try Samsung support to see if they have any ideas.

Another way is in Developer Options (enable, if not already enabled, then find and tap the build number 7 times); choose “Advanced restart” to add the option to boot into recovery directly on your shutdown/restart menu.
(At least that’s how it is on my Sony.)

You did not unlock the device at all before you started with /e/ … I think?

You might try with other SIM cards, but I think that there is the possibility that the locking software is going to be part of the Samsung ecosystem which is not on the phone now.

My suggestion with the reset was just to allow you to make very definite contact with the SIM in the First start wizard – sorry to hear it didn’t work!

Unfortunately i did not try unlocking before i loaded the e software which in hindsight would have been the smart thing to do. I have had no response from Samsung so far. I will keep playing around with it to see if i can get it to work.
Thanks again for the suggestions!

I have experienced that, you must restore back to “Samsung Firmware” (stock OS) to be abble to unlock the SIM network capability with the code

It is easier using Odin (windows), but it is possible using Heimdall or Heimdall-frontend (linux, macos)

Hi all. Sorry for the late reply. I have had success with the samsung firmware and was able to unlock the device for my SIM card. Now i will reinstall eos and hopefully be on my way! Thanks again to everyone for the help!

Much appreciated!