Gigaset GS290 update from v0.16 to v0.17 without issues - /e/ (stable)

Hi all,

just in case you might hesitate to update from v0.16 to v0.17 (stable) on your beloved GS290 as well,
I can tell you it worked like charm on my device.

I updated via the update tile in settings and did not face any issues at the time of writing.

Was a bit surpriesed to have the weather app, hoped to get rid of it.

Phone, mail is working. Will see how roaming/calls abroad are doing in the near future. If I do not give any update here, then everything is fine.

Thank you very much to the developer, tester and project managment helping to make the update such a pleasure.


1 Like

Congrats Obdi!

This is really strange. Mine fails (Also via settings, German locale), described in detail here.

Does anybody have an idea, how I could delete the already downloaded 0.17 to trigger download anew?

Could you provide the exact version string, you got now?
I am on 0.16-20210422111920 and fail to install 0.17-20210615117215.
(June 15th, 0,94 GB)

Thanks, Marcel

Do not have a GS290 but this should work on it as well…

Settings >> Apps and notification >> App info >> Tap three dots menu top right >> Show system >>Updater >>Storage & cache >> Clear storage + Clear cache
Return to Main screen.
Now if you check in Updater the entries should have been removed. Refresh the updater and check again if any downloads are available.

1 Like

Thank you. Unfortunately this was not the cause of the problem.
Verification on update fails just as before. Should I file an issue on gitlab?

Yes pl raise an issue on gitlab

1 Like


Hi Marcel,

sorry to hear. I came from 0.16-20210422111920 (stable) and updated with the update function to 0.17-20210615117215 (stable).

Prior to 0.16 I had /e/ installations done with adb (and root etc.) and the known issues with the update. So I decided to use the easy installer. This worked fine for several GS290 devices on my side. So it is really strange why you end up here.

Thanks @Manoj for tagging the ticket.

Given that Easy Installer seems to be the primary path,
not via command line from Linux as I installed,
should I expect any action on this ticket at all?

I learnt from @obdi that it seems to make all the difference.
He installed via Easy Installer, his device is not in root mode and updates work.

I wonder, would it be possible to install once more using Easy Installer?
Is it possible at all, given that there is not Android 10 but /e/OS in Root Mode on the current device?

1 Like

Hey, I’m having the same trouble as you. I tried the workaround descriped in the closed topic on github, but it doesn’t work (the last guy could upgrade from 0.13 to 0.14 and then 0.16). Also, I tried installing the update via “adb sideload”, but it seems the build you can download on the site for the GS290 isn’t the right one. Can I get it anywhere else?
Trying to use easyinstaller doesn’t work either. The installer can’t find my device, because I can’t let my pc take controll of the usb connection. Sometimes the option even disappears on /e/. Should I try it in fastloader?

There is one more thing. In my command lines for the tried update I’m having the addition of
“E:public: 179_129 unsupported filesystem exfat” after “Verifying update package…”.

1 Like

Hi @Skilfing,

yes, the options all seem to have an issue.
Please comment on my gitlab ticket (see above).
I also referenced Alexandre Roux who worked on the old ticket, but he didn’t react, so far.
Probably we need some more cases to make it relevant enough to look into it.
It looks like a classical regression (error previously removed, popping up again).
I’ll wait for some guidance from /e/, as I have no intention to brick the phone.

Cheers, Marcel

1 Like

Hi @marcel.f as your bug report mentions TWRP, I thought I would link this in case you had not read it. Gigaset GS290, how to root and install ZIP files? - #32 by aibd

(Note, that walkthrough is for a rescue. When just experimenting with TWRP you would not be doing such a thorough wipe of data and internal storage without a good reason. TWRP also allows a backup, so this is good to checkout first, remembering you have an “experimental” TWRP)

1 Like

Hi @aibd,

I didn’t do anything with TWRP. That was just a sidenote, maybe confusing, sorry.
I am bit risk averse here :slight_smile:

I installed following the regular docu for installation via Linux command line tools.
Only twist was that I had to go to a specific version of fastboot tools (following docu),
not the latest. Works well, still unlocked, but I wonder, which path I will eventually take for updates.
And I was slightly surprised to see that the same problem has been there two releases before.

All immediate ideas to get to the easyInstaller track seem to be problematic.
Others struggled to go back to stock Android which seems to be a prerequisite.
So instead of risky experiments I hope that Alexandre Roux will check if this is a regression of the previous error and provide some guidance.

Thanks for answering.
Cheers, Marcel


Same here, just with windows. Getting the Version described in the docu was a hazzle, but I managed and istalled the OS as intended.

I would try to reinstall with the easyinstaller, but I can’t get it to work. Also I would manually install the update via adb, if I could get the right update for it.

1 Like

Hi @Skilfing welcome

it seems the build you can download on the site for the GS290 isn’t the right one. Can I get it anywhere else?

You would initially look for it here: Install /e/ on a Gigaset GS290 - “GS290”

Please can you define “the right one”?

You would need to check if you were on a stable or dev build, and perhaps check that you had not made a mistake with Different Build Types at any time in the past.

I would just point out that you are using a thread with “update without issues” in the title! Do feel free to reply in a new post with #support in the tags line. :slight_smile:

I downloaded the stable version for v0.17. The thing is, that this version is over 2 GB, but the downloaded update on the phone is only 1.4 GB. So if I am trying to apply the stable version via fastloader in adb mode while in root mode (or what’s it called) then I get the message, that the update image is the wrong one. So there must be a differnce between those.
When I rooted my phone from Android to /e/ I used the stable version 0.16, just like @marcel.f using the manual for it on the /e/ website.

Oh and btw I still get orange mode while booting the phone, don’t know if that’s normal.

1 Like

So to summarize the state of affairs on GS290 upgrades:

Hi Marcel, thank you for documenting this issue well.

A factory ROM is essential in order to have a relationship with GS290, I have twice requested from Gigaset such ROM, the more voices the better!

In the absense of such ROM, an idea from an amateur! :slight_smile:

Loosely, like this.

The ROM has been shown to have the ability to restore a GS290 in certain circumstances.

While some forum contributors and others seem to have used with SP Flash Tool and reported a bricked device.

I speculate there is some missing/or out of date vendor magic and it may be centred in the Vendor partition.

I would be interested to know is whether it would be workable to

diff a ROM clone from a known clean device or live system with the

particularly to diff the vendor partition area.

Supposing the vendor magic was found, would it then be possible to patch such diff, with a trustable tool?

I think the resolution is not a developer puzzle, but a clear top level discussion about mutual alignment.
There are enough good reasons for Gigaset to play nice with /e/, both from a brand perspective and simply to sell more devices. Once this contact is established, a straight top down order should provide the required tech pieces to resolve this without guessing or hacking.
Next step: escalation inside /e/ org to create awareness and make this happen.

P.S. I don’t think /e/ sells GS290 phones without any agreement whatsoever.
/e/ is a sales channel for Gigaset and both sides should act accordingly.

Cheers, Marcel

1 Like

In the request of a factory ROM, which we agree is essential, the voice of actual Gigaset customers will be a good addition to any action by /e/.

This is from Gigaset’s response to me

at the moment that is not possible, but we will forward your feedback to our developers.

Perhaps such tickets should be copied to too :slight_smile:

You are right, I should/will do it, and the others that reported on here and on gitlab should, too.
Technically, as I customer I do not want to get a factory ROM from Gigaset, directly.
I understand that this requires contracts and is sth you do B2B not B2C. But still - all those little annoyances will eventually bubble up.

1 Like