Google Assistant listed in /e/ System Apps

Hi Petefoth

Version I am using is e-0.18-r-20210831132813-dev-beryllium
Really happy with it, like LinageOS but has some very nice extras.

Hey Chrisrg…
Did you do a wipe or format in fastboot? Saw a list of partitions that are supposed to be formatted, was not certain my poco f1 had the same partitions so did not want to chance it…
After several more hours trying everything in twrp, the files are still there so am now willing to try formatting, if I can find that link again… Failing that, got a big hammer…

Just found this;

3rd and 4th line down.
When I look at the google assistant apps, the first one shows at the bottom of the screen under ‘advanced’;
Version 11

The second one shows;
Version 11

Not 100% sure how to use those lines, but they look to be adb commands… Any idea anyone?

Just a wipe.

That is the package name of the app. The text in front of the package name is the command to uninstall; but slightly different to what I use because it has the additional -k argument (if that’s the right term) which is for ‘keep the data and cache directories’.

See here for more info:

For more info on adb commands enter adb help in terminal on linux ubuntu (in my case).

Thanks chrisrg…

Tried that, with the -k, and without… Always the same result, the apps are still there, although now it says;
‘not installed for this user’
but they are still there, and the network access and battery usage is switched back on again for both apps after a reboot.

Still not found a solution… Have removed viruses from systems more easily than these…!
Am also using linux ubuntu terminal…

but they are still there,

This would be expected for this deep running app (which I agree should surely not be there). Just to explain what you are seeing, the command

pm uninstall -k --user 0

does only uninstall for --user 0 (that is you!).

It is still there and it is not a root uninstall. So the system can can on using it, (while you cannot!)

On my Android 11 device (not /e/), those Google Assistant apps are located in the /product partition.

“OK Google enrollment”, “T Google enrollment”, and “X Google enrollment” are present on my Essential PH1 mata running /e/OS 0.11 Pie. Located under /system.

No trackers and data usage is 0.

My FireHound Oreo (LOS-based) has the same three. The Nougat ROMs do not.
I wonder if these files are largely inert or non-functioning without Google Play Services, et al.
I don’t know.

1 Like

And no battery usage either. So nothing to be concerned about but still it would be better if they weren’t on the device at all.

1 Like