Google Assistant listed in /e/ System Apps

Installed /e/ on my OP 7T a few days ago. Just noticed today when looking at the list of System Apps that Google Assistant is listed twice. Why is that even there since /e/ is totally de-googled? Can I remove it?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Did you wipe your phone before flashing /e/? If not, some prgrams from the stock ROM can still e present

G is referenced a few times on /e/, which I thought was a bit weird too. Like in the /e/ browser there is the option to use g as the DNS provider… :thinking:

Yes, I followed the install instructions exactly step by step. Can you or someone else check their system settings → apps and notifications - → show all apps → show system (from the … menu) and look to see if Google Assistant is listed?

Not found in 0.19-q-20211027142973-dev-a3xelte

Interesting. I wonder if it’s only occurring on Android 11. I have 0.19-r on my phone. I looked up the two Google Assistant apps I have on my phone, and, and found out these occur in Android 11. Did the eOS developers miss this?? Can /e/ support comment on this?

Here e-0.18-r-20210814-UNOFFICIAL-serranoltexx : no gogol app

i think it is device specific

I appreciate the screenshots provided. Could it be due to version 0.19? I have not installed any google apps but could a non-google app installed these mysterious google assistant system apps? I have Microsoft apps installed but I don’t see why a Microsoft app would install a google assistant system app. Can someone with /e/ r 0.19 confirm if they have the google assistant system apps? @Manoj can you add your thoughts on this?

Yes, I have checked, using 0.19-r, two g-assistant system app present!

Interesting your g-assistant apps look different than mine. Here is what mine looks like. I’m curious if those are present on a fresh install of /e/ 0.19-r. If an /e/ support person does not reply I may do a restore on my phone to verify. Again, is a third party app installing those or does 0.19-r have it already installed?

I did fresh install, but still it’s there.
let me freshly install the os again, and then will reply

1 Like

The plot thickens. I checked my phone’s folders and files from my PC and found a “” folder in the Android\data folder. I also did a Seedvault Backup and checked the “.SeedVaultAndroidBackup” folder and found there is a “” GMS file. So it’s likely that GMS file is hidden in my phone’s Android\data\ folder.
@safikul It will be interesting to see what you find when you do the fresh install of /e/.

all /e/ devices have microG implemented in system apps to tell to mainstream apps that gogol services are installed even it is not the truth.
microG need this fake GMS package

Can we get /e/ support to confirm that these two apps and GMS file are fake and not real? I’m concerned because of all the possible google files that microG fakes these are the only ones that have the actual google name in them. Therefore are they really fake? As mentioned by others /e/ q and r-.018 do not have these google files. Why does /e/ r-0.19 have them? MicroG is able to fake all the google files without having to actually use google in the file and folder names.

they probably are real, only microG package is a fake GMS

no just mainsteam apps that need to be rassured

don’t think so, it is probably not due to e-0.19-r, but to your device model portage to lineageOS (they don’t care about gogol)

but yes, e-team have to check that, someone must open an issue on Gitlab for that !

1 Like

Pl open an issue in gitlab sharing the details of the device on which it was noticed. We had a similar issue raised on a Samsung s8 dreamlte. The person raising the issue marked it as confidential, so it might not be accessible to other users. This issue seems to be device specific and was closed for the s8. The developers had mentioned that these are proprietary files extracted from the original ROM just like other vendor specific files and is device specific and will not show up on other devices. All the same, you can raise an issue and share device details so that the developers can check if it can be removed from the OnePlus 7T

1 Like

I had a look on my Essential PH_1 (mata) to find I have three google system apps.

The os version is 0.19-r-20211030143465-dev-mata, which is a test build from the last R testing cycle.

EDIT: I also find same apps under e OS-q on the same device.

I have a POCO f1, been using Linage OS until I found those google assistant packages in apps/system. Tried everything to get rid of them. So tried a ported version of CalyxOS, they were still there…!
Now I have E Foundation (very nice rom guys), and they are still there…!! Have tried every wipe I could using TRWP, they will not go away. If I ‘force stop’ they reactivate after a while, they are like a virus.
I did find one suggestion online that stated that only a full partition format using fastboot would clean the system, looked too much like neurosurgery to me, did not want to risk it…
Anything that someone can come up with I will try, if I cant have a de-googled phone, I will go without a phone…

Which /e/ and Android version have you installed? (Details in Settings | System Updates)

My mata is mostly used for testing at the moment and I’m interested to try and get rid of these google apps, so in fastboot I erased system on both slots then reinstalled e with complete wipe in e-recovery first. No difference, the apps are still there.

Uninstalling the apps with adb is possible but they are not removed off the phone this way and can be easily reinstated later. Not a solution and the problem does seem to be device specific, as suggested above.