Google Pixel 4 XL cannot receive SMS but sends sms and calls fine

I just got /e/OS set up today and have begun to test things, I immediately ran into an issue with the default Messaging app not being able to receive messages from other android or iphones. I have tried multiple other messaging apps, and have experienced the same issue. I’m not quite sure where to start with fixing/diagnosing. If anyone would be so kind as to point me in the proper direction I would be greatly appreciative! Thank you in advance!

It seems very unusual that you get this “mix” of success and fail. It is you carrier (SIM card operator) who is responsible for this traffic. Your phone will have a comprehensive number of preinstalled Access Point Names, but with evolving technology carriers may (infrequently) change the APN.

The APN on the device are found at Settings > Network and Internet > Mobile network > Advanced > Access point names

  • You can try to compare your installed APN with those published by the carrier.
  • Easier is to contact your carrier, report the problem and ask the to send the APN to the device.

The hashtag for this issue on the forum is #apn this will link you to other threads on the subject.

Thank you for your response!

I agree, this is extremely unusual; I have discovered I am able to get texts from auto-texting services like when you sign into an app and it needs to send you a code but I’m still unable to receive any other texts (from family/friends/etc).

The APN on my device is the same as my carriers, so I’m not quite sure that’s the issue I’m facing. This is extremely odd.

Odd that you say this happens with Message and other apps.

You might try Settings > Apps and notifications > See all … apps > Message > Permissions.

I have no permissions denied, I guess that is default.

Try deny permission to SMS. Perhaps even restart ?
Now allow SMS permission again.

It has come up on the forum before


call star#star#4636#star#star in dialer
then go to phone info
adjust setting so that both voice and data are active
by chance… who is your service provider?

Thank you again for your response, I tried both your suggestion and the one at the other forum post, neither reaped any results. Very confusing. :frowning:

Voice and Data are active, my service provider is T-mobile.

This issue has fixed itself randomly today, no idea what happened to fix it. Thank you to @aibd and @Tech-e1 for helping!

This topic was automatically closed after 179 days. New replies are no longer allowed.